Cisco работа с STP

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 17:50:32

Имею такую схему
Изображение

Как только настраиваю транки на каталистах лампочка оранжевого цвета сигнализирующая какой порт блокируется, начинает гореть зеленым цветом, на рисунке я указал на него. (Данное на реальных железках и в Cisco Packet Tracer)
При этом на железяках в консоли показывает что все нормально и нужный порт блокируется, ниже выводы.

SW0 (3560)

Код: Выделить всё

sw3560_1#sh spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    24577
             Address     0022.56c3.2b00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24577  (priority 24576 sys-id-ext 1)
             Address     0022.56c3.2b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/20              Desg FWD 19        128.22   P2p
Fa0/22              Desg FWD 19        128.24   P2p

Код: Выделить всё

sw3560_1#sh spanning-tree vlan 2

VLAN0002
  Spanning tree enabled protocol rstp
  Root ID    Priority    24578
             Address     0022.56c3.2b00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24578  (priority 24576 sys-id-ext 2)
             Address     0022.56c3.2b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/20              Desg FWD 19        128.22   P2p
Fa0/22              Desg FWD 19        128.24   P2p

Код: Выделить всё

sw3560_1#sh spanning-tree vlan 3

VLAN0003
  Spanning tree enabled protocol rstp
  Root ID    Priority    24579
             Address     0022.56c3.2b00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24579  (priority 24576 sys-id-ext 3)
             Address     0022.56c3.2b00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/20              Desg FWD 19        128.22   P2p
Fa0/22              Desg FWD 19        128.24   P2p
SW0 (2960)

Код: Выделить всё

Switch>sh spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    24577
             Address     0022.56c3.2b00
             Cost        19
             Port        25 (GigabitEthernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     5c50.15ad.8200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Root FWD 19        128.25   P2p
Gi0/2               Desg FWD 4         128.26   P2p

Код: Выделить всё

Switch>sh spanning-tree vlan 2

VLAN0002
  Spanning tree enabled protocol rstp
  Root ID    Priority    24578
             Address     0022.56c3.2b00
             Cost        19
             Port        25 (GigabitEthernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32770  (priority 32768 sys-id-ext 2)
             Address     5c50.15ad.8200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1               Desg FWD 19        128.1    P2p
Gi0/1               Root FWD 19        128.25   P2p
Gi0/2               Desg FWD 4         128.26   P2p

Код: Выделить всё

Switch>sh spanning-tree vlan 3

VLAN0003
  Spanning tree enabled protocol rstp
  Root ID    Priority    24579
             Address     0022.56c3.2b00
             Cost        19
             Port        25 (GigabitEthernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32771  (priority 32768 sys-id-ext 3)
             Address     5c50.15ad.8200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Root FWD 19        128.25   P2p
Gi0/2               Desg FWD 4         128.26   P2p
SW1 (2960)

Код: Выделить всё

Switch>sh spanning-tree vlan 1

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    24577
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p

Код: Выделить всё

Switch>sh spanning-tree vlan 2

VLAN0002
  Spanning tree enabled protocol rstp
  Root ID    Priority    24578
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32770  (priority 32768 sys-id-ext 2)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p

Код: Выделить всё

Switch>sh spanning-tree vlan 3

VLAN0003
  Spanning tree enabled protocol rstp
  Root ID    Priority    24579
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32771  (priority 32768 sys-id-ext 3)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1               Desg FWD 19        128.1    P2p
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p

Код: Выделить всё

Конфигурация SW0 (3560):
sw3560_1(config)#spanning-tree vlan 1,2,3 root primary
sw3560_1(config)#ip routing
sw3560_1(config-vlan)#vlan 2
sw3560_1(config-vlan)#name VLAN2
sw3560_1(config-vlan)#vlan 3
sw3560_1(config-vlan)#name VLAN3
sw3560_1(config-vlan)#exit

sw3560_1(config)#interface fa0/20
sw3560_1(config-if)#switchport trunk encapsulation dot1q
sw3560_1(config-if)#switchport mode trunk
sw3560_1(config-if)#switchport trunk allowed vlan 1,2,3
sw3560_1(config-if)#exit
sw3560_1(config)#interface fa0/22
sw3560_1(config-if)#switchport trunk encapsulation dot1q
sw3560_1(config-if)#switchport mode trunk
sw3560_1(config-if)#switchport trunk allowed vlan 1,2,3
sw3560_1(config-if)#exit

sw3560_1(config-if)#interface vlan2
sw3560_1(config-if)#ip address 10.0.2.1 255.255.255.0
sw3560_1(config-if)#interface vlan3
sw3560_1(config-if)#ip address 10.0.3.1 255.255.255.0
sw3560_1(config-if)#exit

sw3560_1(config)#ip dhcp excluded-address 10.0.2.1
sw3560_1(config)#ip dhcp excluded-address 10.0.3.1

sw3560_1(dhcp-config)#exit
sw3560_1(config)#ip dhcp pool VLAN2
sw3560_1(dhcp-config)#network 10.0.2.0 255.255.255.0
sw3560_1(dhcp-config)#default-router 10.0.2.1
sw3560_1(dhcp-config)#exit
sw3560_1(config)#ip dhcp pool VLAN3
sw3560_1(dhcp-config)#network 10.0.3.0 255.255.255.0
sw3560_1(dhcp-config)#default-router 10.0.3.1
sw3560_1(config)#spanning-tree mode rapid-pvst

Код: Выделить всё

Конфигурация SW0 (2960):

Switch(config-vlan)#vlan 2
Switch(config-vlan)#name VLAN2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#name VLAN3
Switch(config-vlan)#exit

Switch(config)#interface fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit

Switch(config)#interface gi0/1
Switch(config)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 1,2,3
Switch(config-if)#exit

Switch(config)#interface gi0/2
Switch(config)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 1,2,3
Switch(config-if)#exit
Switch(config)#spanning-tree mode rapid-pvst

Код: Выделить всё

Конфигурация SW1 (2960):
Switch(config-vlan)#vlan 2
Switch(config-vlan)#name VLAN2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#name VLAN3
Switch(config-vlan)#exit

Switch(config)#interface fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit

Switch(config)#interface gi0/1
Switch(config)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 1,2,3
Switch(config-if)#exit

Switch(config)#interface gi0/2
Switch(config)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 1,2,3
Switch(config-if)#exit
Switch(config)#spanning-tree mode rapid-pvst

Может быть кто нибудь встречал такое поведение ?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 17:56:47

Данная проблема как в Cisco Packet Tracer так и на настоящих железяках.

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение lap » 2012-06-18 18:00:09

ты про это:

Код: Выделить всё

[Amber]
Port is blocked by Spanning Tree Protocol (STP) and is not forwarding data.
After a port is reconfigured, the port LED can remain amber for up to 30 seconds as STP searches the switch for possible loops. 
Не сломалось - не чини.

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 18:07:55

Еще раз. На SW1 (2960) порт блокируется и работает, вот лампочка не сигнализирует о том что порт блокируется.

Код: Выделить всё

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 18:09:58

lap писал(а):ты про это:

Код: Выделить всё

[Amber]
Port is blocked by Spanning Tree Protocol (STP) and is not forwarding data.
After a port is reconfigured, the port LED can remain amber for up to 30 seconds as STP searches the switch for possible loops. 
Почти =)

STP отрабатывает нормально, порты блокируются, но лампочка не сигнализирует оранжевым цветом что порт блокирован, до настройки на портах транк лампочка оранжевым цветом отображала какой порт блокируется

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение lap » 2012-06-18 18:21:32

может таки оно имеет ввиду что на транке не весь порт заблокирован а только некоторые вланы на нем?
Не сломалось - не чини.

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 18:43:05

lap писал(а):может таки оно имеет ввиду что на транке не весь порт заблокирован а только некоторые вланы на нем?
Неа, вот именно старанно что все VLAN заблокированы.

Код: Выделить всё

Switch>sh spanning-tree

VLAN0001
  Spanning tree enabled protocol rstp
  Root ID    Priority    24577
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p



VLAN0002
  Spanning tree enabled protocol rstp
  Root ID    Priority    24578
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32770  (priority 32768 sys-id-ext 2)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p



VLAN0003
  Spanning tree enabled protocol rstp
  Root ID    Priority    24579
             Address     0022.56c3.2b00
             Cost        19
             Port        26 (GigabitEthernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32771  (priority 32768 sys-id-ext 3)
             Address     c8f9.f977.9000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1               Desg FWD 19        128.1    P2p
Gi0/1               Altn BLK 4         128.25   P2p
Gi0/2               Root FWD 19        128.26   P2p

Код: Выделить всё

Fa0/1               Desg FWD 19        128.1    P2p
Сюда воткнут Ноутбук
Настройки порта

Код: Выделить всё

Switch(config)#interface fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение lap » 2012-06-18 20:19:08

ему пофик, ибо он считает что заблокировано несколько вланов в этом порту а не весь порт.

и на "клиентских" портах имеет смысл дорисовывать " spanning-tree portfast", чтоб все дерево не перестраивалось.
Не сломалось - не чини.

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 21:09:10

lap писал(а):ему пофик, ибо он считает что заблокировано несколько вланов в этом порту а не весь порт.

и на "клиентских" портах имеет смысл дорисовывать " spanning-tree portfast", чтоб все дерево не перестраивалось.
а разве spanning-tree portfast не увеличит нагрузку на каталисте?
при его включении, уведомление даже какое-то пишется.

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение lap » 2012-06-18 21:36:14

он пишет что его оочень не рекомендуется включать на портах в сторону других комутаторов бриджей и прочее л2-шное барахло. и что состояние этого порта пофиг на все остальное дерево.

просто если у тебя будет порт с "клиентом" будет падать/вставать, то у тебя будет производиться пересчет всего дерева и никакие пакетики никуда ходить по этому влану не будут (в случае рстп - 15 секунд, если просто стп - то, по-моему, 45).

А пишет он следующее:

Код: Выделить всё

sw-10.msk(config-if)#spanning-tree portfast 
%Warning: portfast enabled on FastEthernet0/1.
 Usually portfast should be enabled on ports connected to a single host.
 When portfast is enabled, connecting hubs, concentrators, switches, bridges,
 etc. to this interface may cause temporary spanning tree loops.
 Use with CAUTION.
Не сломалось - не чини.

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-18 22:39:57

А как на счет шторма и колец? Нормально или нет?

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение lap » 2012-06-18 23:10:45

Шторм и кольца это плохо. Или ты про что?
Не сломалось - не чини.

Аватара пользователя
Cancer
Гл. Кастратор
Сообщения: 1269
Зарегистрирован: 2008-03-25 12:21:36
Откуда: г. Ростов-на-Дону
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение Cancer » 2012-06-19 16:20:36

lap писал(а):Шторм и кольца это плохо. Или ты про что?
если включить spanning-tree portfast не будет проблем с кольцом и штормом ?

GhOsT_MZ
лейтенант
Сообщения: 662
Зарегистрирован: 2011-04-25 11:40:35
Контактная информация:

Re: Cisco работа с STP

Непрочитанное сообщение GhOsT_MZ » 2012-06-19 16:36:19

С кольцом будут проблемы, если использовать портфаст на транке между двумя коммутаторами, это и в доках написано. Для транка используется spanning-tree portfast trunk, только вот это вроде как для оконечного пользовательского оборудования, если оно подключено транком, но никак не для транка между коммутаторами