cisco VRF + BGP

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-10 13:42:42

vrf.JPG
vrf-bgp
Короче решил заморочиться задачей. так сказать для саморазвития.
не получается передать через bgp маршруты которые в vrf.
при команде sh ip vpn4 all
далал пр этой статье http://www.opennet.ru/docs/RUS/mpls/testbed1.html
что не правильно делаю?
Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-10 15:01:26

тыб показал че уже наконфигурял ;)

а вообще - у тебя мплс завелся? мп-бгп поднялось? редистрибут того что надо в бгп внутри врф-а есть?
Не сломалось - не чини.

Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

Re: cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-10 20:16:49

Код: Выделить всё

hostname R1
ip vrf bank
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
ip cef
interface Loopback1
 ip address 10.200.1.1 255.255.255.255
interface GigabitEthernet0/0
 ip address 95.50.110.1 255.255.255.252
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
interface GigabitEthernet1/0.350
 encapsulation dot1Q 350
 ip vrf forwarding bank
 ip address 192.168.1.1 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 10.200.1.1 0.0.0.0 area 1
 network 95.50.110.0 0.0.0.3 area 1
!
router bgp 1
 no synchronization
 bgp router-id 10.200.1.1
 bgp log-neighbor-changes
 neighbor 10.200.1.2 remote-as 1
 neighbor 10.200.1.2 update-source Loopback1
 no auto-summary
 !
 address-family vpnv4
 neighbor 10.200.1.2 activate
 neighbor 10.200.1.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf bank
 no auto-summary
 no synchronization
 exit-address-family
!

Код: Выделить всё

ip vrf bank
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
ip cef
interface Loopback1
 ip address 10.200.1.2 255.255.255.255
interface GigabitEthernet0/0
 ip address 95.50.110.2 255.255.255.252
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
!
!
interface GigabitEthernet1/0.500
 encapsulation dot1Q 500
 ip vrf forwarding bank
 ip address 192.168.157.1 255.255.255.0
!
!
router ospf 1
 log-adjacency-changes
 network 10.200.1.2 0.0.0.0 area 1
 network 95.50.110.0 0.0.0.3 area 1
!
router bgp 1
 no synchronization
 bgp router-id 10.200.1.2
 bgp log-neighbor-changes
 neighbor 10.200.1.1 remote-as 1
 neighbor 10.200.1.1 update-source Loopback1
 no auto-summary
 !
!
 address-family ipv4 vrf bank
 no auto-summary
 no synchronization
 exit-address-family
!

при выводе ничего нет

Код: Выделить всё


Router#sh ip bgp vpnv4 all

Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-11 9:57:47

1) Посмотрите повнимательнее как там бгп настроено (кусок про адрес-фамили впнв4 и прочими сенд екстендед коммунити )
2) нет мплсных команд на п2п интерфейсе между роутерами (tag-switching ip или в новых софтах mpls ip)
3) в куске с " address-family ipv4 vrf bank" нужно добавить редистрибут конектед, если планируются статические маршруты, то соответственно редистрибьют статик
Не сломалось - не чини.

Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

Re: cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-11 10:20:23

Можно не скромный вопрос. есть address-family ipv4 и address-family vpnv4 в чем их отличия?
Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-11 10:40:17

в ипв4 передаются маршруты которые живут не в врф-ах (глобал рутинг тейбл так называемая) а в впнв4 передается информация о впн-ах
Не сломалось - не чини.

Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

Re: cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-11 10:57:50

добавил.

Код: Выделить всё

mpls label protocol ldp
tag-switching tdp router-id Looback1 force
redistribute connected Что я не докрутил видимо.
при выводе команды

Код: Выделить всё

sh ip route bgp 
пусто.

Код: Выделить всё

sh mpls forwarding-table
16 Pop tah 10.20..1.2/32 0 Gi0/0 95.50.110.2
Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-11 11:03:49

на Gi0/0 с обеих сторн нарисовал mpls ip (или tag-switching ip)?
sh mpls ldp nei ченить показывает? и кстати надо еще допилить мту на интерфейсах (где мплс запущен) ибо мплсная метка. поидее можно выставить mtu 1600 и ip mtu 1500 (осторожно, может развалится оспф из-за несовпадения мту)
Не сломалось - не чини.

Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

Re: cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-11 11:45:26

Все заработало. пасиб.
как я понял.
vrf это функцианал mpls и его нужно включить на обоих железках + на физ. интерфейсах между ними.
и видимо не был включен redistribute в address family vpn4 vrf


но теперь еще одна трабла не пингуется от ПК до роутера тоибшь на комп статика 192.168.157.20 шлюз 192.168.157.1 . который весит на саб-интерфейсе на циске. поставил свитчи сделал trunk в сторону роутера. и access в сторону ПК . в этоге пинг не до шлюза не с шлюза до Пк не идет.
Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-11 11:50:14

ну эта, всякое show mac-address table... влан чтоб на свиче был заведен и все такое.
Не сломалось - не чини.

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: cisco VRF + BGP

Непрочитанное сообщение lap » 2012-05-11 13:43:55

Врф-ы можно юзать и без мплс-а (помоему зовется врф-лайт), но таких вкусностей как настроил стык pe-ce и все заработало там не будет.
Не сломалось - не чини.

Аватара пользователя
CTOPMbI4
прапорщик
Сообщения: 482
Зарегистрирован: 2008-05-02 20:20:47
Откуда: Made in Russia

Re: cisco VRF + BGP

Непрочитанное сообщение CTOPMbI4 » 2012-05-11 14:19:06

lap писал(а):Врф-ы можно юзать и без мплс-а (помоему зовется врф-лайт), но таких вкусностей как настроил стык pe-ce и все заработало там не будет.
Благодарю. все пашет. просто свитч стандартный в гнс косячный видимо не отрабатывал влан норм.
поставил норм свитч на IOS 3620. руками все прокинул. все завелось.
Если будут вопросы буду у тебя спрашивать. респект. ;-)
Это почти неподвижности мука
Мчаться куда то со скоростью звука,
зная преакрасно, что есть уже где то
Некто
Летящий
Со скорости
Света!