двойной нат?

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
playnet
мл. сержант
Сообщения: 75
Зарегистрирован: 2009-07-02 15:33:24

двойной нат?

Непрочитанное сообщение playnet » 2011-07-07 19:14:28

Есть в локалке сервера, в частности с www и svn. Перевожу с керио на циску систему и столкнулся с проблемой: для удобства работы используются внешние имена (test.site.ru), где прописан внешний айпи. Извне - работает. Изнутри - нет.
На керио эту проблему я решил: было правило в начале "пакет с порта lan, к порту lan, порт 80: нат через дефолтный путь+маппинг"
Как сделать тоже самое на циске? НЕ через днс!
Кусок конфига:

Код: Выделить всё

! 0-3 LAN, 4 WAN
interface FastEthernet3
 spanning-tree portfast
!
interface FastEthernet4
 ip address 1.2.3.4 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0 secondary
 ip address 192.168.3.1 255.255.255.0 secondary
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 1.2.3.1
!
ip nat pool NATPOOL 1.2.3.4 1.2.3.4 netmask 255.255.255.0
ip nat inside source list NATACL pool NATPOOL overload
ip nat inside source static tcp 192.168.2.20 81 1.2.3.4 80 extendable
!
ip access-list extended NATACL
 permit ip 192.168.2.0 0.0.0.255 any
!
access-list 10 permit any


Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
vadim64
майор
Сообщения: 2101
Зарегистрирован: 2009-09-17 15:15:26
Откуда: Засратовец

Re: двойной нат?

Непрочитанное сообщение vadim64 » 2011-07-07 20:53:14

подписка
Люди не делятся на национальности, партии, фракции и религии. Люди делятся на умных и дураков, а вот дураки делятся на национальности, партии, фракции и религии.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: двойной нат?

Непрочитанное сообщение Alex Keda » 2011-07-09 20:31:45

vadim64 писал(а):подписка
для этого достаточно поставить галку и нажать "отправить"

писать ничё не надо =)
Убей их всех! Бог потом рассортирует...

Аватара пользователя
vadim64
майор
Сообщения: 2101
Зарегистрирован: 2009-09-17 15:15:26
Откуда: Засратовец

Re: двойной нат?

Непрочитанное сообщение vadim64 » 2011-07-09 20:38:43

Alex Keda писал(а):
vadim64 писал(а):подписка
для этого достаточно поставить галку и нажать "отправить"

писать ничё не надо =)
спасиба, кэп :smile:
Люди не делятся на национальности, партии, фракции и религии. Люди делятся на умных и дураков, а вот дураки делятся на национальности, партии, фракции и религии.

playnet
мл. сержант
Сообщения: 75
Зарегистрирован: 2009-07-02 15:33:24

Re: двойной нат?

Непрочитанное сообщение playnet » 2011-07-10 1:24:21

Лучше бы что-то дельное предложили... %)

Аватара пользователя
vadim64
майор
Сообщения: 2101
Зарегистрирован: 2009-09-17 15:15:26
Откуда: Засратовец

Re: двойной нат?

Непрочитанное сообщение vadim64 » 2011-07-10 7:30:06

я бы на вашем месте расписал более подробно задачу.
типа: пакет идёт с такого то интерфейса с таким то айпишником дестинейшена. после прохождения ната пакет попадает на такой то интерфейс с таким то айпишником etc...
Люди не делятся на национальности, партии, фракции и религии. Люди делятся на умных и дураков, а вот дураки делятся на национальности, партии, фракции и религии.