нат

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
kirill.adw
сержант
Сообщения: 217
Зарегистрирован: 2009-05-21 16:26:40

нат

Непрочитанное сообщение kirill.adw » 2012-11-18 14:47:21

Всем привет народпомогите пожалуйста настроить НАТ на 1841 модели


интерфйс провайдера
FastEthernet0/0
ip адрес от провайдера получаю по dhcp 192.168.227.163


интерфйс для локальной сети
FastEthernet0/1
ip адреса раздаю по dhcp


ПК в локальной сети получает ip адрес от циски, жлюз пингуется но ресурсы провайдера нет.
например 192.168.227.20 не пингуется, хотя данный ИП с циски пингуется

вот ман по которому производил настройку
http://www.it-club.org/leadership/pyat_ ... 14827.html

Код: Выделить всё


Building configuration...



Current configuration : 1585 bytes

!

! Last configuration change at 15:26:10 UTC Sun Nov 18 2012 by admin

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname kiska

!

boot-start-marker

boot-end-marker

!

no logging buffered

no logging console

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.0.128 10.0.0.255

ip dhcp excluded-address 10.0.0.1 10.0.0.10

!

ip dhcp pool LAN

   network 10.0.0.0 255.255.255.0

   default-router 10.0.0.1 

   dns-server 10.0.0.3 10.0.0.4 

   domain-name pc.lan

!

ip dhcp pool local

   default-router 10.0.0.1 

!

!

ip domain name test.lan

!

username admin privilege 15 secret 5 xxxxxxxxxxx

!

!

!

interface FastEthernet0/0

 description WAN

 ip address dhcp

 ip nat outside

 no ip route-cache

 duplex auto

 speed auto

!

interface FastEthernet0/1

 description LAN

 ip address 10.0.0.1 255.255.255.0

 ip nat inside

 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

 rate-limit output 10240000 1920000 3840000 conform-action transmit exceed-action drop

 no ip route-cache

 duplex auto

 speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

!

ip http server

ip http authentication local

ip nat inside source list NAT interface FastEthernet0/0 overload

!

ip access-list extended NAT

 permit ip 10.0.0.0 0.0.0.255 any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

 login

!

end

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

rmn
старшина
Сообщения: 427
Зарегистрирован: 2008-10-03 18:52:02

Re: нат

Непрочитанное сообщение rmn » 2012-11-18 15:21:10

поменяй строчки местами:

Код: Выделить всё

ip access-list extended NAT permit ip 10.0.0.0 0.0.0.255 any
ip nat inside source list NAT interface FastEthernet0/0 overload
Сначала создаем access-list, потом его юзаем...

kirill.adw
сержант
Сообщения: 217
Зарегистрирован: 2009-05-21 16:26:40

Re: нат

Непрочитанное сообщение kirill.adw » 2012-11-19 7:43:13

заработало, всем спасибо!

ip routing
ip cef
ip route 0.0.0.0 0.0.0.0 dhcp