Не передаётся vlan с одной циски на другую

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-06 18:54:46

Есть 2 циски, между собой соединены оптикой. Порты соединения переведены в транковый режим. Не хотят передаваться вланы с одной на другую. Причём вланы, которые были сконфигурированы до меня - передаются нормально. А я захотел добавить ещё один влан и не выходит. Привожу конфиги цисок.
Модели cat1=2900Xl, cat2=2950.

router вклюён в 1 порт cat2,

СХЕМА1
Схема, по которой работало, когда не было второй циски
router ----- cat2 ----server (включён в 6 порт)

СХЕМА2
Схема по которой они должны работать: <------------------ ВОТ ТАК НЕ РАБОТАЕТ :(
router ---- cat2---- cat1---server (включён в 10 порт)


Оба свича принадлежат разным vtp доменам, оба находятся в режимах сервер. на обоих vlan'ы все существуют.


Помогите настроить их, что бы они работали по схеме2. Может я что-то упустил? Уже пробовал и переводить порт не в режим trunk'a, а просто в режим access vlan - тоже самое. Подозреваю, что он просто не передаётся на cat1 с cat2.

cat1

Код: Выделить всё

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname gamma-sw
!
aaa new-model
aaa authentication login default local
aaa authorization exec default local
enable secret ***********
enable password 7 ************8
!
!

!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 switchport access vlan 855
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,401,856,857,1002-1005
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,271,1002-1005
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
 switchport access vlan 771

!
interface FastEthernet0/9
 switchport access vlan 772
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,103,200,1002-1005
 switchport mode trunk
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14

interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
 description for VLAN Conversion 271-616
 switchport access vlan 271
!
interface FastEthernet0/18
 description for VLAN Conversion 271-616
 switchport access vlan 616
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,103,200,522,616,771,772,855-857,1002-1005
 switchport mode trunk
!
interface VLAN1
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN771
 ip address xx.xx.xx.xx
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway xx.xx.xx.xx
access-list 1 permit any
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 access-class 1 in

 exec-timeout 14400 0
 escape-character 3
line vty 5 15
 access-class 1 in
 exec-timeout 14400 0
 escape-character 3
!
end
cat2

Код: Выделить всё

Current configuration : 3719 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname delta-sw
!
aaa new-model
aaa authentication login default local
aaa authorization exec default local
enable secret 5 ************
!
ip subnet-zero
no ip rcmd domain-lookup
!
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 59,101-107,200
!
!
!
!
interface FastEthernet0/1
 switchport trunk allowed vlan 101-107,522,610,616,618,619,771,772,783-786
 switchport trunk allowed vlan add 855-857
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 101
!
interface FastEthernet0/3
 switchport access vlan 101
!
interface FastEthernet0/4
 switchport access vlan 101
!
interface FastEthernet0/5
 switchport access vlan 618
!
interface FastEthernet0/6
 switchport trunk allowed vlan 103,200
 switchport mode trunk
!
interface FastEthernet0/7
 switchport access vlan 785
!
interface FastEthernet0/8
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 611
!
interface FastEthernet0/12
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 771
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 59
!
interface FastEthernet0/16
 switchport access vlan 59
!
interface FastEthernet0/17
 switchport access vlan 59
!
interface FastEthernet0/18
 switchport access vlan 59
!
interface FastEthernet0/19
 switchport access vlan 59
!
interface FastEthernet0/20
 switchport access vlan 200
!
interface FastEthernet0/21
 switchport access vlan 200
!
interface FastEthernet0/22
 switchport access vlan 200
!
interface FastEthernet0/23
 switchport trunk allowed vlan 7,59,101-107,200-202
 switchport mode trunk
!
interface FastEthernet0/24
 switchport trunk allowed vlan 101-107,200,522,610,611,616-619,771,772,783-786
 switchport trunk allowed vlan add 855-857
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan771
 ip address xx.xx.xx.xx
 no ip route-cache
!
ip default-gateway xx.xx.xx.xx
ip http server
access-list 1 permit any
!
line con 0
 stopbits 1
line vty 0 4
 access-class 1 in
 exec-timeout 14400 0
 escape-character 3
line vty 5 15
 access-class 1 in
 exec-timeout 14400 0
 escape-character 3
!
!
end

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
hizel
дядя поня
Сообщения: 9032
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение hizel » 2009-04-06 20:04:46

какими портами каталисты соеденены?
и см sh vlan
я например часто забываю vlan cоздать
в conf t

Код: Выделить всё

vlan N
name olo
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-07 9:46:36

соединены 24---24. Вланы проверил, на обеих цисках есть. Думал дело в инкапсуляции, так как на одной циске на 24-ом порту есть инкапсуляция, а на другой - нет. Но для других вланов всё работает. :(

Гость
проходил мимо

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение Гость » 2009-04-07 10:51:59

вы где смотрите? на сервере?
в sh mac-address-table смотрели?

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-07 13:07:11

Что смотреть?
В sh mac-address-table смотрел: МАС сервака периодически появляется на указанном порту, потом пропадает.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение zingel » 2009-04-07 13:47:41

Код: Выделить всё

sh int trunk
и с одной и со второй
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-07 15:18:09

cat1

Код: Выделить всё

sh int trunk
        ^
% Invalid input detected at '^' marker.
cat2

Код: Выделить всё

sh interfaces trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/23      on           802.1q         trunking      1
Fa0/24      on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/1       101-107,522,610,616,618-619,771-772,783-786,855-857
Fa0/23      7,59,101-107,200-202
Fa0/24      101-107,200,522,610-611,616-619,771-772,783-786,855-857

Port        Vlans allowed and active in management domain
Fa0/1       101-103,105,522,616,618-619,771-772,783,785-786,855-857
Fa0/23      59,101-103,105,200
Fa0/24      101-103,105,200,522,611,616-619,771-772,783,785-786,855-857

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       101-103,105,522,616,618-619,771-772,783,785-786,855-857
Fa0/23      59,101-103,105,200
Fa0/24      101-103,105,200,522,611,616-619,771-772,783,785-786,855-857 

Dirty.Eager
мл. сержант
Сообщения: 72
Зарегистрирован: 2008-10-25 3:05:59

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение Dirty.Eager » 2009-04-08 10:34:02

Приведи вывод

Код: Выделить всё

sh vtp status
с обоих каталистов.

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-08 11:10:18

Код: Выделить всё

cat1

sh vtp status
VTP Version                     : 2
Configuration Revision          : 11
Maximum VLANs supported locally : 68
Number of existing VLANs        : 16
VTP Operating Mode              : Server
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xE1 0xE1 0x7D 0xA4 0xB9 0xCD 0x9D 0xB2 

Код: Выделить всё

cat2

sh vtp status
VTP Version                     : 2
Configuration Revision          : 18
Maximum VLANs supported locally : 64
Number of existing VLANs        : 25
VTP Operating Mode              : Server
VTP Domain Name                 : domain.ua
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xE1 0x58 0x19 0x1E 0xD8 0x59 0xD4 0x67 

Dirty.Eager
мл. сержант
Сообщения: 72
Зарегистрирован: 2008-10-25 3:05:59

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение Dirty.Eager » 2009-04-08 21:03:30

Странное число vlan'ов для cat1 - 16...
Дай еще

Код: Выделить всё

sh int fa0/24 switchport
на обоих каталистах.
И

Код: Выделить всё

sh vlan id ...
для любого из "проблемных" вланов и для любого из работающих вланов.

atckoe
проходил мимо

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение atckoe » 2009-04-13 12:12:31

Vlan id то какой? Уважаемый.
Вы заметили что у вас на аплинк портах конкретно задаются влан-айди которые разрешены для пропускания? ваш влан-айди входит в эти ограничения? :)

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-13 13:06:07

да. заметил. конфигурацию скидывал сюда уже после некоторых манипуляций. Поэтому vlan могут отличаться. Так что здесь всё в порядке.

Вообщем, тему можно закрывать, так как нашёл решение такое: использовать те вланы, для которых всё работает нормально.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение zingel » 2009-04-14 11:26:36

Вообщем, тему можно закрывать, так как нашёл решение такое: использовать те вланы, для которых всё работает нормально.
далеко пойдёшь =)
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-14 12:17:21

zingel писал(а):
Вообщем, тему можно закрывать, так как нашёл решение такое: использовать те вланы, для которых всё работает нормально.
далеко пойдёшь =)
Ну все так пойдут, если не найдут нормальное решение. Ибо времени ждать пока через месяц-второй кто-то что-то подскажет нету. Да и тестить на рабочей системе, которая находится удалённо и держит ещё и регионы и около 1000 человек тоже не хочется. Учитывая, что всё это дело работает 24/7. А начальству не объяснишь, что тебе нужно подождать пока на форуме ответят, отключить всех или если произойдёт сбой, то может всё не работать и т.д.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение zingel » 2009-04-14 12:30:55

если нет времени то нужно делать стенд и на нём до упора ковырять пока не заработает
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-14 13:26:41

Ну я пробовал на PacketTracer и работает. Но это не показатель :). Просто больше не на чем тренироваться. А раскошеливаться ещё на стендовые циски начальство тем более не согласится.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение Alex Keda » 2009-04-14 22:33:54

тогда пусть не требуют 24/7
Убей их всех! Бог потом рассортирует...

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Не передаётся vlan с одной циски на другую

Непрочитанное сообщение skeletor » 2009-04-15 12:37:28

тогда пусть не требуют 24/7
Ну этого от их не дождёшся. :)

Кстати!!! На одном из форумов подсказали неплохую идею: может провайдер блочит (у нас, кстати, не оптика между цисками, а именно транспорт, возможно с самого начала не сказал :oops: ). Позвонил прову, сказал, что пробросит нужный влан. Теперь ожидаю. :)