не работает интернет у pptp пользователей (cisco)

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
diakon2
ефрейтор
Сообщения: 62
Зарегистрирован: 2010-04-13 14:38:09

не работает интернет у pptp пользователей (cisco)

Непрочитанное сообщение diakon2 » 2014-02-20 15:49:18

добрый день умы сайта сего)

обращаюсь к вам с проблемой так как гугл не нашел ответа.

имеется сеть на cisco, белый внешний ип от провайдера, десяток саб интерфейсов для каждого отдела. все работает, все довольны.

сейчас встала задача - подключить к офисной сети удаленных пользователей, чтобы они видели внутренние сервера и могли ходить в интернет через офисный канал( так как на удаленных обьектах стоят различные прокси и прочие изощрения которые мешают сотрудникам выполнять их прямые обязаности)

итак pptp сервер поднят, клиенты подключаются, каждому выдается ип адрес из отдельной подсети, все видят внутренние офисные сервера... но не работает интернет, никак. какбы я не старался. какбэ не переделывал конфиг, какиебы статьи не читал, в итоге одно и тоже - соединение устанавливается, все внутренние ресурсы доступны но интернет не работает.

причем когда я создаю впн подключение из внутренней офисной сети, то интернет работает, но как только я подключаюсь из дома\удаленного офиса, то интернет работать отказывается. на всех трех цисках в трех никак не связаных между собой фирмах, ситуация таже самая. провайдеры везде разные.


ios - adventerprisec-k9

Код: Выделить всё

ip dhcp pool pptp-users
   network 192.168.9.0 255.255.255.0
   default-router 192.168.9.1
   dns-server 192.168.9.1

vpdn-group VPN
! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1

interface FastEthernet0/0.1
 description link to LAN
 ip address 192.168.10.201 255.255.255.0
 ip accounting output-packets
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
interface FastEthernet0/1
 description link to WAN
 ip address 62.176.x.x 255.255.255.0
 ip access-group FIREWALL in
 ip access-group FIREWALL out
 ip verify unicast reverse-path
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip inspect INSPECT_OUT out
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface Virtual-Template1
 description pptp
 ip unnumbered FastEthernet0/1
 ip verify unicast reverse-path
 no ip redirects
 ip nat inside
 ip virtual-reassembly
 ip mroute-cache
 peer default ip address dhcp-pool pptp-users
 no keepalive
 ppp authentication pap callin
!
ip local pool vpnpool 192.168.9.20 192.168.9.25
ip route 0.0.0.0 0.0.0.0 62.176.x.x
!
!
no ip http server
no ip http secure-server
ip nat inside source list NAT interface FastEthernet0/1 overload
ip nat inside source static tcp 62.176.x.x 22 62.176.x.x4 22 extendable
ip nat inside source static tcp 62.176.x.x 1723 62.176.x.x 1723 extendable
!
ip access-list extended FIREWALL
 permit icmp any any
 permit ip any any
 permit tcp any host 62.176.x.x eq 1723
 permit gre any host 62.176.x.x
ip access-list extended NAT
 permit ip any any


где косяк?

пробовал и ip unnambered менять на обычные внутренние ипы, ситуация таже - внутренние ресурсы все работают, интернет не работает. причем!!!!! если я подключился по тим вьюверу к хосту внутри офисной сети и поднял pptp соединение, то тим вьюверское соединение не рвется, я продолжаю управлять компьютером в офисной сети, но при этом не работает интернет, рвутся конекты от скайпа и аськи.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: не работает интернет у pptp пользователей (cisco)

Непрочитанное сообщение lap » 2014-02-20 17:12:33

Скорее всего у вас дефолт переписывается в сторону пптп. Попробуйте подампить пакетики. Может надо нат донастроить или еще чего...
Не сломалось - не чини.

diakon2
ефрейтор
Сообщения: 62
Зарегистрирован: 2010-04-13 14:38:09

Re: не работает интернет у pptp пользователей (cisco)

Непрочитанное сообщение diakon2 » 2014-11-06 16:24:02

проблема была в

ip nat inside source list NAT interface FastEthernet0/1 overload

ip access-list extended NAT
permit ip any any

нужно было сделать так

ip nat inside source list 15 interface GigabitEthernet0/0 overload

access-list 15 permit 192.168.0.0 0.0.255.255

во первых нужно явно указать кому можно за нат
во вторых нужно использовать другой тип аксес листа. вроде как это упрощенный а использовался расширеный.

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: не работает интернет у pptp пользователей (cisco)

Непрочитанное сообщение lap » 2014-11-06 16:32:24

ну можно и именованый, только не говорить екстендед а стандард
Не сломалось - не чини.