Нужна помощь: OSPF и BGP (с 2 разными AS)

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение TiRider » 2010-08-20 10:43:20

Добрый день!

Уважаемые гуру, подскажите пожалуйста. Буду признателен вам!

Имеется 2 роутера. На обоих запущены процессы OSPF и BGP. Получили свою автономную систему (AS) и хотим перейти на нее. Не задача заключается в следующем, голову уже словал:

На 1-ом маршрутизаторе процессы ospf 1 и bgp 64500 (приватная автономная зона).

Код: Выделить всё

router ospf 1
log-adjacency-changes
 redistribute connected subnets
 redistribute static
 passive-interface default
 no passive-interface GigabitEthernet0/1
 network 192.168.160.0 0.0.0.15 area 0
 network 192.168.160.16 0.0.0.15 area 0

Код: Выделить всё

router1#sh ip ospf 1
 Routing Process "ospf 1" with ID 192.168.161.254 (у loopback0 адрес 192.168.161.254)
 Start time: 00:00:15.632, Time elapsed: 5w6d
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 ........
BGP 64500

Код: Выделить всё

router bgp 64500
 no synchronization
 bgp router-id 192.168.187.43 (ip-адрес выданный нам в точке обмена трафиком)
 bgp log-neighbor-changes
 network 192.168.160.0 mask 255.255.254.0 ("белые" адреса, заменены на выдуманные)
 network 192.168.168.0.0 mask 255.255.255.0 ("белые" адреса, заменены на выдуманные)
 network 172.19.36.0 mask 255.255.252.0
 network 172.19.132.0 mask 255.255.252.0
 aggregate-address 192.168.160.0 255.255.254.0 summary-only
 aggregate-address 192.168.168.0 255.255.255.0 summary-only
 aggregate-address 172.19.36.0 255.255.252.0 summary-only
 aggregate-address 172.19.132.0 255.255.252.0 summary-only
 neighbor PEER1 peer-group
 neighbor PEER1 remote-as 12345 (AS провайдера изменен (подключены в общую точку обмена трафиком PEER1)
 neighbor PEER1 next-hop-self
 neighbor PEER1 send-community both
 neighbor PEER1 prefix-list 1 out
 neighbor PEER1 maximum-prefix 300 restart 60
 neighbor INT peer-group
 neighbor INT remote-as 64500 (внутренний пиринг между маршрутизаторами. на разные маршрутизаторы подключаются физики/юрики,сделано именно для этого)
 neighbor INT next-hop-self
 neighbor INT send-community both
 neighbor INT filter-list 1 out
 neighbor PEER2 peer-group
 neighbor PEER2 remote-as 54321 (AS провайдера изменен (подключены в общую точку обмена трафиком PEER2)
 neighbor PEER2 next-hop-self
 neighbor PEER2 send-community both
 neighbor PEER2 prefix-list 1 out
 neighbor PEER2 route-map kr-ix.in in
 neighbor PEER2 maximum-prefix 300 restart 60
 neighbor 192.168.159.1 peer-group PEER2 (ip-адрес изменен)
 neighbor 192.168.160.14 peer-group INT (ip-адрес изменен)
 neighbor 192.168.187.1 peer-group PEER1 (ip-адрес изменен)
 no auto-summary
Второй маршрутизатор имеет следующую конфигурацию.

Код: Выделить всё

router ospf 1
 log-adjacency-changes
 redistribute connected subnets
 redistribute static subnets
 passive-interface default
 no passive-interface GigabitEthernet0/0.10
 network 192.168.160.0 0.0.0.15 area 0
 network 192.168.160.16 0.0.0.15 area 0

Код: Выделить всё

Routing Process "ospf 1" with ID 192.168.184.101 (данный адрес является шлюзом вышестоящего провайдера, для выхода в интернет (интернет и пиринг PEER1) берем у одного и того же)
 Start time: 00:00:14.752, Time elapsed: 5w6d
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 It is an autonomous system boundary router
 Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution

Код: Выделить всё

router bgp 64500
 no synchronization
 bgp log-neighbor-changes
 neighbor INT peer-group
 neighbor INT remote-as 64500
 neighbor 192.168.160.5 peer-group INT
 no auto-summary
Нужно грамотное объяснение, как оставить между маршрутизаторами нормальную связь для обмена информацией, запустив второй ospf. А на втором маршрутизаторе "заглушив" приватную AS 64500 заменить ее на выделенную нам.

Т.е. на 1-ом маршрутизаторе ospf 1 и bgp 64500 с пирингом, на втором маршрутизаторе связь с первым и ospf 1, и bgp "NEW AS". Слышал что если делать редистрибуцию скажем на одном из маршрутизаторов bgp --> ospf то будет "петляние" маршрутизации.

Сорри если что-то не то написал. Не профи в цисках.

Подскажите грамотно кто может. Заранее благодарен!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение lap » 2010-08-20 12:01:20

Можно рассмотреть вариант использования после перенастройки на новую автономку фчу вида "neighbor XXX local-as 64500", удаленный роутер будет считать что у него сессия с as 64500. как в таких случаях ведет себя комьюнити локал-ас я к сожалению сказать не смогу (ибо хз). И еще - что у вас ходит в бгп а что в оспф? Возможно иежду оспф и бгп ничего и ненадо редестрибутить. Разводить зоопарк из роутеров в разных AS не советую.
Не сломалось - не чини.

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение skeletor » 2010-08-20 12:01:37

Я не совсем понял зачем на обеих концах одновременно поднимать и ospf и bgp?

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение lap » 2010-08-20 12:07:33

Мне в большинстве случаев приходилось сталкиваться с тем что внутри AS внутресетевые интерфейсы и loopbak-и ходят в какомнибудь OSPF-е или ISIS-е, а все клиентские специфики распространяются по БГП. впринципе такой вариант построения сети в цысковских доках обычно и рассматривается. БГП внутри сети строится на лупбеках (neighbor xxx update-source LoopbackX ). Как настроено в данном случае - я чето както пока несовсем понял.
Не сломалось - не чини.

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение TiRider » 2010-08-20 21:29:24

Друзья!

Если нужна дополнительная информация, скажите, скину.

Бгп внутри сети создана специально, чтобы корректно работал пиринг для физиков и юриков. Об этом я указывал. Что они подключаются к разным маршрутизаторам.

Если вы предлагаете другой подход, при котором можно будет сохранить топологию, но изменить тип маршрутизации избавившись от лишнего, но не потеряв ничего, готов выслушать ;-)

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение lap » 2010-08-21 11:09:07

В чем состоит идея разведения зоопарка АСок внутри ваших владений?
Какую информацию получает второй роутер (с клиентами) от первого (с двумя бгп с кем-то еще)?
Какой роутер будет анонсировать во внешний мир ваши сети? (как это кстати сейчас выглядит?)

Если у вас все клиентские сети ходят в оспф-е, а выйти в интернет можно только с роутера1, то невижу смысла запускать бгп где-то еще, кроме как на роутере1, и снего в ОСПФе анонсировать маршрут по умолчанию всем остальным.
Не сломалось - не чини.

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение lap » 2010-08-21 11:32:34

Насчет того большинства случаев, про который я говорил ране (с условием что физики/юрики живут в разных местах), выглядит оно примерно так:
Drawing1.png
Drawing1.png (20.96 КБ) 2719 просмотров
и соответственно конфигурация:

Код: Выделить всё

R1
interface loopback 0
 ip address 10.0.0.1 255.255.255.255.255

int X1
 10.10.10.1 255.255.255.252

int Y1
 10.10.10.5 255.255.255.252

int isp1
 172.16.0.2 255.255.255.252

int isp2
 192.168.0.2 255.255.255.252

router ospf 1
 router-id 10.0.0.1
 log-adjacency-changes
 passive-interface default
 no passive-interface X1
 no passive-interface Y1
 network 10.0.0.1 0.0.0.0 area 0
 network 10.10.10.0 0.0.0.3 area 0
 network 10.10.10.4 0.0.0.3 area 0

router bgp XXXX  (ваша новая AS)
 bgp router-id 10.0.0.1
 bgp always-compare-med
 bgp log-neighbor-changes
 redistribute static
 redistribute connected
 neighbor ibgp peer-group
 neighbor ibgp remote-as XXXX
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor ibgp send-community
 neighbor ibgp route-reflector-client
 neighbor ibgp default-originate
 neighbor 10.0.0.2 peer-group ibgp-full
 neighbor 10.0.0.3 peer-group ibgp-full
 neighbor 172.16.0.1 remote-as AS-ISP1
 neighbor 192.168.0.1 remote-as AS-ISP2
 + все префикслисты и прочее


R2 (юрики)
interface loopback 0
 ip address 10.0.0.2 255.255.255.255.255

int X2
 10.10.10.2 255.255.255.252

router ospf 1
 router-id 10.0.0.2
 log-adjacency-changes
 passive-interface default
 no passive-interface X1
 network 10.0.0.2 0.0.0.0 area 0
 network 10.10.10.0 0.0.0.3 area 0

router bgp XXXX  (ваша новая AS)
 bgp router-id 10.0.0.2
 bgp always-compare-med
 bgp log-neighbor-changes
 redistribute static
 redistribute connected
 neighbor ibgp-full peer-group
 neighbor ibgp-full remote-as XXXX
 neighbor ibgp-full update-source Loopback0
 neighbor ibgp-full version 4
 neighbor ibgp-full send-community
 neighbor ibgp-full next-hop-self
 neighbor 10.0.0.1 peer-group ibgp-full

Для роутера с физиками конфига такаяже как и для юриков, надо поменять только адреса интерфейсов.

если ктото из внешних пиров будет ломаться на замену remote-as с приватной на новую (или их не будет устраивать время проведения работ, например ночью или утром), в качестве временного решения можно использовать "neighbor XXX local-as 64500".

Так как я не увидел никаких роутмап, то комьюнити вы тоже никакие не навешиваете, и проблем с распространением маршрутов в момент когда на одном роутере старая АС а на другом уже новая быть не должно. Попробуйте собрать схему в какомнибудь динамипсе, и поэксперементировать с почти живым оборудованием.
Не сломалось - не чини.

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Нужна помощь: OSPF и BGP (с 2 разными AS)

Непрочитанное сообщение TiRider » 2010-08-23 7:35:42

Уважаемый lap! Спасибо вам большое за помощь. Попробую на dynampis'е ваш конфиг. В принципе то должно заработать. Как проверю, отпишусь сюда.