Проброс IPTV на Cisco 2821

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-02-04 14:40:37

Доброго <usertime>!
Столкнулся с проблемой. Настраиваю себе домашний шлюз на Cisco 2821. Все что хотелось сделал. Два провайдера с балансировкой и ip sla, NAT.
И вот, столкнулся с проблемой. Один из провайдеров отдает мультикастом IPTV, хотелось бы смотреть его с машин из локалки. Настраиваю multicast-routing, но не работает.
#sh run
Building configuration...
Current configuration : 4617 bytes
!
! Last configuration change at 00:36:05 YEKT Sat Feb 4 2012 by Mors
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Mors-Home-GW
!
boot-start-marker
boot-end-marker
!
!
security authentication failure rate 10 log
security passwords min-length 6
logging buffered 262144 errors
logging rate-limit 10 except errors
logging console errors
enable secret 5 *******************************
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone YEKT 6 0
!
no dot11 syslog
ip source-route
no ip gratuitous-arps
!
!
ip cef
!
ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
domain-name mors.cc
dns-server 8.8.8.8 87.224.197.1 217.24.176.230 87.224.213.1 217.24.177.2 8.8.4.4
!
!
no ip bootp server
ip domain name mors.cc
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 87.224.197.1
ip name-server 87.224.213.1
ip name-server 217.24.176.230
ip name-server 217.24.177.2
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
ip address trusted list
ipv4 192.168.0.0 255.255.255.0
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn FCZ1140714R
username mors privilege 15 password 7 **********************
!
redundancy
!
!
ip tcp selective-ack
ip tcp timestamp
ip ssh version 2
!
track 500 ip sla 500 reachability
delay down 60 up 180
!
track 1000 ip sla 1000 reachability
delay down 60 up 180
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description INSYS
ip address 212.104.88.*** 255.255.255.192
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex full
speed 100
no mop enabled
!
interface GigabitEthernet0/1
description LAN
ip address 192.168.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly in
ip igmp helper-address 212.104.88.193
ip igmp helper-address udl GigabitEthernet0/0
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/0/0
description KABINET
ip address 90.157.83.*** 255.255.254.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
duplex full
speed 100
no mop enabled
!
interface ATM0/1/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
shutdown
no atm ilmi-keepalive
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source static tcp 192.168.0.3 15781 interface FastEthernet0/0/0 15781
ip nat inside source static udp 192.168.0.3 15781 interface FastEthernet0/0/0 15781
ip nat inside source static tcp 192.168.0.3 3389 interface FastEthernet0/0/0 3389
ip nat inside source static tcp 192.168.0.4 3389 interface GigabitEthernet0/0 3389
ip nat inside source static tcp 192.168.0.4 15781 interface GigabitEthernet0/0 15781
ip nat inside source static udp 192.168.0.4 15781 interface GigabitEthernet0/0 15781
ip nat inside source route-map INSYS interface GigabitEthernet0/0 overload
ip nat inside source route-map KABINET interface FastEthernet0/0/0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0/0 90.157.82.1 name KABINET track 500
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 212.104.88.193 name INSYS track 1000
!
ip sla 500
icmp-echo 8.8.8.8 source-interface FastEthernet0/0/0
tag KABINET
threshold 400
timeout 1000
frequency 30
ip sla schedule 500 life forever start-time now
ip sla 1000
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/0
tag INSYS
threshold 400
timeout 1000
frequency 30
ip sla schedule 1000 life forever start-time now
no logging trap
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 deny any
no cdp run
!
!
!
!
route-map INSYS permit 1
match ip address 1
match interface GigabitEthernet0/0
!
route-map KABINET permit 1
match ip address 1
match interface FastEthernet0/0/0
!
!
!
!
!
control-plane
!
!
voice-port 0/3/0
shutdown
!
voice-port 0/3/1
shutdown
!
voice-port 0/3/2
shutdown
!
voice-port 0/3/3
shutdown
!
!
!
mgcp profile default
!
!
!
!
!
banner motd ^CMors Home GW^C
!
line con 0
exec-timeout 0 0
transport output telnet
speed 115200
line aux 0
exec-timeout 0 0
transport output telnet
line vty 0 4
transport input ssh
transport output ssh
!
scheduler allocate 20000 1000
end


#sh ip igmp interface
GigabitEthernet0/0 is up, line protocol is up
Internet address is 212.104.88.***/26
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP configured querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 1 joins, 0 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 212.104.88.*** (this system)
IGMP querying router is 10.2.16.12
Multicast groups joined by this system (number of users):
224.0.1.40(1)
GigabitEthernet0/1 is up, line protocol is up
Internet address is 192.168.0.1/24
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP configured querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 3 joins, 3 leaves
Multicast routing is enabled on interface
Multicast TTL threshold is 0
Multicast designated router (DR) is 192.168.0.1 (this system)
IGMP querying router is 192.168.0.1 (this system)
IGMP helper address is 212.104.88.193
IGMP helper is to UDL interface GigabitEthernet0/0
No multicast groups joined by this system

#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
239.255.255.250 GigabitEthernet0/1 00:01:12 00:02:51 169.254.136.187
224.0.1.40 GigabitEthernet0/0 00:27:20 00:01:19 212.104.88.***

#sh ip igmp membership
Channel/Group Reporter Uptime Exp. Flags Interface
*,239.255.255.250 169.254.136.187 00:02:04 02:51 2A Gi0/1
*,224.0.1.40 212.104.88.*** 00:28:12 02:30 2LA Gi0/0

#sh ip igmp udlr
IGMP UDLR Status, UDL Interfaces: None
Group Address Interface UDL Reporter Reporter Expires
239.255.255.250 GigabitEthernet0/1 0.0.0.0 stopped

#sh ip pim interface
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
212.104.88.*** GigabitEthernet0/0 v2/SD 0 30 1 212.104.88.***
192.168.0.1 GigabitEthernet0/1 v2/SD 0 30 1 192.168.0.1

#sh ip pim neighbor
пустой

Подскажите, что делаю не так?

PS. Буду благодарен если ткнете и в другие ляпы конфига. Я не особо спец в Cisco, вот мучаю эту для самообразования.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35139
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение Alex Keda » 2012-02-04 20:16:29

оформите сообщение, в соответсвтии с правилами, описанными вверху страницы
Убей их всех! Бог потом рассортирует...

DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-02-04 20:30:36

Alex Keda писал(а):оформите сообщение, в соответсвтии с правилами, описанными вверху страницы
С удовольствием. Ткните только носом в кнопку "Изменить сообщение", минут 5 искал, но видимо со зрением у меня большие проблемы :smile:

GhOsT_MZ
лейтенант
Сообщения: 662
Зарегистрирован: 2011-04-25 11:40:35
Контактная информация:

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение GhOsT_MZ » 2012-02-04 21:57:57

Нихрена себе домашний маршрутизатор, так еще с security лицензией...

PS: извиняюсь, не удержался...

DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-02-04 22:12:51

GhOsT_MZ писал(а):Нихрена себе домашний маршрутизатор, так еще с security лицензией...

PS: извиняюсь, не удержался...
Достался от одного непорядочного работодателя в качестве выходного пособия ))

GhOsT_MZ
лейтенант
Сообщения: 662
Зарегистрирован: 2011-04-25 11:40:35
Контактная информация:

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение GhOsT_MZ » 2012-02-04 22:13:57

DMors писал(а):
GhOsT_MZ писал(а):Нихрена себе домашний маршрутизатор, так еще с security лицензией...

PS: извиняюсь, не удержался...
Достался от одного непорядочного работодателя в качестве выходного пособия ))
Да, я бы не отказался от такого пособия выходного))))

DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-02-06 17:25:07

Нашел решение:

Код: Выделить всё

ip multicast-routing
no ip igmp snooping
!
interface GigabitEthernet0/0
  description WAN + IPTV
  ip pim sparse-dense-mode
!
interface GigabitEthernet0/1
  description LAN
  ip pim sparse-dense-mode
  ip igmp helper-address 10.2.16.12  <<-- IGMP router, уточнил у провайдера
!
ip pim rp-address 212.104.88.193 override  <<-- шлюз провайдера провайдера

TPAKTOP
проходил мимо

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение TPAKTOP » 2012-04-05 14:28:23

Простите, что такое - "шлюз провайдера провайдера"?

DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-04-05 14:43:37

Опечатался, должно быть: "шлюз провайдера IP TV". Обычно это тот же ip, что и основной шлюз, прописываемый как маршрут по умолчанию.

TPAKTOP
проходил мимо

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение TPAKTOP » 2012-04-05 17:36:44

Т.е., иными словами - адрес default gateway (next hop), в случае если один провайдер?

А что делать, если не называют адрес IGMP роутера?

DMors
проходил мимо
Сообщения: 6
Зарегистрирован: 2012-02-04 14:34:03

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение DMors » 2012-04-05 17:53:36

Т.е., иными словами - адрес default gateway (next hop), в случае если один провайдер?
Да
А что делать, если не называют адрес IGMP роутера?
Я уточнил в техподдержке провайдера, когда объяснил зачем мне это нужно, без проблем дали IP.

TPAKTOP
проходил мимо

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение TPAKTOP » 2012-04-06 11:37:15

А мне сообщили, что подозревают меня в том, что я буду продавать IPTV сторонним людям. 8-|
Поэтому мне такую информацию не сообщат. Как будто бы мне трудно купить Dlink за 800 рублей, и Wireshak'ом отснифить этот самый IGMP прокси.
Маразм...

TPAKTOP
проходил мимо

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение TPAKTOP » 2012-04-08 0:04:20

Перепробовал все. Помимо Кошки замучал Микротик.

В конце концов подключил напрямую и выяснилось, что в этом вилане вообще не работает. :D

P.S. Есть отдельный вилан, на L2, там все пашет. Но мне именно на L3 хотелось IPTV.

TPAKTOP
проходил мимо

Re: Проброс IPTV на Cisco 2821

Непрочитанное сообщение TPAKTOP » 2012-04-10 19:47:38

Говорил с кучей народу в провайдере: КолЦентр - тех поддержка - админы - руководитель тех.поддержки - директор регионального офиса - директор региональных директоров - технический директор. После длинной перепятии, три вилана слили в один, и в Кошке все заработало с тем же конфигом, что указан на сайте Лиссяры.