Часть раздела NTFS не видна из под фри

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-17 23:50:47

Сабж.
При монтировании раздела NTFS видна примерно треть его содержимого. Пробовал и руками и через fstab
Fdisk показывает правильный размер раздела - 533G
Диск WD6401AALS разбит на три слайса
ad4s1 - ufs - 44G
ad4s2 - fat32- 33G
ad4s5 - ntfs - 533G
фря 7.1-RELEASE amd64

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение zingel » 2009-02-18 3:23:17

При монтировании раздела NTFS
какой командой монтируете?
Z301171463546 - можно пожертвовать мне денег

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-18 13:21:35

mount_ntfs или mount -t ntfs результат одинаковый.

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение manefesto » 2009-02-18 14:33:55

не верю что не показывает.
я такой яростный шо аж пиздеЦ
Изображение

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-18 14:42:21

manefesto писал(а):не верю что не показывает.
Лол, чем вас убедить, мой фюрер? :-D

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение manefesto » 2009-02-18 15:50:43

во фре

Код: Выделить всё

ls /mnt/ntfs
в винде на этом же разделе
я такой яростный шо аж пиздеЦ
Изображение

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-19 0:15:13

Изображение -винда
Изображение - фря
Последний раз редактировалось hizel 2009-02-19 0:29:56, всего редактировалось 1 раз.
Причина: [img][/img]

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение manefesto » 2009-02-19 10:35:52

во-первых непонятно как вы монтируете и используете ли ключики -C -L.
во-вторых я бы на вашем месте проверил раздел под виндой.
я такой яростный шо аж пиздеЦ
Изображение

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-20 1:43:51

mount_ntfs -Ccp1251 /dev/ad4s5 /ntfs
чем проверить?

Аватара пользователя
Useroff
мл. сержант
Сообщения: 113
Зарегистрирован: 2008-09-21 7:11:09

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Useroff » 2009-02-20 3:42:58

Попробуй приматнировать другой раздел, у меня тож такая бага была :bn:
Сам не понял что за бред, на одном логическом устройстве было 1/3, в основном ток файлы винды :(
А на другом было все, вместе с теми файлами :cz2:
LOL

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение zingel » 2009-02-20 4:31:29

в новой фре есть поддержка ntfs ядром, собери ядро с опцией

Код: Выделить всё

options NTFS
Z301171463546 - можно пожертвовать мне денег

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-22 22:04:13

Я ядро пока не трогал, юзаю GENERIC, там эта опция есть

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-23 17:31:18

Может у кого-то есть ещё идеи? :cry:

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение paradox » 2009-02-23 17:46:11

идей можно нагенерить дохрена
от глюке в бсд
до того что тебе написали выше

ну для начала
можно
ls -l /dev/ad*
можно еще и
dmesg -a
на кучу

paix
лейтенант
Сообщения: 863
Зарегистрирован: 2007-09-24 12:41:05
Откуда: dn.ua
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение paix » 2009-02-23 22:30:45

оффтоп.

не советую юзать ntfs-3g (на запись).

был случай когда записывал бекапы на нтфс раздел из фри, в результате потом показывалось что место занималось, а файлов нет. Никакие проги востановления ничего не нашли.
With best wishes, Sergej Kandyla

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35267
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Alex Keda » 2009-02-24 2:42:58

сдаётся мне - оно на руском имени срубаеццо...
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35267
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Alex Keda » 2009-02-24 2:43:19

там коре дампы от ls не валяются пачками?
Убей их всех! Бог потом рассортирует...

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-02-27 2:11:56

Код: Выделить всё

ls -l /dev/ad*
crw-r-----  1 root  operator  -   0,  84 27 лют 00:47 /dev/ad0
crw-r-----  1 root  operator  -   0,  85 27 лют 00:47 /dev/ad4
crw-r-----  1 root  operator  -   0,  86 27 лют 00:47 /dev/ad4s1
crw-r-----  1 root  operator  -   0,  89 27 лют 00:47 /dev/ad4s1a
crw-r-----  1 root  operator  -   0,  90 27 лют 00:47 /dev/ad4s1b
crw-r-----  1 root  operator  -   0,  91 27 лют 00:47 /dev/ad4s1c
crw-r-----  1 root  operator  -   0,  92 27 лют 00:47 /dev/ad4s1d
crw-r-----  1 root  operator  -   0,  93 27 лют 00:47 /dev/ad4s1e
crw-r-----  1 root  operator  -   0,  94 27 лют 00:47 /dev/ad4s1f
crw-r-----  1 root  operator  -   0,  87 27 лют 00:47 /dev/ad4s2
crw-r-----  1 root  operator  -   0,  88 27 лют 00:47 /dev/ad4s3
crw-r-----  1 root  operator  -   0,  95 27 лют 00:47 /dev/ad4s5

Код: Выделить всё

dmesg -a
Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.1-RELEASE #0: Thu Jan  1 08:58:24 UTC 2009
    root@driscoll.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 Processor 3200+ (2010.31-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x20ff2  Stepping = 2
  Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CM
OV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
  Features2=0x1<SSE3>
  AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
  AMD Features2=0x1<LAHF>
usable memory = 1059909632 (1010 MB)
avail memory  = 1021157376 (973 MB)
ACPI APIC Table: <Nvidia AWRDACPI>
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <Nvidia AWRDACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 3fef0000 (3) failed
Timecounter "ACPI-fast" fracpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xda004000-0xda004fff irq 21 at devic
e 2.0 on pci0
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 10 ports with 10 removable, self powered
ehci0: <NVIDIA nForce4 USB 2.0 controller> mem 0xfeb00000-0xfeb000ff irq 22 at d
evice 2.1 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb1: EHCI version 1.0
usb1: companion controller, 4 ports each: usb0
usb1: <NVIDIA nForce4 USB 2.0 controller> on ehci0
usb1: USB revision 2.0
uhub1: <nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb1
uhub1: 10 ports with 10 removable, self powered
umass0: <Kingston DataTraveler 2.0, class 0/0, rev 2.00/1.10, addr 2> on uhub1
umass1: <Sony Storage Media, class 0/0, rev 2.00/1.00, addr 3> on uhub1
pci0: <multimedia, audio> at device 4.0 (no driver attached)
atapci0: <nVidia nForce CK804 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0
x177,0x376,0xf000-0xf00f at device 6.0 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
atapci1: <nVidia nForce CK804 SATA300 controller> port 0x9f0-0x9f7,0xbf0-0xbf3,0
x970-0x977,0xb70-0xb73,0xd800-0xd80f mem 0xda002000-0xda002fff irq 21 at device 
7.0 on pci0
atapci1: [ITHREAD]
ata2: <ATA channel 0> on atapci1
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci1
ata3: [ITHREAD]equency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
atapci2: <nVidia nForce CK804 SATA300 controller> port 0x9e0-0x9e7,0xbe0-0xbe3,0
x960-0x967,0xb60-0xb63,0xc400-0xc40f mem 0xda001000-0xda001fff irq 22 at device 
8.0 on pci0
atapci2: [ITHREAD]
ata4: <ATA channel 0> on atapci2
ata4: [ITHREAD]
ata5: <ATA channel 1> on atapci2
ata5: [ITHREAD]
pcib1: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci5: <ACPI PCI bus> on pcib1
rl0: <Accton MPX 5030/5038 10/100BaseTX> port 0xa000-0xa0ff mem 0xd9000000-0xd90
000ff irq 16 at device 6.0 on pci5
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> PHY 0 on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:04:e2:21:3a:4a
rl0: [ITHREAD]
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0xa400-0xa4ff mem 0xd9001000-0xd90
010ff irq 17 at device 7.0 on pci5
vr0: Quirks: 0x0
vr0: Revision: 0x86
miibus1: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus1
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: Ethernet address: 00:40:f4:75:7d:87
vr0: [ITHREAD]
pcm0: <Creative EMU10K1> port 0xa800-0xa81f irq 18 at device 8.0 on pci5
pcm0: <eMicro EM28028 AC97 Codec>
pcm0: [ITHREAD]
nfe0: <NVIDIA nForce4 CK804 MCP9 Networking Adapter> port 0xb000-0xb007 mem 0xda
000000-0xda000fff irq 23 at device 10.0 on pci0
miibus2: <MII bus> on nfe0
e1000phy0: <Marvell 88E1111 Gigabit PHY> PHY 9 on miibus2
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-FDX, auto
nfe0: Ethernet address: 00:15:f2:d0:53:29
nfe0: [FILTER]
pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci4: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 13.0 on pci0
pci2: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 14.0 vgapci0: <VGA-compatible display> mem 0xd0000000-0xd3ffffff,0xc0000000-0xcffffff
f,0xd4000000-0xd4ffffff irq 18 at device 0.0 on pci1
acpi_tz0: <Thermal Zone> on acpi0
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FILTER]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio0: [FILTER]
ppc0: <Parallel port> port 0x378-0x37f,0x778-0x77b irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppbus0: [ITHREAD]
plip0: <PLIP network interface> on ppbus0
plip0: WARNING: using obsoleted IFF_NEEDSGIANT flag
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ppc0: [GIANT-LOCKED]
ppc0: [ITHREAD]
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model IntelliMouse, device ID 3
cpu0: <ACPI CPU> on acpi0
powernow0: <Cool`n'Quiet K8> on cpu0
device_attach: powernow0 attach returned 6
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcefff,0xd0000-0xd3fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2010312277 Hz quality 800on pci0
pci1: <ACPI PCI bus> on pcib5
Timecounters tick every 1.000 msec
ad0: 238475MB <WDC WD2500JB-00KFA0 08.05J08> at ata0-master UDMA100
ad4: 610480MB <WDC WD6401AALS-00L3B2 01.03B01> at ata2-master SATA300
da1 at umass-sim1 bus 1 target 0 lun 0
da1: <Sony Storage Media 0100> Removable Direct Access SCSI-0 device 
da1: 40.000MB/s transfers
da1: 960MB (1966080 512 byte sectors: 64H 32S/T 960C)
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <Kingston DataTraveler 2.0 PMAP> Removable Direct Access SCSI-0 device 
da0: 40.000MB/s transfers
da0: 1968MB (4030464 512 byte sectors: 255H 63S/T 250C)
GEOM_LABEL: Label for provider da0s1 is msdosfs/FLESHKO.
Trying to mount root from ufs:/dev/ad4s1a
Loading configuration files.
kernel dumps on /dev/ad4s1b
Entropy harvesting:
 interrupts
 ethernet
 point_to_point
 kickstart
.
swapon: adding /dev/ad4s1b as swap device
Starting file system checks:
/dev/ad4s1a: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad4s1a: clean, 143573 free (2469 frags, 17638 blocks, 1.0% fragmentation)
/dev/ad4s1f: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad4s1f: clean, 245168 free (32 frags, 30642 blocks, 0.0% fragmentation)
/dev/ad4s1d: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad4s1d: clean, 16072893 free (57085 frags, 2001976 blocks, 0.3% fragmentati
on)
/dev/ad4s1e: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad4s1e: clean, 903947 free (147 frags, 112975 blocks, 0.0% fragmentation)
Setting hostuuid: e84287dc-837a-da11-925d-fdc2cd8d854f.
Setting hostid: 0xca43b23b.
Mounting local file systems:
.
Setting hostname: taz.
net.inet6.ip6.auto_linklocal: 
1
 -> 
0 -> 
2.6.16

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5 
        inet6 ::1 prefixlen 128 
        inet 127.0.0.1 netmask 0xff000000 
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 00:04:e2:21:3a:4a
        inet 192.168.1.4 netmask 0xffffff00 broadcast 192.168.1.255
        media: Ethernet autoselect (none)
        status: no carrier
add net default: gateway 192.168.1.1
Additional routing options:
.
Starting devd.
hw.acpi.cpu.cx_lowest: 
C1

sysctl: 
hw.acpi.cpu.cx_lowest
: 
Invalid argument
Additional IP options:
.
Mounting NFS file systems:
.
ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib
32-bit compatibility ldconfig path: /usr/lib32
Creating and/or trimming log files:
.
Starting syslogd.
Checking for core dump on /dev/ad4s1b...
savecore: no dumps found
Initial amd64 initialization:
.
Additional ABI support:
 linux
.
Clearing /tmp (X related).
Starting local daemons:
.
Mounting late file systems:

compat.linux.osrelease: 
2.4.2
.
Configuring syscons:
 keymap
 scrnmap
 font8x16
 font8x14
 font8x8
 blanktime
.
Starting sshd.
Starting cron.
Local package initialization:
.
Starting default moused:
.
Starting background file system checks in 60 seconds.

Fri Feb 27 00:47:41 UTC 2009
rl0: link state changed to UP

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение paradox » 2009-02-27 11:44:20

переименуй или перенеси куда то папки с русскими именами
и еще раз ls

Termitnik
сержант
Сообщения: 169
Зарегистрирован: 2008-04-05 20:09:45
Откуда: Киев

Re: Часть раздела NTFS не видна из под фри

Непрочитанное сообщение Termitnik » 2009-03-07 23:20:40

то же самое