нужно обновитсо

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
risk94
лейтенант
Сообщения: 831
Зарегистрирован: 2007-06-01 19:27:51

нужно обновитсо

Непрочитанное сообщение risk94 » 2008-07-02 19:24:35

есть боевой серв:

Код: Выделить всё

FreeBSD 888888888.com 4.8-RELEASE FreeBSD 4.8-RELEASE #0: Thu Apr  3 10:53:38 GMT 2003     root@8888888888888.com:/usr/obj/usr/src/sys/GENERIC  i386
На нем proftpd-1.2.8 (дырявый) без поддержки муси.

Хочу обновить залатать дыру. просто из сырцов пересобрать?

Не сочтите за глупость. учусь я. Спасибо

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: нужно обновитсо

Непрочитанное сообщение zg » 2008-07-02 19:29:22

risk94 писал(а):Хочу обновить залатать дыру. просто из сырцов пересобрать?
ну да, скачай сырцы и поставь.. если соберётся... насколько я понимаю поддержку 4й ветки уже убрали c freebsd.org, поэтому обновлять систему нет смысла

paradox_
проходил мимо

Re: нужно обновитсо

Непрочитанное сообщение paradox_ » 2008-07-02 19:37:30

так чего обновить надо
фрю или фтп = )))
чего убрали?
RELENG_4_8 всида есть = ))

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: нужно обновитсо

Непрочитанное сообщение zg » 2008-07-02 19:46:47

paradox_ писал(а):чего убрали?
RELENG_4_8 всида есть = ))
пакеты и порты как я понимаю ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/
"/pub/FreeBSD/ports/i386" is new cwd.

These are packages for the i386 architecture. Here are brief
descriptions of each subdirectory.

packages-5-stable: Packages for FreeBSD-5-stable.
packages-6-stable: Packages for FreeBSD-6-stable.
packages-6.3-release: Packages for FreeBSD 6.3-release.
packages-7-stable: Packages for FreeBSD-7-stable.
packages-7.0-release: Packages for FreeBSD 7.0-release.
packages-8-current: Packages for FreeBSD-8-current.

packages-*-release directories are built from the ports collection
shipped with the release, and are not updated thereafter.

packages-*-stable and packages-*-current are updated roughly once a
week.

Please see the file "../../dir.sizes" for the current size of each
directory. In particular, mirroring thise directories will cause about
8GB of traffic per week from packages-?-stable and packages-?-current
updates.

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: нужно обновитсо

Непрочитанное сообщение _kirill_ » 2008-07-02 20:08:26

Код: Выделить всё

man portupgrade
или

Код: Выделить всё

%make search name=portupgrade
Port:   portupgrade-2.4.3_2,2
Path:   /usr/ports/ports-mgmt/portupgrade
Info:   FreeBSD ports/packages administration and management tool suite
Maint:  sem@FreeBSD.org
B-deps: ruby-1.8.6.111_2,1
R-deps: db41-4.1.25_4 perl-5.8.8_1 ruby-1.8.6.111_2,1 ruby18-bdb-0.6.2
WWW:    http://wiki.freebsd.org/portupgrade

paradox_
проходил мимо

Re: нужно обновитсо

Непрочитанное сообщение paradox_ » 2008-07-02 20:17:56

>_kiril_
неее
это все не то

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: нужно обновитсо

Непрочитанное сообщение zg » 2008-07-02 20:21:52

_kirill_ писал(а):или
Код:
%make search name=portupgrade
Port:   portupgrade-2.4.3_2,2
Path:   /usr/ports/ports-mgmt/portupgrade
портапгрейд в 4 и 7 фре несколько различаются, это раз

Код: Выделить всё

  FreeBSD  4.11-RELEASE (MAIL) #1: Mon Oct  3 19:07:03 YEKST 2005
 Welcome to FreeBSD!
$ cd /usr/ports
$ make search name=portupgrade
Port:   portupgrade-20041226_1
Path:   /usr/ports/sysutils/portupgrade
Info:   FreeBSD ports/packages administration and management tool suite
Maint:  knu@FreeBSD.org
B-deps: openssl-0.9.7e_2 ruby-1.8.2_3
R-deps: openssl-0.9.7e_2 rc_subr-1.31 ruby-1.8.2_3 ruby18-bdb1-0.2.2
WWW:

$
ссылки из дерева портов на исходники 95% битые, это два
компиляторы и библиотеки старые, это три

установить порт на 4ке, а тем более новый, практически не реально

risk94
лейтенант
Сообщения: 831
Зарегистрирован: 2007-06-01 19:27:51

Re: нужно обновитсо

Непрочитанное сообщение risk94 » 2008-07-02 20:37:04

zg писал(а):...установить порт на 4ке, а тем более новый, практически не реально
что посоветуете? Как подзащитица? Параноя меня замучает ....

paradox_
проходил мимо

Re: нужно обновитсо

Непрочитанное сообщение paradox_ » 2008-07-02 20:41:25

Код: Выделить всё

X:\work\cvsup\freebsd\7.0S\src\sys\dev>ping 888888888.com

Обмен пакетами с 888888888.com [82.98.86.173] по 32 байт:

Ответ от 82.98.86.173: число байт=32 время=317мс TTL=55
Ответ от 82.98.86.173: число байт=32 время=291мс TTL=55
все пойду дырявый фтп ломону = )))

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: нужно обновитсо

Непрочитанное сообщение zg » 2008-07-02 20:42:16

risk94 писал(а):что посоветуете? Как подзащитица? Параноя меня замучает ....
да никак, про порты забудь, собирай из сырцов, потом резервную копию демона сделай и подмени если они совместимы. У меня такой финт ушами прошёл с vsftpd, когда его пропатчил на одной системе, а установил в другой, правда мажорные версии совпадали и фри и демона.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35297
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: нужно обновитсо

Непрочитанное сообщение Alex Keda » 2008-07-02 21:19:21

zg писал(а):
risk94 писал(а):что посоветуете? Как подзащитица? Параноя меня замучает ....
да никак, про порты забудь, собирай из сырцов, потом резервную копию демона сделай и подмени если они совместимы. У меня такой финт ушами прошёл с vsftpd, когда его пропатчил на одной системе, а установил в другой, правда мажорные версии совпадали и фри и демона.
вы бредите, все и массово...
что уу вас из портов не собирается? у меня собирается всё.
что касается proftpd - подождите пять минут сходу на последний хост с 4.11 - попробую.
Убей их всех! Бог потом рассортирует...

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: нужно обновитсо

Непрочитанное сообщение zg » 2008-07-02 21:22:11

lissyara писал(а):что уу вас из портов не собирается? у меня собирается всё.
xmms на 4.11 :Bravo:

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35297
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: нужно обновитсо

Непрочитанное сообщение Alex Keda » 2008-07-02 21:27:41

Код: Выделить всё

  ??????????????????????????????????????????????????????????????????????
  ?                   Options for proftpd 1.3.1_14                     ?
  ? ?????????????????????????????????????????????????????????????????? ?
  ? ?[ ] IPV6             Use IPv6                                   ? ?
  ? ?[ ] LDAP             Use LDAP                                   ? ?
  ? ?[ ] LDAP_TLS         Use LDAP TLS (Requires LDAP, OPENSSL)      ? ?
  ? ?[X] MYSQL            MySQL auth (Can be combined with PGSQL)    ? ?
  ? ?[ ] PGSQL            Postgres auth (Can be combined with MYSQL) ? ?
  ? ?[ ] TDS              FreeTDS - Sybase & MS-SQL auth (Exclusive) ? ?
  ? ?[ ] OPENSSL          Include mod_tls                            ? ?
  ? ?[ ] QUOTA            Include mod_quota                          ? ?
  ? ?[X] IFSESSION        Include mod_ifsession                      ? ?
  ? ?[X] README           Include mod_readme                         ? ?
  ? ?[X] RATIO            Include mod_ratio                          ? ?
  ? ?[X] CTRLS            Include controls                           ? ?
  ? ?[X] REWRITE          Include mod_rewrite                        ? ?
  ? ?[X] WRAP             Include mod_wrap2                          ? ?
  ? ?[ ] WRAP_FILE        Include mod_wrap2_file                     ? ?
  ? ?[ ] WRAP_SQL         Include mod_wrap2_sql                      ? ?
  ? ?[ ] RADIUS           Include mod_radius                         ? ?
  ? ?[ ] QUOTATAB_RADIUS  include mod_quotatab_radius                ? ?
  ? ?[ ] BAN              Include mod_ban (Requires CTRLS)           ? ?
  ? ?[X] NLS              Use nls (builds mod_lang)                  ? ?
  ? ?[ ] CLAMAV           Include mod_clamav                         ? ?
  ? ?[ ] DIGEST           Include mod_digest                         ? ?
  ? ?[ ] COMB             Include mod_comb (multistream upload)      ? ?
  ? ?[X] CODECONV         Use charset conversion (mod_codeconv)      ? ?
  ???????v(+)???????????????????????????????????????????????????????????
  ?                       [  OK  ]       Cancel                        ?
  ??????????????????????????????????????????????????????????????????????
собрался. порты обновил 3 минуты назад.
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35297
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: нужно обновитсо

Непрочитанное сообщение Alex Keda » 2008-07-02 21:29:06

zg писал(а):
lissyara писал(а):что уу вас из портов не собирается? у меня собирается всё.
xmms на 4.11 :Bravo:
простите, иксов в те времена не держал.
да и 4.11 у мя была тока на тонких клиентах да серверах...
Убей их всех! Бог потом рассортирует...