Ospf помогите!!!!!

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
John
проходил мимо

Ospf помогите!!!!!

Непрочитанное сообщение John » 2008-02-11 0:28:02

Есть неслько маршрутизаторов и несколько зон ospf, проблема заключается в том что постояно идут обновления, при которых произходят потери пакетов! Кто с этим встречался помогите )

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

John
проходил мимо

Ospf помогите!!!!!

Непрочитанное сообщение John » 2008-02-11 0:44:34

есть два равнозначных шлюза (один из которых бэкап), к ним подключены три pppoe сервака, каждый сервак в отдельном влане вместе с шлюзами, у каждого сервака со шлюзами своя зона ospf, нулевая зона между эти двумя шлюзами и внешним шлюзом, кроме это к шлюзам подключена stub зона в которой находятся, некоторые внутрение серваки, к внешнему маршрутизатору тоже подключена stub зона в которой находять некоторые внутрение серваки, вот в краце описал схему, hellp!!!

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35071
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение Alex Keda » 2008-02-11 1:21:27

картинку, вкратце, нарисуй и приложи.
Убей их всех! Бог потом рассортирует...

John
проходил мимо

Ospf помогите!!!!!

Непрочитанное сообщение John » 2008-02-11 9:40:08

Вкратце нарисовал схему.
Вложения
ospf.JPG

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение zingel » 2008-02-11 22:54:02

Используется ли QoS?
Дайте вывод sh ip ospf neighbor и ip ospf show global c граничного устройства.
А лучше всего дайте конфиги, сто процентов флапает один из портов, какой именно, можно будет сказать после просмотра конфигов и sh log на всех устройствах.
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35071
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение Alex Keda » 2008-02-12 1:25:57

втыкай шланги лепи маршруты и всё заведётся.
======
вопроса я так и не услышал.
чё надо-то? Есть сеть и есть.... чё не так? =)
Убей их всех! Бог потом рассортирует...

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение zingel » 2008-02-12 1:30:04

я как понял у него или соседи отваливаются или STP глючит, из-за этого где-то, что-то теряется, а понять где именно он не может =)
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35071
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение Alex Keda » 2008-02-12 1:41:37

помоему он сказать не может что у него не так =)
Убей их всех! Бог потом рассортирует...

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение zingel » 2008-02-12 1:44:37

судя по-схеме, там всё очень "не так" =)))), в любом случае без конфигов мы ничего не узнаем, в остальном:

Пусть юзает логи на кошке или настроит репортинг ошибок к себе на мыло.

И я не вкурил, что там стоит? Коммутаторы? (Если да, то какие?) Свичи? (если да, то какие?) И на схеме нираспятого не видно, где кто и зачем вообще....кошачьи схемы так не делаются....

прочитай вот - http://zingel.dubki.ru/text/unix/CISCO/ любую книжку, там же и картинки возьми для своей схемы и сделай нормальную, естественно с портами (что к чему куда идёт, Fa || Gi || Te )...
Z301171463546 - можно пожертвовать мне денег

John
проходил мимо

Ospf помогите!!!!!

Непрочитанное сообщение John » 2008-02-12 10:06:16

проблема заключается в том что постояно идут обновления, при которых теряются маршруты и произходят потери пакетов! (читайте внимательнее называется)))
Пакеты теряються у клиентов, которые подключатся к PPPoE сервакам ( три внизу), это не коммутаторы и темболее не свичи) это машины под фряхой.
Схему нарисовал в кратце) просьба не придераться)
конфиги на двух машинах которые находятся выше pppoe серваков.

Код: Выделить всё

interface vlan204
        ip ospf priority 250

interface vlan301
        ip ospf priority 230

interface vlan302
        ip ospf priority 220

interface vlan303
        ip ospf priority 210

interface vlan206
        ip ospf priority 200

router ospf
 compatible rfc1583
 network 10.1.4.0/24 area 0
 network 10.1.6.0/24 area 1
 area 1 stub
 network 10.1.31.0/24 area 2
 network 10.1.32.0/24 area 4
 network 10.1.33.0/24 area 5
 redistribute connected
 redistribute static
 default-information originate always


interface vlan204
       ip ospf priority 245

interface vlan301
        ip ospf priority 225

interface vlan302
        ip ospf priority 215

interface vlan303
        ip ospf priority 205

interface vlan206
        ip ospf priority 195

router ospf
 compatible rfc1583
 network 10.1.4.0/24 area 0
 network 10.1.6.0/24 area 1
 area 1 stub
 network 10.1.31.0/24 area 2
 network 10.1.32.0/24 area 4
 network 10.1.33.0/24 area 5
 redistribute connected
 redistribute static
 default-information originate always

sh ip ospf neighbor

    Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
10.1.3.8        255 Full/DR           37.337s 10.1.4.1        vlan204:10.1.4.2         0     0     0
10.1.33.2       245 Full/DROther      37.337s 10.1.4.3        vlan204:10.1.4.2         0     0     0
10.1.33.2       195 Full/Backup       38.336s 10.1.6.2        vlan206:10.1.6.1         0     0     0
10.1.6.4          1 Full/DROther      37.330s 10.1.6.4        vlan206:10.1.6.1         0     0     0
10.1.6.5          1 Full/DROther      37.331s 10.1.6.5        vlan206:10.1.6.1         0     0     0
10.1.6.7          1 Full/DROther      38.322s 10.1.6.7        vlan206:10.1.6.1         0     0     0
10.1.33.2       225 Full/Backup       38.363s 10.1.31.2       vlan301:10.1.31.1        0     0     0
10.1.31.3         1 Full/DROther      38.367s 10.1.31.3       vlan301:10.1.31.1        0     0     0
10.1.33.2       215 Full/Backup       37.331s 10.1.32.2       vlan302:10.1.32.1        0     0     0
10.1.32.3         1 Full/DROther      37.347s 10.1.32.3       vlan302:10.1.32.1        0     0     0
10.1.33.2       205 Full/Backup       37.331s 10.1.33.2       vlan303:10.1.33.1        0     0     0
10.1.33.3         1 Full/DROther      37.342s 10.1.33.3       vlan303:10.1.33.1        0     0     0

    Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
10.1.3.8        255 Full/DR           39.337s 10.1.4.1        vlan204:10.1.4.3         0     0     0
10.1.33.1       250 Full/Backup       39.314s 10.1.4.2        vlan204:10.1.4.3         0     0     0
10.1.33.1       200 Full/DR           39.314s 10.1.6.1        vlan206:10.1.6.2         0     0     0
10.1.6.4          1 Full/DROther      39.313s 10.1.6.4        vlan206:10.1.6.2         0     0     0
10.1.6.5          1 Full/DROther      39.313s 10.1.6.5        vlan206:10.1.6.2         0     0     0
10.1.6.7          1 Full/DROther      30.273s 10.1.6.7        vlan206:10.1.6.2         0     0     0
10.1.33.1       230 Full/DR           39.314s 10.1.31.1       vlan301:10.1.31.2        0     0     0
10.1.31.3         1 Full/DROther      30.381s 10.1.31.3       vlan301:10.1.31.2        0     0     0
10.1.33.1       220 Full/DR           39.314s 10.1.32.1       vlan302:10.1.32.2        0     0     0
10.1.32.3         1 Full/DROther      39.386s 10.1.32.3       vlan302:10.1.32.2        0     0     0
10.1.33.1       210 Full/DR           39.314s 10.1.33.1       vlan303:10.1.33.2        0     0     0
10.1.33.3         1 Full/DROther      39.352s 10.1.33.3       vlan303:10.1.33.2        0     0     0
Для информации сейчас отключил один из шлюзов стоящих выше pppoe серваков все работает.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Ospf помогите!!!!!

Непрочитанное сообщение zingel » 2008-02-12 13:32:44

и скоро всё упадёт, когда будет новый кривой BPDU, и будет корневой бридж, который всё флапнет.....

проснусь когда (с работы только пришел) отвечу как быть.....
Z301171463546 - можно пожертвовать мне денег