проблема со скринсевером (гном)

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
PAVka
проходил мимо
Сообщения: 3
Зарегистрирован: 2008-02-11 14:31:18

проблема со скринсевером (гном)

Непрочитанное сообщение PAVka » 2008-02-11 14:51:25

поставил freebsd v6.3 , по умолчанию wm гном
при загрузке в гном под пользователем сразу выдает ошибку :
gnome-screensaver-bugreport.txt

Код: Выделить всё

System: FreeBSD 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:45:45 UTC 2008     root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386 
X Vendor: The X.Org Foundation 
X Vendor Release: 10400000 
Selinux: No 
Accessibility: Disabled 
GTK+ Theme: Clearlooks 
Icon Theme: gnome 

Memory status: size: 13460 vsize: 13460 resident: 9228 share: 13836232 rss: 9228 rss_rlim: 2307 
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 133 

Backtrace was generated from '/usr/local/bin/gnome-screensaver' 

(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[New LWP 100065] 
[Switching to LWP 100065] 
0x28aec639 in wait4 () from /lib/libc.so.6 
#0  0x28aec639 in wait4 () from /lib/libc.so.6 
#1  0x28acb3e1 in waitpid () from /lib/libc.so.6 
#2  0x28a76242 in waitpid () from /lib/libpthread.so.2 
#3  0x287e507f in g_spawn_sync () from /usr/local/lib/libglib-2.0.so.0 
#4  0x287e52eb in g_spawn_command_line_sync () 
   from /usr/local/lib/libglib-2.0.so.0 
#5  0x28bcbd47 in bugbuddy_segv_handle () 
   from /usr/local/lib/gtk-2.0/modules/libgnomebreakpad.so 
#6  0x28a7df81 in sigaction () from /lib/libpthread.so.2 
#7  <signal handler called> 
#8  0x28b535df in kill () from /lib/libc.so.6 
#9  0x28a77236 in raise () from /lib/libpthread.so.2 
#10 0x28b5228c in abort () from /lib/libc.so.6 
#11 0x286b0196 in dbus_shutdown () from /usr/local/lib/libdbus-1.so.3 
#12 0x286acbce in dbus_watch_handle () from /usr/local/lib/libdbus-1.so.3 
#13 0x28699fbc in dbus_connection_add_filter () 
   from /usr/local/lib/libdbus-1.so.3 
#14 0x080546fe in gs_listener_acquire () 
#15 0x0805086d in gs_monitor_start () 
#16 0x0804fbd4 in main () 

Thread 1 (LWP 100065): 
#0  0x28aec639 in wait4 () from /lib/libc.so.6 
No symbol table info available. 
#1  0x28acb3e1 in waitpid () from /lib/libc.so.6 
No symbol table info available. 
#2  0x28a76242 in waitpid () from /lib/libpthread.so.2 
No symbol table info available. 
#3  0x287e507f in g_spawn_sync () from /usr/local/lib/libglib-2.0.so.0 
No symbol table info available. 
#4  0x287e52eb in g_spawn_command_line_sync () 
   from /usr/local/lib/libglib-2.0.so.0 
No symbol table info available. 
#5  0x28bcbd47 in bugbuddy_segv_handle () 
   from /usr/local/lib/gtk-2.0/modules/libgnomebreakpad.so 
No symbol table info available. 
#6  0x28a7df81 in sigaction () from /lib/libpthread.so.2 
No symbol table info available. 
#7  <signal handler called> 
No symbol table info available. 
#8  0x28b535df in kill () from /lib/libc.so.6 
No symbol table info available. 
#9  0x28a77236 in raise () from /lib/libpthread.so.2 
No symbol table info available. 
#10 0x28b5228c in abort () from /lib/libc.so.6 
No symbol table info available. 
#11 0x286b0196 in dbus_shutdown () from /usr/local/lib/libdbus-1.so.3 
No symbol table info available. 
#12 0x286acbce in dbus_watch_handle () from /usr/local/lib/libdbus-1.so.3 
No symbol table info available. 
#13 0x28699fbc in dbus_connection_add_filter () 
   from /usr/local/lib/libdbus-1.so.3 
No symbol table info available. 
#14 0x080546fe in gs_listener_acquire () 
No symbol table info available. 
#15 0x0805086d in gs_monitor_start () 
No symbol table info available. 
#16 0x0804fbd4 in main () 
No symbol table info available. 
когда захожу под рутом выдает тоже самое +

Код: Выделить всё

----------- .xsession-errors (915 sec old) --------------------- 
CalDAV Eplugin starting up ... 
** (gnome-power-preferences:1442): WARNING **: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory 
** (gnome-power-preferences:1442): WARNING **: Could not connect to DBUS daemon: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory 
** (gnome-power-preferences:1442): WARNING **: Either HAL or DBUS are not working! 
(/usr/local/libexec/gnome-screensaver-gl-helper:1445): Gdk-CRITICAL **: gdk_x11_visual_get_xvisual: assertion `visual != NULL' failed 
** (gnome-power-preferences:1447): WARNING **: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory 
** (gnome-power-preferences:1447): WARNING **: Could not connect to DBUS daemon: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory 
** (gnome-power-preferences:1447): WARNING **: Either HAL or DBUS are not working! 
-------------------------------------------------- 
в папке /var/run/dbus/ вообще пусто ...
я так понимаю должна быть запущена какаято служба сообщений dbus или я не правильно настроил xorg.conf ???
так же не работает "управление энергопотреблением" - компьютер не уходит в спящий режим - это 2 разные проблемы или как то связаны между собой : screensaver + dbus + acpi ???

все вроде стоит на что ругается ...

Код: Выделить всё

pavka# pkg_version -v | grep dbus 
dbus-1.0.2_2 = up-to-date with port 
dbus-glib-0.74 = up-to-date with port 
py25-dbus-0.82.3 = up-to-date with port

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
terminus
майор
Сообщения: 2305
Зарегистрирован: 2007-10-29 11:27:35
Откуда: Рига

Re: проблема со скринсевером (гном)

Непрочитанное сообщение terminus » 2008-02-11 14:59:11

echo 'dbus_enable="YES"' >> /etc/rc.conf
Модель: AST-PM-105/0044; Тип: Универсальный, ремонтный; Название: Терминус; Род повреждения: Распад функций; Выводы: Сдать на слом.

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: проблема со скринсевером (гном)

Непрочитанное сообщение manefesto » 2008-02-11 15:00:50

добавь в /etc/rc.conf

Код: Выделить всё

dbus_enable="YES"
И не надо ляля что гном по умолчанию ставится....что выберешь то и поставить.....ставлюсь последнее время через custom
я такой яростный шо аж пиздеЦ
Изображение

PAVka
проходил мимо
Сообщения: 3
Зарегистрирован: 2008-02-11 14:31:18

Re: проблема со скринсевером (гном)

Непрочитанное сообщение PAVka » 2008-02-11 15:31:30

спасибо за советы будем пробовать

может просто не так выразился , просто хотел сказать что установил гном а не кде или *боксы и прописал сразу загрузку в гном (гдм)
я ж только учусь :oops:

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: проблема со скринсевером (гном)

Непрочитанное сообщение manefesto » 2008-02-11 15:56:42

У меня в 7.0rc1 нормально перекодирование флэшки в гноме не работало...зато в кедах замечательно
PS: Я об автомонтировании флэшки
я такой яростный шо аж пиздеЦ
Изображение

PAVka
проходил мимо
Сообщения: 3
Зарегистрирован: 2008-02-11 14:31:18

Re: проблема со скринсевером (гном)

Непрочитанное сообщение PAVka » 2008-02-11 16:31:44

в дебиане вроде все работает - тоже стоит гном
а так пока QT не перейдет на gpl буду на гноме )
до функций автомонтирования в познаниях фрибсд пока не добрался ))