Все вопросы по установке, обновлению и эксплуатации FreeBSD: конфигурация и сопровождение.
Модератор: terminus
Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-16 16:05:47
Ставлю проксю с авторизацией в AD
по статье
http://www.lissyara.su/?id=1375
/etc/krb5.conf
Код: Выделить всё
[libdefaults]
default_realm = COMPANY.BY
[realms]
SRV01.COMPANY.BY = {
kdc = SRV01.COMPANY.BY
admin_server = SRV01.COMPANY.BY
}
[domain_realm]
.fenster.by = COMPANY.BY
[logging]
kdc = FILE:/var/log/krb5kdc.log
admin_server = FILE:/var/log/kadmin.log
default = FILE:/var/log/krb5lib.log
smb.conf
Код: Выделить всё
[global]
workgroup = COMPANY
security = ADS
password server = srv01.COMPANY.BY
realm = COMPANY.BY
netbios name = SQUID
server string = Proxy server of COMPANY
log file = /var/log/samba/%m.%U.log
max log size = 50000
winbind uid = 10000-20000
winbind gid = 10000-20000
winbind use default domain = yes
display charset = koi8-r
unix charset = koi8-r
dos charset = 866
template homedir = /usr/home/%D/%U
template shell=/bin/csh
[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No
use client driver = yes
public = No
собсна билетик получаю нормально.
но ввести в домен не получается
Код: Выделить всё
net join -U administrator
administrator's password:
Using short domain name -- FENSTER
Failed to set servicePrincipalNames. Please ensure that
the DNS domain of this server matches the AD domain,
Or rejoin with using Domain Admin credentials.
Deleted account for 'SQUID' in realm 'FENSTER.BY'
Failed to join domain: Type or value exists
ADS join did not work, falling back to RPC...
Unable to find a suitable server
Unable to find a suitable server
Понятно, что проблема в DNS, но в чем именно?
Larin
-
Хостинг HostFood.ru
-
Хостинг HostFood.ru
Тарифы на хостинг в России, от 12 рублей:
https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.:
https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах:
https://www.host-food.ru/domains/
-
Morty
- ст. лейтенант
- Сообщения: 1370
- Зарегистрирован: 2007-07-17 23:25:12
Сообщение
Morty » 2008-06-16 16:20:54
Morty
-
tango
- Access Forbidden
- Сообщения: 247
- Зарегистрирован: 2007-12-15 17:41:18
- Откуда: Санкт- Петербург
-
Контактная информация:
Сообщение
tango » 2008-06-16 16:22:34
в DNS-е запись для сервера со сквидом есть?
И вообще... сервер со сквидом использует какой днс?... провайдера или доменный?
tango
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-16 16:51:42
tango писал(а):в DNS-е запись для сервера со сквидом есть?
вроде бы нету.
tango писал(а):
И вообще... сервер со сквидом использует какой днс?... провайдера или доменный?
доменный.
Larin
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-16 16:52:47
и что туда прописать?
srv01.company.by и остальные компы пингуются нормально
Larin
-
tango
- Access Forbidden
- Сообщения: 247
- Зарегистрирован: 2007-12-15 17:41:18
- Откуда: Санкт- Петербург
-
Контактная информация:
Сообщение
tango » 2008-06-16 16:55:34
Larin писал(а):tango писал(а):в DNS-е запись для сервера со сквидом есть?
вроде бы нету.
Ну так добавьте.
tango
-
tango
- Access Forbidden
- Сообщения: 247
- Зарегистрирован: 2007-12-15 17:41:18
- Откуда: Санкт- Петербург
-
Контактная информация:
Сообщение
tango » 2008-06-16 16:57:28
Larin писал(а):
и что туда прописать?
прописать соответствие ip-адреса прокси-сервера и его доменного имени.
tango
-
Morty
- ст. лейтенант
- Сообщения: 1370
- Зарегистрирован: 2007-07-17 23:25:12
Сообщение
Morty » 2008-06-16 17:36:27
можно для страховки еще и соответствие АДсрв с ип адрессом в хостс прописать
и ДНС срв если это другой таз тоже можно прописать, хуже от этого не будет
Morty
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-16 18:19:23
tango писал(а):Larin писал(а):
и что туда прописать?
прописать соответствие ip-адреса прокси-сервера и его доменного имени.
спс. завтра попробую.
Larin
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-23 14:28:37
блин...в домен входит, но сквид падает в кору. млять

Larin
-
Morty
- ст. лейтенант
- Сообщения: 1370
- Зарегистрирован: 2007-07-17 23:25:12
Сообщение
Morty » 2008-06-23 14:53:42
в логах что-нибудь есть ?
Morty
-
Alex Keda
- стреляли...
- Сообщения: 35504
- Зарегистрирован: 2004-10-18 14:25:19
- Откуда: Made in USSR
-
Контактная информация:
Сообщение
Alex Keda » 2008-06-23 15:55:50
лишняя опция при компиляции.
у меня такое было когда-чё-то навыбирал не то...
Убей их всех! Бог потом рассортирует...
Alex Keda
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-23 16:02:03
Morty писал(а):в логах что-нибудь есть ?
вообщем ругается на то, что в папке /usr/local/etc/squid/errors/Russian-1251
нет файлика ERR_BAD_NETWORKS ну и других, что в конфиге прописаны...
меняю на другие...
Последний раз редактировалось
Larin 2008-06-23 16:14:08, всего редактировалось 2 раза.
Larin
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-23 16:02:44
lissyara писал(а):лишняя опция при компиляции.
у меня такое было когда-чё-то навыбирал не то...
у меня в окошке ничего не выбрано...
Larin
-
Alex Keda
- стреляли...
- Сообщения: 35504
- Зарегистрирован: 2004-10-18 14:25:19
- Откуда: Made in USSR
-
Контактная информация:
Сообщение
Alex Keda » 2008-06-23 16:09:11
однако, поддержку AD неплохо бы выбрать...
Убей их всех! Бог потом рассортирует...
Alex Keda
-
Larin
- лейтенант
- Сообщения: 975
- Зарегистрирован: 2008-01-29 20:08:41
- Откуда: РБ, Минск
Сообщение
Larin » 2008-06-23 16:22:35
lissyara писал(а):однако, поддержку AD неплохо бы выбрать...
поменял в конфиге все на ERR_CONNECT_FAIL и сквид стартанул..
файлики с ошибками потом сам нарисую..
Larin