Вопрос студента php5-5.2.9 и php5-extensions-1.3

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
gooody
проходил мимо

Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение gooody » 2009-06-22 16:52:42

Доброе время суток
прошу сильно не пинать .... я только учусь :oops:

вотьь есть FreeBSD, пытаюсь поставить из пакаджей php5-5.2.9 и php5-extensions-1.3
и php5-extensions-1.3, который требует php5-5.2.3.tbz

как можно обойти проблему расхождения версий? :oops:


PS дерево портов обновлял
PS2 php5-5.2.3 в портах нет :oops:

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение zg » 2009-06-22 16:55:36

gooody писал(а):как можно обойти проблему расхождения версий?
гм... дак нету такой проблемы. Ставишь пхп, потом экстеншины и всё пашет на ура. :smile:

gooody29
проходил мимо
Сообщения: 6
Зарегистрирован: 2009-06-22 15:34:58

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение gooody29 » 2009-06-22 17:07:37

может я чего то не понимаю ..... но
cd usr/ports/lang/php5
make install clean

//устанавливается php5-5.2.9


cd usr/ports/lang/php5-extensions
make install clean
//для установки php5-extensions-1.3

а оно пишет, ффто у вас мол php5-5.2.9, а надо php5-5.2.3
и выходит из инстала

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение zg » 2009-06-22 17:20:48

gooody29 писал(а):а оно пишет, ффто у вас мол php5-5.2.9, а надо php5-5.2.3
ошибку выложи полностью

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение hizel » 2009-06-22 17:35:17

pkg_info | grep php
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1398
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение server801 » 2009-06-22 19:19:16

пакаджами такие вещи не ставят.

gooody29
проходил мимо
Сообщения: 6
Зарегистрирован: 2009-06-22 15:34:58

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение gooody29 » 2009-06-22 19:32:54

ффот при попытке из портов ...

Код: Выделить всё

checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for dpopen in -lqdbm... yes
checking for QDBM support... yes
checking for gdbm support... configure: error: You cannot combine --with-gdbm wi              th --with-qdbm
===>  Script "configure" failed unexpectedly.
Please report the problem to ale@FreeBSD.org [maintainer] and attach the
"/usr/ports/databases/php5-dba/work/php-5.2.9/ext/dba/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/databases/php5-dba.
*** Error code 1

Stop in /usr/ports/databases/php5-dba.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.
:oops:

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1398
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение server801 » 2009-06-22 19:41:05

так пых то стоит?пожалуйста -ставьте из портов.дайте вывод

Код: Выделить всё

cd /usr/ports/lang/php5
make showconfig
или 
make config

gooody29
проходил мимо
Сообщения: 6
Зарегистрирован: 2009-06-22 15:34:58

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение gooody29 » 2009-06-22 19:45:29

#make showconfig

===> The following configuration options are available for php5-5.2.9:
CLI=on "Build CLI version"
CGI=on "Build CGI version"
APACHE=on "Build Apache module"
DEBUG=on "Enable debug"
SUHOSIN=on "Enable Suhosin protection system (not for jails)"
MULTIBYTE=on "Enable zend multibyte support"
IPV6=off "Enable ipv6 support"
MAILHEAD=on "Enable mail header patch"
REDIRECT=off "Enable force-cgi-redirect support (CGI only)"
DISCARD=on "Enable discard-path support (CGI only)"
FASTCGI=on "Enable fastcgi support (CGI only)"
PATHINFO=on "Enable path-info-check support (CGI only)"
===> Use 'make config' to modify these settings

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1398
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение server801 » 2009-06-22 20:14:55

Код: Выделить всё

cd /usr/ports/databases/php5-dba
make config
дай ка
Последний раз редактировалось server801 2009-06-22 20:43:49, всего редактировалось 1 раз.

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение zg » 2009-06-22 20:43:35

server801 писал(а):пакаджами такие вещи не ставят.
:smile: пакадж — это скомпилированный порт... какбэ :roll:
server801 писал(а):gdb library галка по моему лишняя
гм... это хде такое дают? :smile:

Код: Выделить всё

zg# grep -i gdb /usr/ports/lang/php5-extensions/Makefile
zg# grep -i gdb /usr/ports/lang/php5/Makefile
zg#
gooody29 писал(а):checking for gdbm support... configure: error: You cannot combine --with-gdbm wi              th --with-qdbm
не в версиях дело, галок ты лишних понаставил в экстеншинах. Вобщем

Код: Выделить всё

make -C/usr/ports/lang/php5-extensions/ clean config install clean
из опций нужно обязательно поставить:
1. GD
2. XML XSLT
3. MYSQL
4. MBSTRING
5. PCRE
6. SESSION
7. ICONV
8. PDO
9. ZLIB и ZIP
остальное по выбору, но если не уверен, то лучше не ставь галку.

И когда при компиляции вылезет опция BUNDLED_PCRE галку обязательно поставь, иначе проблемы будут.

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1398
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение server801 » 2009-06-22 20:47:48

скомпилированный,но с какими опциями?я перепутал,ссори,gd4 .если галка стояла -то же ошибка вылезала.

Аватара пользователя
armadex
мл. сержант
Сообщения: 111
Зарегистрирован: 2007-11-07 21:29:33
Откуда: Ukraine, Кривой Рог
Контактная информация:

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение armadex » 2009-06-22 20:52:11

вот и весь ответ

Код: Выделить всё

checking for gdbm support... configure: error: [b]You cannot combine --with-gdbm wi              th --with-qdbm[/b]
Автор благодарит алфавит за любезно предоставленные буквы!

zg
полковник
Сообщения: 5845
Зарегистрирован: 2007-12-07 13:51:33
Откуда: Верх-Нейвинск

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение zg » 2009-06-22 21:01:07

server801 писал(а):скомпилированный,но с какими опциями?
это не имеет значения, система портов работает только с установленными пакетами. Екстеншины — это метапорт, который только и делает, что тянет зависимости.

у топикстартера проблема в dba, который и нафиг никому не нужен.
armadex писал(а):вот и весь ответ
угу,

Код: Выделить всё

     ??????????????????????????????????????????????????????????????????????
     ?                    Options for php5-dba 5.2.9                      ?
     ? ?????????????????????????????????????????????????????????????????? ?
     ? ?              [X] CDB       cdb database support                ? ?
     ? ?              [ ] DB4       Berkeley DB4 support                ? ?
     ? ?              [ ] GDBM      GDBM database support               ? ?
     ? ?              [ ] QDBM      QDBM database support               ? ?
     ? ?              [X] INIFILE   INI file support                    ? ?
     ? ?              [X] FLATFILE  flatfile support                    ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ? ?                                                                ? ?
     ??????????????????????????????????????????????????????????????????????
     ?                       [  OK  ]       Cancel                        ?
     ??????????????????????????????????????????????????????????????????????


нада просто галку с dba снять и всё будет ок :roll:

gooody29
проходил мимо
Сообщения: 6
Зарегистрирован: 2009-06-22 15:34:58

Re: Вопрос студента php5-5.2.9 и php5-extensions-1.3

Непрочитанное сообщение gooody29 » 2009-06-23 9:53:17

Все заработало
ВСЕМ БОЛЬФФОЕ СПАСИБО :)
вот, устанавливается нормально .... :) :) :)


Век живи - Век учись.....

ох и трудно переходить на нормальную систему после 10-ти лет под форточками....