apache-1.3.42_1 is forbidden: CVE-2011-3368

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Ridik5533
рядовой
Сообщения: 39
Зарегистрирован: 2011-12-20 18:16:11
Откуда: Киев

apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Ridik5533 » 2011-12-22 17:37:00

uname -a
#
8.2-RELEASE FreeBSD 8.2-RELEASE #0: Wed Dec 21 11:5 5:10 EET 2011
при установки apache13
# cd /usr/ports/www/apache13
# /usr/ports/www/apache13/> make install clean
===> apache-1.3.42_1 is forbidden: CVE-2011-3368, no patches against this issue .
*** Error code 1

Stop in /usr/ports/www/apache13.
Скажите что делать? Здесь говорится что apache-1.3.42_1 запрещён. Запрещён он CVE'мом, поскольку имеет уязвимости. Как отключить CVE чтобы не ставить apache22?
Надо именн apache13!!!

HELP!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Electronik
капитан
Сообщения: 1593
Зарегистрирован: 2008-11-15 17:32:56
Откуда: Минск
Контактная информация:

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Electronik » 2011-12-22 20:12:06

никак.
"1) Либо осознать, что такое CVE и поискать, как отключить проверку и всё-таки втиснуть апач-1.3
2) Либо осознать, что такое CVE и что такое apache-1.3 и поставить apache-2.x"(С)
google рулит
Предскажем будущее hw по логам и дампу, снимем сглаз и порчу с рута, поможем придумать пароль(С)
Блог

immortal
мл. сержант
Сообщения: 109
Зарегистрирован: 2011-11-10 6:11:34

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение immortal » 2011-12-23 4:17:48

У меня была такая проблема, почитав тырнет и форумы, понял что поддержка апача 1.3 прикрылась. Лечиться установкой 2.2

awgoor
мл. сержант
Сообщения: 132
Зарегистрирован: 2011-04-07 12:42:15

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение awgoor » 2011-12-23 7:29:17

apache-1.3 Перестарается поддерживаться в портах. Просто став те 2.2

Аватара пользователя
Ridik5533
рядовой
Сообщения: 39
Зарегистрирован: 2011-12-20 18:16:11
Откуда: Киев

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Ridik5533 » 2011-12-23 10:35:10

может кто знает как отключить эту проверку CVE? просто надо установить apache-1.3!

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение manefesto » 2011-12-23 12:26:41

вручку поправь Makefile
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
Ridik5533
рядовой
Сообщения: 39
Зарегистрирован: 2011-12-20 18:16:11
Откуда: Киев

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Ridik5533 » 2011-12-23 13:56:31

и где находиться этот Makefile?

Аватара пользователя
Electronik
капитан
Сообщения: 1593
Зарегистрирован: 2008-11-15 17:32:56
Откуда: Минск
Контактная информация:

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Electronik » 2011-12-23 14:35:43

в папке с портом
Предскажем будущее hw по логам и дампу, снимем сглаз и порчу с рута, поможем придумать пароль(С)
Блог

Аватара пользователя
Ridik5533
рядовой
Сообщения: 39
Зарегистрирован: 2011-12-20 18:16:11
Откуда: Киев

Re: apache-1.3.42_1 is forbidden: CVE-2011-3368

Непрочитанное сообщение Ridik5533 » 2011-12-23 15:11:08

Спасибо, разобрался! для тех кто сталкнеться:

# ee /usr/ports/www/apache13/Makefile
FORBIDDEN= CVE-2011-3368, no patches against this issue
DEPRECATED= apache13 is deprecated, migrate to 2.2.x+ now
EXPIRATION_DATE= 2012-01-01
надо закоментировать #
#FORBIDDEN= CVE-2011-3368, no patches against this issue
и все, дальше как обычно
# cd /usr/ports/www/apache13
# make install clean
# rehash
Отдельное спасибо Electronik за наставление! А также manefesto=)