desktop не могу запустить иксы на nVidia GT 610

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
nekkto
проходил мимо
Сообщения: 3
Зарегистрирован: 2016-10-23 22:43:07

desktop не могу запустить иксы на nVidia GT 610

Непрочитанное сообщение nekkto » 2016-10-24 0:37:19

Привет форумчане, я новичек во freebsd. Хочу поставить на десктоп, сейчас стоит дебиан. Вообще-то всегда разбирался сам - гугл выручал. А тут что-то не могу найти решения уже второй день убил.

Систему ставил из портов. При установке отметил флаг "Linux..." . После установки xorg сконфигурировал xorg.conf при помощи nvidia-xconfig. При попытке запуска иксов хоть от юзера хоть от рута просто гаснет экран вверху слева виден прямоугольник курсора и курсор мыши замирает. Добавил дополнительные секции которые учитывают второй видеовыход и второй монитор. Однако ничего не помогло.

прикладываю xogr.conf:

Код: Выделить всё

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.35  (root@asbsd)  Sun Oct 23 14:43:14 EEST 2016

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0"
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    "AllowEmptyInput"   "off"
    InputDevice    "Mouse0" "CorePointer"
    "AllowEmptyInput"   "off"
#    Option "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us,ru,gr"
    Option         "XkbVariant" "winkeys"
    Option         "XkbOptions" "grp:caps_toggle"

EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "NVIDIA Corporation"
    ModelName      "2209WA"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
#    Option         "PreferredMode" "1650x1050"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "NVIDIA Corporation"
    ModelName      "U2410"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
#    Option         "PreferredMode" "1920x1200"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us,ru,gr"
    Option         "XkbVariant" "winkeys"
    Option         "XkbOptions" "grp:caps_toggle"

EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "NVIDIA Corporation"
    ModelName      "2209WA"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
#    Option         "PreferredMode" "1650x1050"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "NVIDIA Corporation"
    ModelName      "U2410"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
#    Option         "PreferredMode" "1920x1200"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "On"
#    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1650x1050 +0+0"
    Option         "TwinViewOrientation" "LeftOf"
    SubSection     "Display"
#        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "On"
#    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-1: 1920x1200 +0+0"
    SubSection     "Display"
#        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
Xorg.0.log:

быть может причина в

Код: Выделить всё

[  3605.360] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
но в портах его нет, на сайте Xorg
https://www.x.org/wiki/VgaArbiter/ есть инструкция, но видимо это только для линукс, так думаю потому, что в моей установленной фре нет директории /opt необходимой для

Код: Выделить всё

export PKG_CONFIG_PATH=/opt/master/lib/pkgconfig

Код: Выделить всё

[  3605.319] 
X.Org X Server 1.17.4
Release Date: 2015-10-28
[  3605.319] X Protocol Version 11, Revision 0
[  3605.319] Build Operating System: FreeBSD 11.0-RELEASE-p1 amd64 
[  3605.319] Current Operating System: FreeBSD bsd.org 11.0-RELEASE-p1 FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
[  3605.320] Build Date: 23 October 2016  12:03:10PM
[  3605.320]  
[  3605.320] Current version of pixman: 0.34.0
[  3605.320] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  3605.320] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3605.320] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 23 20:08:33 2016
[  3605.320] (==) Using config file: "/etc/X11/xorg.conf"
[  3605.320] (==) ServerLayout "X.org Configured"
[  3605.320] (**) |-->Screen "Screen0" (0)
[  3605.320] (**) |   |-->Monitor "Monitor0"
[  3605.320] (**) |   |-->Device "Device0"
[  3605.321] (**) |-->Screen "Screen1" (1)
[  3605.321] (**) |   |-->Monitor "Monitor1"
[  3605.321] (**) |   |-->Device "Device1"
[  3605.321] (**) |-->Input Device "Keyboard0"
[  3605.321] (**) |-->Input Device "Mouse0"
[  3605.321] (==) Automatically adding devices
[  3605.321] (==) Automatically enabling devices
[  3605.321] (==) Not automatically adding GPU devices
[  3605.321] (==) FontPath set to:
	/usr/local/share/fonts/misc/,
	/usr/local/share/fonts/TTF/,
	/usr/local/share/fonts/OTF/,
	/usr/local/share/fonts/Type1/,
	/usr/local/share/fonts/100dpi/,
	/usr/local/share/fonts/75dpi/
[  3605.321] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[  3605.321] (**) Extension "Composite" is disabled
[  3605.321] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3605.321] (WW) Disabling Keyboard0
[  3605.321] (WW) Disabling Mouse0
[  3605.321] (II) Loader magic: 0x8112f0
[  3605.321] (II) Module ABI versions:
[  3605.321] 	X.Org ANSI C Emulation: 0.4
[  3605.321] 	X.Org Video Driver: 19.0
[  3605.321] 	X.Org XInput driver : 21.0
[  3605.321] 	X.Org Server Extension : 9.0
[  3605.321] (--) PCI:*(0:6:0:0) 10de:104a:1043:840d rev 161, Mem @ 0xfd000000/16777216, 0xe0000000/134217728, 0xec000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/65536
[  3605.322] (II) LoadModule: "glx"
[  3605.322] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[  3605.332] (II) Module glx: vendor="NVIDIA Corporation"
[  3605.332] 	compiled for 4.0.2, module version = 1.0.0
[  3605.332] 	Module class: X.Org Server Extension
[  3605.332] (II) NVIDIA GLX Module  367.44  Wed Aug 17 22:01:17 PDT 2016
[  3605.332] (II) LoadModule: "nvidia"
[  3605.332] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[  3605.333] (II) Module nvidia: vendor="NVIDIA Corporation"
[  3605.333] 	compiled for 4.0.2, module version = 1.0.0
[  3605.333] 	Module class: X.Org Video Driver
[  3605.333] (II) NVIDIA dlloader X Driver  367.44  Wed Aug 17 21:41:06 PDT 2016
[  3605.333] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  3605.333] (--) Using syscons driver with X support (version 16777218.0)
[  3605.333] (--) using VT number 9

[  3605.359] (II) Loading sub module "fb"
[  3605.359] (II) LoadModule: "fb"
[  3605.359] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[  3605.359] (II) Module fb: vendor="X.Org Foundation"
[  3605.359] 	compiled for 1.17.4, module version = 1.0.0
[  3605.359] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  3605.359] (II) Loading sub module "wfb"
[  3605.359] (II) LoadModule: "wfb"
[  3605.360] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[  3605.360] (II) Module wfb: vendor="X.Org Foundation"
[  3605.360] 	compiled for 1.17.4, module version = 1.0.0
[  3605.360] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  3605.360] (II) Loading sub module "ramdac"
[  3605.360] (II) LoadModule: "ramdac"
[  3605.360] (II) Module "ramdac" already built-in
[  3605.360] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  3605.360] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  3605.360] (==) NVIDIA(0): RGB weight 888
[  3605.360] (==) NVIDIA(0): Default visual is TrueColor
[  3605.360] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  3605.361] (**) NVIDIA(0): Option "TwinViewOrientation" "LeftOf"
[  3605.361] (**) NVIDIA(0): Option "MetaModes" "DFP-0: 1650x1050 +0+0"
[  3605.361] (**) NVIDIA(1): Option "MetaModes" "DFP-1: 1920x1200 +0+0"
[  3605.361] (**) NVIDIA(0): Enabling 2D acceleration
[  3605.764] (II) NVIDIA(0): NVIDIA GPU GeForce GT 610 (GF119) at PCI:6:0:0 (GPU-0)
[  3605.764] (--) NVIDIA(0): Memory: 1048576 kBytes
[  3605.764] (--) NVIDIA(0): VideoBIOS: 75.19.55.00.02
[  3605.764] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  3605.764] (II) NVIDIA(0): Validated MetaModes:
[  3605.764] (II) NVIDIA(0):     "NULL"
[  3605.764] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[  3605.764] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[  3605.764] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  3605.764] (**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
[  3605.764] (==) NVIDIA(1): RGB weight 888
[  3605.764] (==) NVIDIA(1): Default visual is TrueColor
[  3605.764] (==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
[  3605.764] (II) NVIDIA(1): NVIDIA GPU GeForce GT 610 (GF119) at PCI:6:0:0 (GPU-0)
[  3605.764] (--) NVIDIA(1): Memory: 1048576 kBytes
[  3605.764] (--) NVIDIA(1): VideoBIOS: 75.19.55.00.02
[  3605.764] (II) NVIDIA(1): Detected PCI Express Link width: 16X
[  3605.764] (II) NVIDIA(1): Validated MetaModes:
[  3605.764] (II) NVIDIA(1):     "NULL"
[  3605.764] (II) NVIDIA(1): Virtual screen size determined to be 640 x 480
[  3605.764] (WW) NVIDIA(1): Unable to get display device for DPI computation.
[  3605.764] (==) NVIDIA(1): DPI set to (75, 75); computed from built-in default
[  3605.765] (--) Depth 24 pixmap format is 32 bpp
[  3605.765] (II) NVIDIA: Reserving 12288.00 MB of virtual memory for indirect memory
[  3605.765] (II) NVIDIA:     access.
[  3605.788] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[  3605.788] (II) NVIDIA(0): Setting mode "NULL"
[  3605.793] (==) NVIDIA(0): Disabling shared memory pixmaps
[  3605.793] (==) NVIDIA(0): Backing store disabled
[  3605.793] (==) NVIDIA(0): Silken mouse enabled
[  3605.794] (**) NVIDIA(0): DPMS enabled
[  3605.794] (WW) NVIDIA(0): Option "TwinView" is not used
[  3605.794] (II) Loading sub module "dri2"
[  3605.794] (II) LoadModule: "dri2"
[  3605.794] (II) Module "dri2" already built-in
[  3605.794] (II) NVIDIA(0): [DRI2] Setup complete
[  3605.794] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  3605.794] (--) RandR disabled
[  3605.817] (II) NVIDIA(1): Built-in logo is bigger than the screen.
[  3605.818] (II) NVIDIA(1): Setting mode "NULL"
[  3605.820] (==) NVIDIA(1): Disabling shared memory pixmaps
[  3605.820] (==) NVIDIA(1): Backing store disabled
[  3605.820] (==) NVIDIA(1): Silken mouse enabled
[  3605.821] (**) NVIDIA(1): DPMS enabled
[  3605.821] (WW) NVIDIA(1): Option "TwinView" is not used
[  3605.821] (II) Loading sub module "dri2"
[  3605.821] (II) LoadModule: "dri2"
[  3605.821] (II) Module "dri2" already built-in
[  3605.821] (II) NVIDIA(1): [DRI2] Setup complete
[  3605.821] (II) NVIDIA(1): [DRI2]   VDPAU driver: nvidia
[  3605.821] (--) RandR disabled
[  3605.821] (II) Initializing extension GLX
[  3605.821] (II) Indirect GLX disabled.
[  3605.935] (II) config/devd: probing input devices...
[  3605.935] (II) config/devd: adding input device (null) (/dev/kbdmux)
[  3605.935] (II) LoadModule: "kbd"
[  3605.935] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[  3605.935] (II) Module kbd: vendor="X.Org Foundation"
[  3605.935] 	compiled for 1.17.4, module version = 1.8.1
[  3605.935] 	Module class: X.Org XInput Driver
[  3605.935] 	ABI class: X.Org XInput driver, version 21.0
[  3605.935] (II) Using input driver 'kbd' for 'kbdmux'
[  3605.935] (**) kbdmux: always reports core events
[  3605.935] (**) kbdmux: always reports core events
[  3605.936] (**) Option "Protocol" "standard"
[  3605.936] (**) Option "XkbRules" "base"
[  3605.936] (**) Option "XkbModel" "pc105"
[  3605.936] (**) Option "XkbLayout" "us"
[  3605.936] (**) Option "config_info" "devd:kbdmux"
[  3605.936] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[  3605.952] (II) config/devd: kbdmux is enabled, ignoring device ukbd0
[  3605.952] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[  3605.953] (II) config/devd: adding input device (null) (/dev/sysmouse)
[  3605.953] (II) LoadModule: "mouse"
[  3605.953] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[  3605.953] (II) Module mouse: vendor="X.Org Foundation"
[  3605.953] 	compiled for 1.17.4, module version = 1.9.1
[  3605.953] 	Module class: X.Org XInput Driver
[  3605.953] 	ABI class: X.Org XInput driver, version 21.0
[  3605.953] (II) Using input driver 'mouse' for 'sysmouse'
[  3605.953] (**) sysmouse: always reports core events
[  3605.953] (**) Option "Device" "/dev/sysmouse"
[  3605.953] (==) sysmouse: Protocol: "Auto"
[  3605.953] (**) sysmouse: always reports core events
[  3605.953] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[  3605.953] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[  3605.953] (**) sysmouse: Buttons: 5
[  3605.953] (**) Option "config_info" "devd:sysmouse"
[  3605.954] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[  3605.954] (**) sysmouse: (accel) keeping acceleration scheme 1
[  3605.954] (**) sysmouse: (accel) acceleration profile 0
[  3605.954] (**) sysmouse: (accel) acceleration factor: 2.000
[  3605.954] (**) sysmouse: (accel) acceleration threshold: 4
[  3605.954] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[  3605.954] (II) sysmouse: SetupAuto: protocol is SysMouse
[  3605.954] (II) config/devd: device /dev/ums0 already opened
[  3615.555] (II) config/devd: terminating backend...
[  3615.556] (II) UnloadModule: "mouse"
[  3615.556] (II) UnloadModule: "kbd"
[  3615.807] (II) NVIDIA(GPU-0): Deleting GPU-0
[  3615.809] (II) Server terminated successfully (0). Closing log file.
выхлоп uname -ra:

Код: Выделить всё

11.0-RELEASE-p1
FreeBSD bsd.org 11.0-RELEASE-p1 FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
выхлоп dmesg:

Код: Выделить всё

Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016
    root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)
VT(vga): resolution 640x480
CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (2404.16-MHz K8-class CPU)
  Origin="GenuineIntel"  Id=0x6fb  Family=0x6  Model=0xf  Stepping=11
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0xe3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM>
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
  VT-x: HLT,PAUSE
  TSC: P-state invariant, performance statistics
real memory  = 8589934592 (8192 MB)
avail memory = 8231583744 (7850 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <A_M_I_ OEMAPIC >
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s)
random: unblocking device.
ioapic0 <Version 2.0> irqs 0-23 on motherboard
random: entropy device external interface
kbd1 at kbdmux0
netmap: loaded module
module_register_init: MOD_LOAD (vesa, 0xffffffff8101c950, 0) error 19
vtvga0: <VT VGA driver> on motherboard
cryptosoft0: <software crypto> on motherboard
acpi0: <A_M_I_ OEMXSDT> on motherboard
acpi0: Power Button (fixed)
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 450
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0xcc00-0xcc7f mem 0xfd000000-0xfdffffff,0xe0000000-0xe7ffffff,0xec000000-0xedffffff irq 16 at device 0.0 on pci1
nvidia0: <GeForce GT 610> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: Boot video device
hdac0: <NVIDIA GF119 HDA Controller> mem 0xfea7c000-0xfea7ffff irq 17 at device 0.1 on pci1
hdac1: <Intel 82801G HDA Controller> mem 0xfebfc000-0xfebfffff irq 19 at device 27.0 on pci0
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pcib2: [GIANT-LOCKED]
pcib3: <ACPI PCI-PCI bridge> irq 19 at device 28.3 on pci0
pci2: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> irq 16 at device 28.4 on pci0
pci3: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> irq 17 at device 28.5 on pci0
pci4: <ACPI PCI bus> on pcib5
ahci0: <JMicron JMB363 AHCI SATA controller> mem 0xfc6fe000-0xfc6fffff irq 17 at device 0.0 on pci4
ahci0: AHCI v1.00 with 2 3Gbps ports, Port Multiplier supported
ahci0: quirks=0x8001<NOFORCE,SATA1_UNIT0>
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich1: <AHCI channel> at channel 1 on ahci0
atapci0: <JMicron JMB363 UDMA133 controller> port 0x9c00-0x9c07,0x9880-0x9883,0x9800-0x9807,0x9480-0x9483,0x9400-0x940f at device 0.1 on pci4
ata2: <ATA channel> at channel 0 on atapci0
uhci0: <Intel 82801G (ICH7) USB controller USB-A> port 0xe480-0xe49f irq 20 at device 29.0 on pci0
uhci0: LegSup = 0x2f00
usbus0 on uhci0
uhci1: <Intel 82801G (ICH7) USB controller USB-B> port 0xe800-0xe81f irq 17 at device 29.1 on pci0
uhci1: LegSup = 0x2f00
usbus1 on uhci1
uhci2: <Intel 82801G (ICH7) USB controller USB-C> port 0xe880-0xe89f irq 18 at device 29.2 on pci0
uhci2: LegSup = 0x2f00
usbus2 on uhci2
uhci3: <Intel 82801G (ICH7) USB controller USB-D> port 0xec00-0xec1f irq 19 at device 29.3 on pci0
uhci3: LegSup = 0x2f00
usbus3 on uhci3
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xfebfbc00-0xfebfbfff irq 20 at device 29.7 on pci0
usbus4: EHCI version 1.0
usbus4 on ehci0
pcib6: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci5: <ACPI PCI bus> on pcib6
pci5: <serial bus, FireWire> at device 3.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
ata0: <ATA channel> at channel 0 on atapci1
atapci2: <Intel ICH7 SATA300 controller> port 0xe400-0xe407,0xe080-0xe083,0xe000-0xe007,0xdc00-0xdc03,0xd880-0xd88f mem 0xfebfb800-0xfebfbbff irq 23 at device 31.2 on pci0
ata3: <ATA channel> at channel 0 on atapci2
ata4: <ATA channel> at channel 1 on atapci2
acpi_button0: <Power Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcdfff,0xce000-0xd0fff on isa0
ppc0: cannot reserve I/O port range
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr 928092806000928
device_attach: est0 attach returned 6
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr 928092806000928
device_attach: est1 attach returned 6
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr 928092806000928
device_attach: est2 attach returned 6
est3: <Enhanced SpeedStep Frequency Control> on cpu3
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr 928092806000928
device_attach: est3 attach returned 6
usbus0: 12Mbps Full Speed USB v1.0
ZFS filesystem version: 5
ZFS storage pool version: features support (5000)
Timecounters tick every 1.000 msec
nvme cam probe device init
hdacc0: <NVIDIA (0x001c) HDA CODEC> at cad 0 on hdac0
hdaa0: <NVIDIA (0x001c) Audio Function Group> at nid 1 on hdacc0
pcm0: <NVIDIA (0x001c) (HDMI/DP 8ch)> at nid 4 on hdaa0
pcm1: <NVIDIA (0x001c) (HDMI/DP 8ch)> at nid 5 on hdaa0
hdacc1: <Realtek ALC882 HDA CODEC> at cad 0 on hdac1
hdaa1: <Realtek ALC882 Audio Function Group> at nid 1 on hdacc1
pcm2: <Realtek ALC882 (Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26,28 on hdaa1
pcm3: <Realtek ALC882 (Front Analog)> at nid 27 and 25 on hdaa1
pcm4: <Realtek ALC882 (Rear Digital)> at nid 30 on hdaa1
usbus2: 12Mbps Full Speed USB v1.0
ugen0.1: <Intel> at usbus0
ugen2.1: <Intel> at usbus2
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
usbus4: 480Mbps High Speed USB v2.0
usbus1: 12Mbps Full Speed USB v1.0
ugen4.1: <Intel> at usbus4
ugen1.1: <Intel> at usbus1
uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus4
uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
usbus3: 12Mbps Full Speed USB v1.0
ugen3.1: <Intel> at usbus3
uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
ada0 at ata0 bus 0 scbus3 target 0 lun 0
ada0: <WDC WD800JB-00JJC0 05.01C05> ATA-6 device
ada0: Serial Number WD-WCAM9P392202
ada0: 100.000MB/s transfers (UDMA5, PIO 8192bytes)
ada0: 76319MB (156301488 512 byte sectors)
ada1 at ata3 bus 0 scbus4 target 0 lun 0
uhub4: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
cd0 at ahcich1 bus 0 scbus1 target 0 lun 0
SMP: AP CPU #3 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #1 Launched!
cd0: <Optiarc DVD RW AD-7240S 1.03> Removable CD-ROM SCSI device
cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO 8192bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
Trying to mount root from zfs:zroot/ROOT/default []...
uhub2: 8 ports with 8 removable, self powered
ugen4.2: <vendor 0x0424> at usbus4
uhub5: <vendor 0x0424 product 0x2514, class 9/0, rev 2.00/0.00, addr 2> on usbus4
uhub5: MTT enabled
uhub5: 4 ports with 4 removable, self powered
ugen4.3: <vendor 0x0424> at usbus4
uhub6: <vendor 0x0424 product 0x2514, class 9/0, rev 2.00/0.00, addr 3> on usbus4
uhub6: MTT enabled
uhub6: 3 ports with 2 removable, self powered
Root mount waiting for: usbus4
ugen4.4: <vendor 0x0424> at usbus4
uhub7: <vendor 0x0424 product 0x2640, class 9/0, rev 2.00/0.00, addr 4> on usbus4
uhub7: 3 ports with 2 removable, self powered
Root mount waiting for: usbus4
Root mount waiting for: usbus4
ugen4.5: <Generic> at usbus4
umass0: <Generic Ultra Fast Media Reader, class 0/0, rev 2.00/1.82, addr 5> on usbus4
umass0:  SCSI over Bulk-Only; quirks = 0xc100
umass0:6:0: Attached to scbus6
da0 at umass-sim0 bus 0 scbus6 target 0 lun 0
da0: <Generic Ultra HS-SD/MMC 1.82> Removable Direct Access SCSI device
da0: Serial Number 000000264001
da0: 40.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
da0: quirks=0x2<NO_6_BYTE>
Root mount waiting for: usbus4
ugen4.6: <vendor 0x05e3> at usbus4
uhub8: <vendor 0x05e3 USB2.0 Hub, class 9/0, rev 2.00/7.02, addr 6> on usbus4
Root mount waiting for: usbus4
ugen1.2: <Logitech> at usbus1
ukbd0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 2> on usbus1
kbd2 at ukbd0
uhub8: 4 ports with 4 removable, self powered
Root mount waiting for: usbus4
ugen1.3: <vendor 0x0556> at usbus1
ugen4.7: <vendor 0x0bda> at usbus4
msk0: link state changed to DOWN
msk0: link state changed to UP
ums0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 2> on usbus1
urtw0: <vendor 0x0bda product 0x8187, class 0/0, rev 2.00/1.00, addr 7> on usbus4
urtw0: unknown RTL8187L type: 0x8000000
ums0: 16 buttons and [XYZT] coordinates ID=2
uhid0: <Logitech USB Receiver, class 0/0, rev 2.00/12.03, addr 2> on usbus1
uaudio0: <vendor 0x0556 product 0x0001, class 0/0, rev 1.10/0.01, addr 3> on usbus1
uaudio0: No playback.
uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 44100 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 22050 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 11025 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: Record: 8000 Hz, 1 ch, 16-bit S-LE PCM format, 2x8ms buffer.
uaudio0: No MIDI sequencer.
pcm5: <USB audio> on uaudio0
uaudio0: No HID volume keys found.
urtw0: rtl8187l rf rtl8225u hwrev none
выхлоп pciconf -lv:

Код: Выделить всё

hostb0@pci0:0:0:0:	class=0x060000 card=0x81781043 chip=0x277c8086 rev=0xc0 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82975X Memory Controller Hub'
    class      = bridge
    subclass   = HOST-PCI
pcib1@pci0:0:1:0:	class=0x060400 card=0x00008086 chip=0x277d8086 rev=0xc0 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82975X PCI Express Root Port'
    class      = bridge
    subclass   = PCI-PCI
hdac1@pci0:0:27:0:	class=0x040300 card=0x81d81043 chip=0x27d88086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family High Definition Audio Controller'
    class      = multimedia
    subclass   = HDA
pcib2@pci0:0:28:0:	class=0x060400 card=0x81791043 chip=0x27d08086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family PCI Express Port 1'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:3:	class=0x060400 card=0x81791043 chip=0x27d68086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family PCI Express Port 4'
    class      = bridge
    subclass   = PCI-PCI
pcib4@pci0:0:28:4:	class=0x060400 card=0x81791043 chip=0x27e08086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801GR/GH/GHM (ICH7 Family) PCI Express Port 5'
    class      = bridge
    subclass   = PCI-PCI
pcib5@pci0:0:28:5:	class=0x060400 card=0x81791043 chip=0x27e28086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801GR/GH/GHM (ICH7 Family) PCI Express Port 6'
    class      = bridge
    subclass   = PCI-PCI
uhci0@pci0:0:29:0:	class=0x0c0300 card=0x81791043 chip=0x27c88086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family USB UHCI Controller'
    class      = serial bus
    subclass   = USB
uhci1@pci0:0:29:1:	class=0x0c0300 card=0x81791043 chip=0x27c98086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family USB UHCI Controller'
    class      = serial bus
    subclass   = USB
uhci2@pci0:0:29:2:	class=0x0c0300 card=0x81791043 chip=0x27ca8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family USB UHCI Controller'
    class      = serial bus
    subclass   = USB
uhci3@pci0:0:29:3:	class=0x0c0300 card=0x81791043 chip=0x27cb8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family USB UHCI Controller'
    class      = serial bus
    subclass   = USB
ehci0@pci0:0:29:7:	class=0x0c0320 card=0x81791043 chip=0x27cc8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family USB2 EHCI Controller'
    class      = serial bus
    subclass   = USB
pcib6@pci0:0:30:0:	class=0x060401 card=0x81791043 chip=0x244e8086 rev=0xe1 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801 PCI Bridge'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:	class=0x060100 card=0x81791043 chip=0x27b88086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801GB/GR (ICH7 Family) LPC Interface Bridge'
    class      = bridge
    subclass   = PCI-ISA
atapci1@pci0:0:31:1:	class=0x01018a card=0x81791043 chip=0x27df8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) IDE Controller'
    class      = mass storage
    subclass   = ATA
atapci2@pci0:0:31:2:	class=0x01018f card=0x26011043 chip=0x27c08086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family SATA Controller [IDE mode]'
    class      = mass storage
    subclass   = ATA
none0@pci0:0:31:3:	class=0x0c0500 card=0x81791043 chip=0x27da8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'NM10/ICH7 Family SMBus Controller'
    class      = serial bus
    subclass   = SMBus
vgapci0@pci0:6:0:0:	class=0x030000 card=0x840d1043 chip=0x104a10de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GF119 [GeForce GT 610]'
    class      = display
    subclass   = VGA
hdac0@pci0:6:0:1:	class=0x040300 card=0x840d1043 chip=0x0e0810de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GF119 HDMI Audio Controller'
    class      = multimedia
    subclass   = HDA
ahci0@pci0:2:0:0:	class=0x010601 card=0x81e41043 chip=0x2363197b rev=0x02 hdr=0x00
    vendor     = 'JMicron Technology Corp.'
    device     = 'JMB363 SATA/IDE Controller'
    class      = mass storage
    subclass   = SATA
atapci0@pci0:2:0:1:	class=0x010185 card=0x81e41043 chip=0x2363197b rev=0x02 hdr=0x00
    vendor     = 'JMicron Technology Corp.'
    device     = 'JMB363 SATA/IDE Controller'
    class      = mass storage
    subclass   = ATA
none1@pci0:1:3:0:	class=0x0c0010 card=0x815b1043 chip=0x8023104c rev=0x00 hdr=0x00
    vendor     = 'Texas Instruments'
    device     = 'TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]'
    class      = serial bus
    subclass   = FireWire
Добавил:
в /etc/rc.conf строчку linux_enable="YES"
в /etc/fstab строчку linproc /compat/linux/proc/ linprocfs rw 0 0
в /boot/loader.conf строчку nvidia_load="YES".

може что-либо упустил? или слишком много информации :)
буду признателен за любую помощь.
Заранее благодарю всех кто откликнется.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

snorlov
подполковник
Сообщения: 3829
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

desktop не могу запустить иксы на nVidia GT 610

Непрочитанное сообщение snorlov » 2016-10-24 9:25:58

В xorg.conf добавьте в секцию screen разрешение монитора хоть 800х600, если включиться, то шевельните извилинами

nekkto
проходил мимо
Сообщения: 3
Зарегистрирован: 2016-10-23 22:43:07

desktop не могу запустить иксы на nVidia GT 610

Непрочитанное сообщение nekkto » 2016-10-24 13:44:13

snorlov писал(а):В xorg.conf добавьте в секцию screen разрешение монитора хоть 800х600, если включиться, то шевельните извилинами
ок! как доберусь до компа, попробую. спасибо, что откликнулись.

guest
проходил мимо

desktop не могу запустить иксы на nVidia GT 610

Непрочитанное сообщение guest » 2016-10-24 14:44:08

nekkto писал(а):Привет форумчане, я новичек во freebsd. Хочу поставить на десктоп, сейчас стоит дебиан. Вообще-то всегда разбирался сам - гугл выручал. А тут что-то не могу найти решения уже второй день убил.

Систему ставил из портов. При установке отметил флаг "Linux..." . После установки xorg сконфигурировал xorg.conf при помощи nvidia-xconfig. При попытке запуска иксов хоть от юзера хоть от рута просто гаснет экран вверху слева виден прямоугольник курсора и курсор мыши замирает. Добавил дополнительные секции которые учитывают второй видеовыход и второй монитор. Однако ничего не помогло.

<skipped>

Добавил:
в /etc/rc.conf строчку linux_enable="YES"
в /etc/fstab строчку linproc /compat/linux/proc/ linprocfs rw 0 0
в /boot/loader.conf строчку nvidia_load="YES".

може что-либо упустил? или слишком много информации :)
буду признателен за любую помощь.
Заранее благодарю всех кто откликнется.
# less /usr/ports/UPDATING -> search 20160829

/etc/rc.conf
...
kld_list="nvidia nvidia-modeset"
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
...

nekkto
проходил мимо
Сообщения: 3
Зарегистрирован: 2016-10-23 22:43:07

desktop не могу запустить иксы на nVidia GT 610

Непрочитанное сообщение nekkto » 2016-10-25 0:26:39

guest писал(а):
# less /usr/ports/UPDATING -> search 20160829

/etc/rc.conf
...
kld_list="nvidia nvidia-modeset"
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
...
Премного благодарю!
прикольно, но "общение с линуксом" дает о себе знать. если раньше я читал подобные ответы и :crazy: то сейчас мне было достаточно строчки:
# less /usr/ports/UPDATING -> search 20160829
открыл указанный файл и в нем нашел описание решения. однако, таки вбил в поиске nvidia-modeset и первая же ссылка https://forums.freebsd.org/threads/52311/ помогает мне понять мою проблему.

кстати я её и раньше открывал, но не посчитал нужным последовать инструкции. смутило то, что в конце автор поста вместо полного конфига xorg.conf просто предлагает:
Use your favourite editor to create /usr/local/etc/X11/xorg.conf.d/10-nvidia.conf with the following contents:

Код: Выделить всё

Section "Device"
        Identifier "NVIDIA Card"
        VendorName "NVIDIA Corporation"
        Driver "nvidia"
EndSection
вначале я просто выгрузил старый модуль и подгрузил новый модуль ядра командой

Код: Выделить всё

kldunload "nvidia"
kldload "nvidia-modeset"
и попробовал снова стартануть иксы от рута. :Yahoo!: всё заработало...

далее как и пишет автор по вышеприведенной ссылке добавил строчку в /etc/rc.conf командой

Код: Выделить всё

sysrc kld_list+="nvidia nvidia-modeset"
это тоже для меня новое открытие, намного удобнее, чем править его редактором.
Предварительно удалил xorg.conf из /etc/X11/

Директория /usr/local/etc/X11/xorg.conf.d в моей системе уже была, поэтому я просто создал файл 10-nvidia.conf с содержимым

Код: Выделить всё

Section "Device"
        Identifier "NVIDIA Card"
        VendorName "NVIDIA Corporation"
        Driver "nvidia"
EndSection
После чего перезагрузил машину, чтобы убедиться, что при загрузке модуль подгружается автоматом. Запустил иксы от рута и выполнил уже в графическом режиме nvidia-settings, изменив кое-какие настройки, сохранил новый xorg.conf в /etc/X11/

Благодарю ещё раз за помощь! И хороший урок. Признаться, раньше никогда не обращал внимания на информационные строки в логах.

ps: не знаю, уместно ли такое подробное описание решения, но надеюсь это будет полезно ещё кому-нибудь из новичков.

Отправлено спустя 22 минуты 16 секунд:
подскажите, как пометить тему как [SOLVED]/ [РЕШЕНО] в FAQ не нашел...

Отправлено спустя 40 секунд:
подскажите, как пометить тему как [SOLVED] или [РЕШЕНО] в FAQ не нашел...

Отправлено спустя 35 секунд:
подскажите, как пометить тему как решенную, в FAQ не нашел...