firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-28 11:29:52

Как с этим бороться?

Код: Выделить всё

# pkg check -d
Checking all packages: 100%
ImageMagick has require a missing libraries: libgdk_pixbuf-2.0.so.0
ardour has require a missing libraries: libgdk_pixbuf-2.0.so.0
audacity has require a missing libraries: libgdk_pixbuf-2.0.so.0
calibre has require a missing libraries: libgdk_pixbuf-2.0.so.0
chromium has require a missing libraries: libgdk_pixbuf-2.0.so.0
classpath has require a missing libraries: libgdk_pixbuf-2.0.so.0
darktable has require a missing libraries: libgdk_pixbuf-2.0.so.0
filezilla has require a missing libraries: libgdk_pixbuf-2.0.so.0
firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0
gegl has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-app has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-beautify-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-focusblur-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-gmic-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-gutenprint has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-lensfun-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-lqr-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-refocus-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-resynthesizer has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-save-for-web has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-wavelet-decompose-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-wavelet-denoise-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gimp-wavelet-sharpen-plugin has require a missing libraries: libgdk_pixbuf-2.0.so.0
gnome-mount has require a missing libraries: libgdk_pixbuf-2.0.so.0
goocanvas has require a missing libraries: libgdk_pixbuf-2.0.so.0
gsmartcontrol has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtk-update-icon-cache has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtk3 has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtkmm24 has require a missing libraries: libgdk_pixbuf-2.0.so.0
gtkspell has require a missing libraries: libgdk_pixbuf-2.0.so.0
gutenprint-base has require a missing libraries: libgdk_pixbuf-2.0.so.0
inkscape has require a missing libraries: libgdk_pixbuf-2.0.so.0
leafpad has require a missing libraries: libgdk_pixbuf-2.0.so.0
libglade2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
libgnomecanvas has require a missing libraries: libgdk_pixbuf-2.0.so.0
libgnomecanvasmm has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                            
libgsf has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                      
libgtkhtml has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                  
libnotify has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                   
libopenraw has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                  
libreoffice has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                 
librsvg2 has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                    
libxul has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                      
lives has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                       
mjpegtools has require a missing libraries: libgdk_pixbuf-2.0.so.0                                                                                                                  
mlt has require a missing libraries: libgdk_pixbuf-2.0.so.0
nspluginwrapper has require a missing libraries: libgdk_pixbuf-2.0.so.0
oss has require a missing libraries: libgdk_pixbuf-2.0.so.0
p5-Gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
policykit-gnome has require a missing libraries: libgdk_pixbuf-2.0.so.0
py27-gimp has require a missing libraries: libgdk_pixbuf-2.0.so.0
py27-goocanvas has require a missing libraries: libgdk_pixbuf-2.0.so.0
py27-gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
py27-numpy has require a missing libraries: libopenblas.so
stardict has require a missing libraries: libgdk_pixbuf-2.0.so.0
swfdec has require a missing libraries: libgdk_pixbuf-2.0.so.0
transmission-gtk has require a missing libraries: libgdk_pixbuf-2.0.so.0
webkit-gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
wifimgr has require a missing libraries: libgdk_pixbuf-2.0.so.0
wx28-gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
wx30-gtk2 has require a missing libraries: libgdk_pixbuf-2.0.so.0
xarchiver has require a missing libraries: libgdk_pixbuf-2.0.so.0
xscreensaver has require a missing libraries: libgdk_pixbuf-2.0.so.0
zenity has require a missing libraries: libgdk_pixbuf-2.0.so.0

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35292
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Alex Keda » 2015-09-28 21:04:37

у вас что-то не работает?
нет? тогда - забить =)

Отправлено спустя 28 секунд:
как вариант

Код: Выделить всё

pkg upgrade -fy
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-28 21:22:16

Alex Keda писал(а):у вас что-то не работает?
нет? тогда - забить =)

Отправлено спустя 28 секунд:
как вариант

Код: Выделить всё

pkg upgrade -fy
а у вас хорошее чувство юмора. На всё забить... :)))) И чего это я в вас такой влюблюнный! :Yahoo!:

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35292
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Alex Keda » 2015-09-28 23:10:59

причём тут юмор?
работает - не трожь =)
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-28 23:29:40

Alex Keda писал(а):причём тут юмор?
работает - не трожь =)
так иногда же вырубает систему, вот я и начал искать где и шо, а тут по команде увидел какие-то ошибки, может они влияют...

guest
проходил мимо

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение guest » 2015-09-29 8:44:50

Elimelech писал(а):
Alex Keda писал(а):причём тут юмор?
работает - не трожь =)
так иногда же вырубает систему, вот я и начал искать где и шо, а тут по команде увидел какие-то ошибки, может они влияют...
конечно влияют:

# pkg info | grep gdk-pixbuf2
# ldconfig -r | grep libgdk_pix
# ls -la /usr/local/lib/libgdk_*
# pkg which /usr/local/lib/libgdk_pixbuf-2.0.so.0

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-29 10:39:17

Код: Выделить всё

# pkg info | grep gdk-pixbuf2
gdk-pixbuf2-2.31.7             Graphic library for GTK+
linux-c6-gdk-pixbuf2-2.24.1    RPM of the gdk-pixbuf lib (Linux CentOS 6.6)

Код: Выделить всё

# ldconfig -r | grep libgdk_pix
        293:-lgdk_pixbuf-2.0.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0
        295:-lgdk_pixbuf_xlib-2.0.0 => /usr/local/lib/libgdk_pixbuf_xlib-2.0.so.0

Код: Выделить всё

# ls -la /usr/local/lib/libgdk_*
lrwxr-xr-x  1 root  wheel      29 17 сен 04:32 /usr/local/lib/libgdk_pixbuf-2.0.so -> libgdk_pixbuf-2.0.so.0.3100.7
lrwxr-xr-x  1 root  wheel      29 17 сен 04:32 /usr/local/lib/libgdk_pixbuf-2.0.so.0 -> libgdk_pixbuf-2.0.so.0.3100.7
-rwxr-xr-x  1 root  wheel  117936 17 сен 04:32 /usr/local/lib/libgdk_pixbuf-2.0.so.0.3100.7
lrwxr-xr-x  1 root  wheel      34 17 сен 04:32 /usr/local/lib/libgdk_pixbuf_xlib-2.0.so -> libgdk_pixbuf_xlib-2.0.so.0.3100.7
lrwxr-xr-x  1 root  wheel      34 17 сен 04:32 /usr/local/lib/libgdk_pixbuf_xlib-2.0.so.0 -> libgdk_pixbuf_xlib-2.0.so.0.3100.7
-rwxr-xr-x  1 root  wheel   55448 17 сен 04:32 /usr/local/lib/libgdk_pixbuf_xlib-2.0.so.0.3100.7

Код: Выделить всё

# pkg which /usr/local/lib/libgdk_pixbuf-2.0.so.0
/usr/local/lib/libgdk_pixbuf-2.0.so.0 was installed by package gdk-pixbuf2-2.31.7

guest
проходил мимо

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение guest » 2015-09-29 15:49:25

Что-то Вы намутили с апгрейдом из портов или пакетов, ибо:

Код: Выделить всё

# pkg info -r gdk-pixbuf2
gdk-pixbuf2-2.31.2_1:
        gtk-update-icon-cache-2.24.27
        gtk2-2.24.27
        libnotify-0.7.6_1
        chromium-43.0.2357.132
        virtualbox-ose-4.3.30
# pkg info -d gdk-pixbuf2
gdk-pixbuf2-2.31.2_1:
        libXi-1.7.4_1,1
        libX11-1.6.2_3,1
        libXt-1.1.4_3,1
        tiff-4.0.4
        png-1.6.18
        jpeg-8_6
        jasper-1.900.1_14
        glib-2.42.2
        gettext-runtime-0.19.4
#
выше, первое - от чего зависит gdk-pixbuf, второе - что зависит от него, Ваш второй список, будет
больше, больше хлама установлено.

покажите:
# ldd /usr/local/share/chromium/chrome

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-29 16:10:15

Код: Выделить всё

# ldd /usr/local/share/chromium/chrome
/usr/local/share/chromium/chrome:
        libexecinfo.so.1 => /usr/lib/libexecinfo.so.1 (0x2ec31000)
        libkvm.so.6 => /lib/libkvm.so.6 (0x2ec34000)
        libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0x2ec3d000)
        libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0x2ec40000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x2ec7f000)
        libevent-2.0.so.5 => /usr/local/lib/libevent-2.0.so.5 (0x2ed73000)
        libicui18n.so.55 => /usr/local/lib/libicui18n.so.55 (0x2edb1000)
        libicuuc.so.55 => /usr/local/lib/libicuuc.so.55 (0x2f029000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0x2f1a5000)
        libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0x2f1df000)
        libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0x2f26b000)
        libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0x2f276000)
        libthr.so.3 => /lib/libthr.so.3 (0x2f386000)
        libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0x2f3a7000)
        libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0x2f3ee000)
        libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0x2f449000)
        libjpeg.so.8 => /usr/local/lib/libjpeg.so.8 (0x2f47a000)
        libX11.so.6 => /usr/local/lib/libX11.so.6 (0x2f4d2000)
        libXi.so.6 => /usr/local/lib/libXi.so.6 (0x2f5ec000)
        libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0x2f5fa000)
        libgconf-2.so.4 => /usr/local/lib/libgconf-2.so.4 (0x2f61f000)
        libnss3.so.1 => /usr/local/lib/nss/libnss3.so.1 (0x2f653000)
        libsmime3.so.1 => /usr/local/lib/nss/libsmime3.so.1 (0x2f78e000)
        libnssutil3.so.1 => /usr/local/lib/nss/libnssutil3.so.1 (0x2f7b1000)
        libplds4.so.1 => /usr/local/lib/libplds4.so.1 (0x2f7d3000)
        libplc4.so.1 => /usr/local/lib/libplc4.so.1 (0x2f802000)
        libnspr4.so.1 => /usr/local/lib/libnspr4.so.1 (0x2f831000)
        libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x2f865000)
        libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0x2f9a4000)
        libXext.so.6 => /usr/local/lib/libXext.so.6 (0x2f9ae000)
        libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0x2f9bd000)
        libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0x2f9c2000)
        libXss.so.1 => /usr/local/lib/libXss.so.1 (0x2f9ca000)
        libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x2f9cd000)
        libre2.so.0 => /usr/local/lib/libre2.so.0 (0x2fb3d000)
        libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0x2fb8c000)
        libasound.so.2 => /usr/local/lib/libasound.so.2 (0x2fb8f000)
        libm.so.5 => /lib/libm.so.5 (0x2fc66000)
        libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0x2fc8d000)
        libXtst.so.6 => /usr/local/lib/libXtst.so.6 (0x2fc90000)
        libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0x2fc95000)
        libwebp.so.5 => /usr/local/lib/libwebp.so.5 (0x2fc9e000)
        libwebpdemux.so.1 => /usr/local/lib/libwebpdemux.so.1 (0x2fcfb000)
        libxslt.so.1 => /usr/local/lib/libxslt.so.1 (0x2fcfe000)
        libsnappy.so.1 => /usr/local/lib/libsnappy.so.1 (0x2fd35000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0x2fd3b000)
        libcups.so.2 => /usr/local/lib/libcups.so.2 (0x2fd5e000)
        libspeechd.so.2 => /usr/local/lib/libspeechd.so.2 (0x2fdc9000)
        libusb.so.3 => /usr/lib/libusb.so.3 (0x2fdd2000)
        libFLAC.so.8 => /usr/local/lib/libFLAC.so.8 (0x2fde2000)
        libspeex.so.1 => /usr/local/lib/libspeex.so.1 (0x2fe16000)
        libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0x2fe2c000)
        libgtk-x11-2.0.so.0 => /usr/local/lib/libgtk-x11-2.0.so.0 (0x2fe6a000)
        libgdk-x11-2.0.so.0 => /usr/local/lib/libgdk-x11-2.0.so.0 (0x30260000)
        libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0x302fe000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x3031b000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x303c9000)
        libc.so.7 => /lib/libc.so.7 (0x303e2000)
        libelf.so.1 => /usr/lib/libelf.so.1 (0x30557000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x3056d000)
        libiconv.so.2 => /usr/local/lib/libiconv.so.2 (0x30579000)
        libpcre.so.1 => /usr/local/lib/libpcre.so.1 (0x3066d000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x306e4000)
        libffi.so.6 => /usr/local/lib/libffi.so.6 (0x306f6000)
        libicudata.so.55 => /usr/local/lib/libicudata.so.55 (0x30800000)
        libz.so.6 => /lib/libz.so.6 (0x306fd000)
        libbz2.so.4 => /usr/lib/libbz2.so.4 (0x30711000)
        libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0x30721000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x30732000)
        libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0x30734000)
        libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0x307e1000)
        libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0x307f8000)
        libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0x320b7000)
        libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0x320bf000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0x320da000)
        libgraphite2.so.3 => /usr/local/lib/libgraphite2.so.3 (0x32154000)
        librpcsvc.so.5 => /usr/lib/librpcsvc.so.5 (0x32184000)
        libdbus-glib-1.so.2 => /usr/local/lib/libdbus-glib-1.so.2 (0x3218d000)
        libORBit-2.so.0 => /usr/local/lib/libORBit-2.so.0 (0x321ae000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x32203000)
        libgnutls.so.28 => /usr/local/lib/libgnutls.so.28 (0x32226000)
        libdns_sd.so.1 => /usr/local/lib/libdns_sd.so.1 (0x32333000)
        libcrypt.so.5 => /lib/libcrypt.so.5 (0x3233b000)
        libltdl.so.7 => /usr/local/lib/libltdl.so.7 (0x3235f000)
        libogg.so.0 => /usr/local/lib/libogg.so.0 (0x32368000)
        libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0x307fb000)
        libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0x307fe000)
        libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0x3236e000)
        libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0x32372000)
        libxcb-shape.so.0 => /usr/local/lib/libxcb-shape.so.0 (0x32378000)
        libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0x3237b000)
        libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0x32381000)
        libXau.so.6 => /usr/local/lib/libXau.so.6 (0x3238d000)
        libpthread-stubs.so.0 => /usr/local/lib/libpthread-stubs.so.0 (0x32390000)
        libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0x32392000)
        libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0x32397000)
        libxcb-glx.so.0 => /usr/local/lib/libxcb-glx.so.0 (0x323bc000)
        libXxf86vm.so.1 => /usr/local/lib/libXxf86vm.so.1 (0x323cf000)
        libp11-kit.so.0 => /usr/local/lib/libp11-kit.so.0 (0x323d4000)
        libtspi.so.1 => /usr/local/lib/libtspi.so.1 (0x32420000)
        libtasn1.so.6 => /usr/local/lib/libtasn1.so.6 (0x32486000)
        libnettle.so.4 => /usr/local/lib/libnettle.so.4 (0x32498000)
        libhogweed.so.2 => /usr/local/lib/libhogweed.so.2 (0x324c4000)
        libgmp.so.10 => /usr/local/lib/libgmp.so.10 (0x324ee000)
        libcrypto.so.7 => /lib/libcrypto.so.7 (0x32550000)

guest
проходил мимо

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение guest » 2015-09-29 18:48:32

Elimelech писал(а):

Код: Выделить всё

# ldd /usr/local/share/chromium/chrome
/usr/local/share/chromium/chrome:
        libexecinfo.so.1 => /usr/lib/libexecinfo.so.1 (0x2ec31000)
        libkvm.so.6 => /lib/libkvm.so.6 (0x2ec34000)
        libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0x2ec3d000)
        libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0x2ec40000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x2ec7f000)
        libevent-2.0.so.5 => /usr/local/lib/libevent-2.0.so.5 (0x2ed73000)
        libicui18n.so.55 => /usr/local/lib/libicui18n.so.55 (0x2edb1000)
        libicuuc.so.55 => /usr/local/lib/libicuuc.so.55 (0x2f029000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0x2f1a5000)
        libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0x2f1df000)
        libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0x2f26b000)
        libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0x2f276000)
        libthr.so.3 => /lib/libthr.so.3 (0x2f386000)
        libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0x2f3a7000)
        libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0x2f3ee000)
        libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0x2f449000)
        libjpeg.so.8 => /usr/local/lib/libjpeg.so.8 (0x2f47a000)
        libX11.so.6 => /usr/local/lib/libX11.so.6 (0x2f4d2000)
        libXi.so.6 => /usr/local/lib/libXi.so.6 (0x2f5ec000)
        libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0x2f5fa000)
        libgconf-2.so.4 => /usr/local/lib/libgconf-2.so.4 (0x2f61f000)
        libnss3.so.1 => /usr/local/lib/nss/libnss3.so.1 (0x2f653000)
        libsmime3.so.1 => /usr/local/lib/nss/libsmime3.so.1 (0x2f78e000)
        libnssutil3.so.1 => /usr/local/lib/nss/libnssutil3.so.1 (0x2f7b1000)
        libplds4.so.1 => /usr/local/lib/libplds4.so.1 (0x2f7d3000)
        libplc4.so.1 => /usr/local/lib/libplc4.so.1 (0x2f802000)
        libnspr4.so.1 => /usr/local/lib/libnspr4.so.1 (0x2f831000)
        libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x2f865000)
        libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0x2f9a4000)
        libXext.so.6 => /usr/local/lib/libXext.so.6 (0x2f9ae000)
        libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0x2f9bd000)
        libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0x2f9c2000)
        libXss.so.1 => /usr/local/lib/libXss.so.1 (0x2f9ca000)
        libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x2f9cd000)
        libre2.so.0 => /usr/local/lib/libre2.so.0 (0x2fb3d000)
        libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0x2fb8c000)
        libasound.so.2 => /usr/local/lib/libasound.so.2 (0x2fb8f000)
        libm.so.5 => /lib/libm.so.5 (0x2fc66000)
        libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0x2fc8d000)
        libXtst.so.6 => /usr/local/lib/libXtst.so.6 (0x2fc90000)
        libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0x2fc95000)
        libwebp.so.5 => /usr/local/lib/libwebp.so.5 (0x2fc9e000)
        libwebpdemux.so.1 => /usr/local/lib/libwebpdemux.so.1 (0x2fcfb000)
        libxslt.so.1 => /usr/local/lib/libxslt.so.1 (0x2fcfe000)
        libsnappy.so.1 => /usr/local/lib/libsnappy.so.1 (0x2fd35000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0x2fd3b000)
        libcups.so.2 => /usr/local/lib/libcups.so.2 (0x2fd5e000)
        libspeechd.so.2 => /usr/local/lib/libspeechd.so.2 (0x2fdc9000)
        libusb.so.3 => /usr/lib/libusb.so.3 (0x2fdd2000)
        libFLAC.so.8 => /usr/local/lib/libFLAC.so.8 (0x2fde2000)
        libspeex.so.1 => /usr/local/lib/libspeex.so.1 (0x2fe16000)
        libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0x2fe2c000)
        libgtk-x11-2.0.so.0 => /usr/local/lib/libgtk-x11-2.0.so.0 (0x2fe6a000)
        libgdk-x11-2.0.so.0 => /usr/local/lib/libgdk-x11-2.0.so.0 (0x30260000)
        libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0x302fe000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x3031b000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x303c9000)
        libc.so.7 => /lib/libc.so.7 (0x303e2000)
        libelf.so.1 => /usr/lib/libelf.so.1 (0x30557000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x3056d000)
        libiconv.so.2 => /usr/local/lib/libiconv.so.2 (0x30579000)
        libpcre.so.1 => /usr/local/lib/libpcre.so.1 (0x3066d000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x306e4000)
        libffi.so.6 => /usr/local/lib/libffi.so.6 (0x306f6000)
        libicudata.so.55 => /usr/local/lib/libicudata.so.55 (0x30800000)
        libz.so.6 => /lib/libz.so.6 (0x306fd000)
        libbz2.so.4 => /usr/lib/libbz2.so.4 (0x30711000)
        libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0x30721000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x30732000)
        libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0x30734000)
        libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0x307e1000)
        libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0x307f8000)
        libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0x320b7000)
        libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0x320bf000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0x320da000)
        libgraphite2.so.3 => /usr/local/lib/libgraphite2.so.3 (0x32154000)
        librpcsvc.so.5 => /usr/lib/librpcsvc.so.5 (0x32184000)
        libdbus-glib-1.so.2 => /usr/local/lib/libdbus-glib-1.so.2 (0x3218d000)
        libORBit-2.so.0 => /usr/local/lib/libORBit-2.so.0 (0x321ae000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x32203000)
        libgnutls.so.28 => /usr/local/lib/libgnutls.so.28 (0x32226000)
        libdns_sd.so.1 => /usr/local/lib/libdns_sd.so.1 (0x32333000)
        libcrypt.so.5 => /lib/libcrypt.so.5 (0x3233b000)
        libltdl.so.7 => /usr/local/lib/libltdl.so.7 (0x3235f000)
        libogg.so.0 => /usr/local/lib/libogg.so.0 (0x32368000)
        libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0x307fb000)
        libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0x307fe000)
        libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0x3236e000)
        libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0x32372000)
        libxcb-shape.so.0 => /usr/local/lib/libxcb-shape.so.0 (0x32378000)
        libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0x3237b000)
        libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0x32381000)
        libXau.so.6 => /usr/local/lib/libXau.so.6 (0x3238d000)
        libpthread-stubs.so.0 => /usr/local/lib/libpthread-stubs.so.0 (0x32390000)
        libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0x32392000)
        libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0x32397000)
        libxcb-glx.so.0 => /usr/local/lib/libxcb-glx.so.0 (0x323bc000)
        libXxf86vm.so.1 => /usr/local/lib/libXxf86vm.so.1 (0x323cf000)
        libp11-kit.so.0 => /usr/local/lib/libp11-kit.so.0 (0x323d4000)
        libtspi.so.1 => /usr/local/lib/libtspi.so.1 (0x32420000)
        libtasn1.so.6 => /usr/local/lib/libtasn1.so.6 (0x32486000)
        libnettle.so.4 => /usr/local/lib/libnettle.so.4 (0x32498000)
        libhogweed.so.2 => /usr/local/lib/libhogweed.so.2 (0x324c4000)
        libgmp.so.10 => /usr/local/lib/libgmp.so.10 (0x324ee000)
        libcrypto.so.7 => /lib/libcrypto.so.7 (0x32550000)
выше видно, что динамическая библиотека присутствует, это было видно и ранее и
по крайней мере chrome ее цепляет, а значит должен работать:

Код: Выделить всё

libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0x302fe000)
могу предположить что Вы попортили локальную базу local.sqlite...

Попробуйте проверить на отсутствующие зависимости:

# pkg check -d -a

результат?

а потом:

# pkg check --shlibs
?

все зависит от понимания работы с пакетами и портами, использования portmaster или portupgrade.

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-29 19:06:12

мне интресно знать каким образом я смог попортить local.sqlite...

guest
проходил мимо

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение guest » 2015-09-29 19:42:08

Elimelech писал(а):мне интресно знать каким образом я смог попортить local.sqlite...
мне тоже... как Вы умудряетесь все ломать, каким таким образом?
Видимо от незнания.

Удачи

Аватара пользователя
Elimelech
лейтенант
Сообщения: 672
Зарегистрирован: 2009-11-28 18:42:07
Откуда: Украина
Контактная информация:

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение Elimelech » 2015-09-29 19:58:51

уже всё починил!

Код: Выделить всё

root@F3ja:/usr/home/elimelech # pkg check -d -a
Checking all packages: 100%
root@F3ja:/usr/home/elimelech # pkg check --shlibs
Checking all packages: 100%
root@F3ja:/usr/home/elimelech # 

guest
проходил мимо

firefox has require a missing libraries: libgdk_pixbuf-2.0.so.0

Непрочитанное сообщение guest » 2015-09-29 20:05:58

Elimelech писал(а):уже всё починил!

Код: Выделить всё

root@F3ja:/usr/home/elimelech # pkg check -d -a
Checking all packages: 100%
root@F3ja:/usr/home/elimelech # pkg check --shlibs
Checking all packages: 100%
root@F3ja:/usr/home/elimelech # 
просто чудо :)