Не устанавливается apache 22

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
KornXolio
рядовой
Сообщения: 34
Зарегистрирован: 2013-08-01 19:46:03

Не устанавливается apache 22

Непрочитанное сообщение KornXolio » 2013-08-15 9:13:10

Очень странно, но не получается установить Апач:
/usr/include/c++/4.2/bits/istream.tcc:340: internal compiler error: Segmentation fault: 11
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** [Source/CMakeFiles/CMakeLib.dir/cmGeneratedFileStream.cxx.o] Error code 1
1 error
*** [Source/CMakeFiles/CMakeLib.dir/all] Error code 2
1 error
*** [all] Error code 2
1 error
*** [do-build] Error code 1

Stop in /usr/ports/devel/cmake.
*** [build-depends] Error code 1

Stop in /usr/ports/databases/mysql55-client.
*** [install] Error code 1

Stop in /usr/ports/databases/mysql55-client.
*** [lib-depends] Error code 1

Stop in /usr/ports/devel/apr1.
*** [install] Error code 1

Stop in /usr/ports/devel/apr1.
*** [lib-depends] Error code 1

Stop in /usr/ports/www/apache22.
*** [install] Error code 1

Stop in /usr/ports/www/apache22.
Порты были обновлены...
Устанавливаю через пользователя с правами sudo.
Последний раз редактировалось f_andrey 2013-08-15 14:01:25, всего редактировалось 1 раз.
Причина: Автору. пожалуйста, выбирайте соответствующий раздел форума.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

KornXolio
рядовой
Сообщения: 34
Зарегистрирован: 2013-08-01 19:46:03

Re: Не устанавливается apache 22

Непрочитанное сообщение KornXolio » 2013-08-15 11:36:36

Помогло обновление портов через root.
Проблема при запуске apach, проблема как понял в сертификатах, что с ними надо делать? Совсем отключить?

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Не устанавливается apache 22

Непрочитанное сообщение hizel » 2013-08-15 18:01:19

Доставляет, что ошибка при сборке gcc. Впрочем, ждем телепатов.
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

werder39
проходил мимо

Re: Не устанавливается apache 22

Непрочитанное сообщение werder39 » 2013-08-16 9:12:52

KornXolio , идите читайте маны, а не обновляйте порты через рут)))))
А если влом читать то хоть делайте по манам, http://www.lissyara.su/

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Не устанавливается apache 22

Непрочитанное сообщение hizel » 2013-08-16 9:45:44

а не обновляйте порты через рут)))))
Штоа!? Сам вали отседова, гадкий ананимус.
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

KornXolio
рядовой
Сообщения: 34
Зарегистрирован: 2013-08-01 19:46:03

Re: Не устанавливается apache 22

Непрочитанное сообщение KornXolio » 2013-08-17 11:11:13

Настроил, заработало. Но сервер не видно из интернета, в локальной сети работает. Сервер и интернет разделяет шлюз а дальше оптоволокно, шлюз Huawei в котором настроил проброс 80 порта но толку нет. Через домен сайт пингуется.

irina79kk
проходил мимо
Сообщения: 1
Зарегистрирован: 2013-08-17 17:46:26

Re: Не устанавливается apache 22

Непрочитанное сообщение irina79kk » 2013-08-17 17:57:09

Почему порты через рут нельзя обновлять?

KornXolio
рядовой
Сообщения: 34
Зарегистрирован: 2013-08-01 19:46:03

Re: Не устанавливается apache 22

Непрочитанное сообщение KornXolio » 2013-08-17 18:31:37

irina79kk писал(а):Почему порты через рут нельзя обновлять?
Думаю на этот вопрос ответа нам не получить, во всяком случае после обновления портов всё поставилось, до этого некорректно что то делал.

Что касается неработающего 80-го порта, получилось что после смены его на любой другой страницы загружаются. Причиной стал либо сам роутер от МГТС, который они установили совершенно бесплатно в квартире и которым по счастливой случайности довелось пользоваться, либо в самом провайдере МГТС блокирующем 80 порт. Теперь новая головная боль, либо искать пути решения проблемы, либо менять провайдера.
Кто то был в аналогичной ситуации? :st:

mak_v_
проходил мимо

Re: Не устанавливается apache 22

Непрочитанное сообщение mak_v_ » 2013-08-18 14:48:44

а не обновляйте порты через рут)))))
Пришло время переустанавливать Шindows?

KornXolio
рядовой
Сообщения: 34
Зарегистрирован: 2013-08-01 19:46:03

Re: Не устанавливается apache 22

Непрочитанное сообщение KornXolio » 2013-09-13 17:16:30

Код: Выделить всё

cc: passwd/.libs/apr_getpass.o: No such file or directory
cc: strings/.libs/apr_cpystrn.o: No such file or directory
cc: strings/.libs/apr_fnmatch.o: No such file or directory
cc: strings/.libs/apr_snprintf.o: No such file or directory
cc: strings/.libs/apr_strings.o: No such file or directory
cc: strings/.libs/apr_strnatcmp.o: No such file or directory
cc: strings/.libs/apr_strtok.o: No such file or directory
*** [libapr-1.la] Error code 1
1 error
*** [all-recursive] Error code 1
1 error
*** [do-build] Error code 2

Stop in /usr/ports/devel/apr1.
*** [install] Error code 1

Stop in /usr/ports/devel/apr1.
*** [lib-depends] Error code 1

Stop in /usr/ports/www/apache22.
*** [install] Error code 1

Stop in /usr/ports/www/apache22.
В чем может быть проблема?

Аватара пользователя
MaestroBSD
проходил мимо
Сообщения: 4
Зарегистрирован: 2015-01-30 21:46:52
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение MaestroBSD » 2015-01-30 23:36:15

Ребята привет, давно не был, хана, помогайте! Обновил FreeBSD через freebsd-update c 8.4 сразу на 10.1 все вроде прошло нормально, пересобрал ядро, обновился через svn. Наблюдаюся глюки pkg - например при команде pkg install он предлагает удалить сам себя ))) Ну да ладно, решил я все пакеты заново пересобрать, идея такая меня постигла, заодно чтобы pkg не глючил и не подхватывал старое дерево портов, удалил нахрен /var/db/pkg/* и /usr/ports/* кроме distfiles, зафигачил portsnap, собрал pkg, сделал pkg2ng, собрал portupgrade, затем, c помощью такой-то матери, собрал mc без поддержки графических библиотек, собрал mysql56 и dhcpd-server и приступил к установке apache24 и все, хана, ни php56 ни apache24 не встают из-за apr1 - все решения в инете пересмотрел, и пути указывал и что-только не делал - нихуахуа не получается! Вывод ошибки при make apache24:

Код: Выделить всё

configure:
configure: Configuring Apache Portable Runtime library...
configure:
checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a build directory, or an apr-config file.
===>  Script "configure" failed unexpectedly.
Please report the problem to apache@FreeBSD.org [maintainer]
Вывод ошибки при make install apr1:

Код: Выделить всё

# make install
===>  Installing for apr-1.5.1.1.5.4
===>   apr-1.5.1.1.5.4 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so.1.6.0)
===>   apr-1.5.1.1.5.4 depends on shared library: libgdbm.so - found (/usr/local/lib/libgdbm.so.4.0.0)
===>   apr-1.5.1.1.5.4 depends on shared library: libmysqlclient.so.18 - found (/usr/local/lib/mysql/libmysqlclient.so.18)
===>   apr-1.5.1.1.5.4 depends on shared library: libdb-5.3.so - found (/usr/local/lib/db5/libdb-5.3.so.0.0.0)
===>  Checking if apr already installed
===>   Registering installation for apr-1.5.1.1.5.4
pkg-static: Unable to access file /usr/ports/devel/apr1/work/stage/usr/local/lib/apr-util-1/apr_dbm_gdbm-1.so: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/apr1/work/stage/usr/local/lib/apr-util-1/apr_dbm_gdbm.a: No such file or directory
pkg-static: Unable to access file /usr/ports/devel/apr1/work/stage/usr/local/lib/apr-util-1/apr_dbm_gdbm.so: No such file or directory
*** Error code 74

Stop.
make[1]: stopped in /usr/ports/devel/apr1
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/apr1
Отправлено спустя 5 минут 33 секунды:
И действительно, там реально нет таких файлов, есть apr_dbm_db-1.so короче, у всех трех файлов на конце db а не gdbm

Отправлено спустя 33 минуты 23 секунды:
Может сделать символические ссылки на нужные файлы? )))

Отправлено спустя 48 минут 43 секунды:
Сделал символические ссылки на все три файлы, прокатило, apr1 установился из портов.

Код: Выделить всё

# cd /usr/ports/devel/apr1/work/stage/usr/local/lib/apr-util-1/
# ln -s apr_dbm_db-1.so apr_dbm_gdbm-1.so
И так для всех трех файлов

Аватара пользователя
tom.cat
старшина
Сообщения: 441
Зарегистрирован: 2007-11-24 20:23:49
Откуда: Мытищи
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение tom.cat » 2015-01-31 0:12:16

MaestroBSD писал(а): помогайте!
Не ваш случай?
20140322:
AFFECTS: users of devel/apr1
AUTHOR: ohauer@FreeBSD.org

APR was updated to 1.5.0, BDB requirement was bumped to 48+
It is necessary to first remove the old version of devel/apr1.

Please rebuild all ports which are using functions from APR/APR-util
such as Apache, Subversion, etc.

# portmaster -r apr
or
# portupgrade -r devel/apr1
/usr/ports/UPDATING читаете? :)
When you see pigs fly it means Windows has become open source

Аватара пользователя
MaestroBSD
проходил мимо
Сообщения: 4
Зарегистрирован: 2015-01-30 21:46:52
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение MaestroBSD » 2015-01-31 0:26:25

Ха-ха-ха - читаю, и это не сработало ни с portupgrade ни с portmaster, a pkg install -fR devel/apr1 вообще предлагает удалить сам себя - pkg предлагает удалить pkg - вот мой случай ))))

Аватара пользователя
tom.cat
старшина
Сообщения: 441
Зарегистрирован: 2007-11-24 20:23:49
Откуда: Мытищи
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение tom.cat » 2015-01-31 0:29:28

Ось живет своей жизнью :)
When you see pigs fly it means Windows has become open source

Аватара пользователя
MaestroBSD
проходил мимо
Сообщения: 4
Зарегистрирован: 2015-01-30 21:46:52
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение MaestroBSD » 2015-01-31 0:43:05

tom.cat писал(а):Ось живет своей жизнью :)
Да, и кстати, логично что не прокатило ни с portmaster ни c portupgrade, так как по сути не с чем выстраивать зависимость, apr1 ведь не установлен ))) В общем и целом, сейчас у меня дампится система, пятница - ночь ))) Где-то через часик соберу mod_php56 который подтянет за собой и php56 и apache24 и отпишусь - и если будут глюки с работой php или apache - уже тогда попробую portupgrade -r devel/apr1 :crazy:

Аватара пользователя
MaestroBSD
проходил мимо
Сообщения: 4
Зарегистрирован: 2015-01-30 21:46:52
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение MaestroBSD » 2015-01-31 15:36:10

Продолжим сию эпопею, удалил я нафиг все симлинки и поставил apr1 без поддержки GNU dbm библиотек. Теперь apache24 выдает следующую ошибку, уже новую. Не забываем, порты снесены и устанавливаются заново. Ось FreeBSD 10.1

Код: Выделить всё

# uname -a
FreeBSD kruglic.sanatin.ru 10.1-RELEASE-p4 FreeBSD 10.1-RELEASE-p4 #2 r277424: Wed Jan 21 02:08:43 YEKT 2015     Evgen@kruglic.sanatin.ru:/usr/obj/usr/src/sys/ROUTER  i386
apache24 ошибка:

Код: Выделить всё

/usr/local/share/apr/build-1/libtool --silent --mode=link cc    -O2 -pipe -I/usr/include -DLIBICONV_PLUG -fstack-protector -fno-strict-aliasing    -L/usr/local/lib/db6 -L/usr/local/lib  -L/usr/lib -Wl,-rpath,/usr/lib:/usr/local/lib -fstack-protector -o htpasswd  htpasswd.lo passwd_common.lo      /usr/local/lib/libaprutil-1.la -ldb-6.1 -lexpat -L/usr/local/lib -R/usr/local/lib -lapr-1 -lcrypt -lpthread -lcrypt
libtool: link: cannot find the library `/usr/local/lib/libapr-1.la' or unhandled argument `/usr/local/lib/libapr-1.la'
*** [htpasswd] Error code 1

make[4]: stopped in /usr/ports/www/apache24/work/httpd-2.4.10/support
1 error
ага... что ж - делаю portmaster -r libiconv-1.14_6

На всякий ПЖ мой /etc/make.conf

Код: Выделить всё

# cat /etc/make.conf
#TAR=/usr/local/bin/gtar
#MAKE_JOBS_USAFE=yes
PERL_VERSION=5.20.1
#DEFAULT_VERSION=python=3.4
WITH_PKGNG=yes
#CPUTYPE?=native
#INSTALL=install -C
NO_GAMES=yes
NO_SENDMAIL=yes
WITHOUT_X11=yes
WITHOUT_GUI=yes
WITHOUT_FLOPPY=yes
DOC_LANG=en_US.ISO8859-1 ru_RU.KOI8-R
LOCALIZED_LANG=ru
Да, и на всякий случай, может кому что навеет # pkg info -a

Код: Выделить всё

apr-1.5.1.1.5.4                Apache Portability Library
autoconf-2.69                  Automatically configure source code on many Un*x platforms
autoconf-wrapper-20131203      Wrapper script for GNU autoconf
bind910-9.10.1P1_1             BIND DNS suite with updated DNSSEC and DNS64
ca_root_nss-3.17.3_1           The root certificate bundle from the Mozilla Project
cmake-3.1.1                    Cross-platform Makefile generator
cmake-modules-3.1.1            Modules and Templates for CMake
curl-7.40.0                    Non-interactive tool to get files from FTP, GOPHER, HTTP(S) servers
db5-5.3.28_2                   The Oracle Berkeley DB, revision 5.3
db6-6.1.19                     The Oracle Berkeley DB, revision 6.1
dialog4ports-0.1.5_2           Console Interface to configure ports
expat-2.1.0_2                  XML 1.0 parser written in C
gdbm-1.11_2                    GNU database manager
gettext-runtime-0.19.4         GNU gettext runtime libraries and programs
gettext-tools-0.19.4           GNU gettext development and translation tools
glib-2.42.1                    Some useful routines of C programming (current stable version)
gmake-4.1_1                    GNU version of 'make' utility
gmake-lite-4.1_1               Minimalist version of gnu make
help2man-1.43.3_1              Automatically generating simple manual pages from program output
idnkit-1.0_5                   Library to handle internationalized domain names
indexinfo-0.2.2                Utility to regenerate the GNU info page index
isc-dhcp43-server-4.3.1        The ISC Dynamic Host Configuration Protocol server
libffi-3.2.1                   Foreign Function Interface
libiconv-1.14_6                Character set conversion library
m4-1.4.17_1,1                  GNU m4
mc-4.8.13_3                    Midnight Commander, a free Norton Commander Clone
mysql56-client-5.6.22          Multithreaded SQL database (client)
mysql56-server-5.6.22          Multithreaded SQL database (server)
mysqlbackup-2.8                Creates MySQL backups on a periodic basis
p5-Locale-gettext-1.05_4       Message handling functions
pcre-8.35_2                    Perl Compatible Regular Expressions library
perl5.20-5.20.1_10             Practical Extraction and Report Language
pkg-1.4.7                      Package manager
pkgconf-0.9.7                  Utility to help to configure compiler and linker flags
portmaster-3.17.7              Manage your ports without external databases or languages
portupgrade-2.4.13_1,2         FreeBSD ports/packages administration and management tool suite
py27-Babel-1.3_2               Collection of tools for internationalizing Python applications
py27-Jinja2-2.7.3              Fast and easy to use stand-alone template engine
py27-MarkupSafe-0.23           Implements a XML/HTML/XHTML Markup safe string for Python
py27-docutils-0.12             Python Documentation Utilities
py27-pygments-2.0.2            Syntax highlighter written in Python
py27-pytz-2014.10,1            World Timezone Definitions for Python
py27-setuptools27-5.5.1_1      Python packages installer
py27-sphinx-1.2.3              Python documentation generator
python27-2.7.9                 Interpreted object-oriented programming language
ruby20-bdb-0.6.6_4             Ruby interface to Oracle Berkeley DB revision 2 or later
Отправлено спустя 14 минут 31 секунду:
Ага, не помогло... Народ, есть какие-нибудь размышления на эту тему?

Отправлено спустя 14 минут 28 секунд:
Еще немного инфы:

Код: Выделить всё

# ls -la | grep libapr
-rw-r--r--   1 root  wheel    680312 20 янв  2012 libapr-0.a
-rw-r--r--   1 root  wheel       938 20 янв  2012 libapr-0.la
lrwxr-xr-x   1 root  wheel        13 20 янв  2012 libapr-0.so -> libapr-0.so.9
-rwxr-xr-x   1 root  wheel    480044 20 янв  2012 libapr-0.so.9
-rw-r--r--   1 root  wheel    257862 31 янв 14:34 libapr-1.a
lrwxr-xr-x   1 root  wheel        17 31 янв 14:34 libapr-1.so -> libapr-1.so.0.5.1
lrwxr-xr-x   1 root  wheel        17 31 янв 14:34 libapr-1.so.0 -> libapr-1.so.0.5.1
-rwxr-xr-x   1 root  wheel    172664 31 янв 14:34 libapr-1.so.0.5.1
-rw-r--r--   1 root  wheel    424252 20 янв  2012 libaprutil-0.a
-rw-r--r--   1 root  wheel       954 20 янв  2012 libaprutil-0.la
lrwxr-xr-x   1 root  wheel        17 20 янв  2012 libaprutil-0.so -> libaprutil-0.so.9
-rwxr-xr-x   1 root  wheel    306090 20 янв  2012 libaprutil-0.so.9
-rw-r--r--   1 root  wheel    188954 31 янв 14:34 libaprutil-1.a
-rwxr-xr-x   1 root  wheel      1054 30 янв 23:05 libaprutil-1.la
lrwxr-xr-x   1 root  wheel        21 31 янв 14:34 libaprutil-1.so -> libaprutil-1.so.0.5.4
lrwxr-xr-x   1 root  wheel        21 31 янв 14:34 libaprutil-1.so.0 -> libaprutil-1.so.0.5.4
-rwxr-xr-x   1 root  wheel    135164 31 янв 14:34 libaprutil-1.so.0.5.4
Отправлено спустя 29 минут 29 секунд:
если так будет продолжаться, я уйду на nginx =)

Отправлено спустя 1 час 58 минут 22 секунды:
Все надоело, так как прыгал через freebsd-update с версии 8.4 сразу на 10.1 - решил сделать финт ушами... через svnlite обновил /usr/rsc и пересобираю мир, не знаю, надо ли заново пересобирать ядро после сборки мира, наверное надо, как проведу в single mode инсталляцию мира, отпишусь, проблема у меня с pkg при вызове pkg install или pkg upgrade пакет настойчиво требует удалить сам себя, мотивируя тем, что у меня устаревшая версия, а версия у меня что ни на есть новая!!! 1.4.7 - но где-то, не могу найти где, ведь чистил целиком и /var/db/pkg и /usr/ports пакет находит умоминание о pkg_1.3.8 и при этом настойчиво удаляет сам себя 1.4.7 - как решать - не знаю

Отправлено спустя 23 минуты 8 секунд:
По субботам на форум вообще заходят?

Аватара пользователя
tom.cat
старшина
Сообщения: 441
Зарегистрирован: 2007-11-24 20:23:49
Откуда: Мытищи
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение tom.cat » 2015-02-01 18:25:22

MaestroBSD писал(а):я уйду на nginx
Давно пора
When you see pigs fly it means Windows has become open source

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35182
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Не устанавливается apache 22

Непрочитанное сообщение Alex Keda » 2015-02-01 19:37:21

я бы настоятельно посоветовал удалить /usr/local и сделать всё с нуля, ибо
удалил нахрен /var/db/pkg/*
не приводит у удалению софта.
Убей их всех! Бог потом рассортирует...

Аватара пользователя
andrian_freebsd
сержант
Сообщения: 171
Зарегистрирован: 2013-08-21 16:10:16
Откуда: Україна

Не устанавливается apache 22

Непрочитанное сообщение andrian_freebsd » 2015-02-08 21:25:36

переустанови каждый порт который нужен для apache в ручную, например пересобери apr1, стартуй apache и оно тебе скажет что еще надо переустановить.