Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
shuk007
рядовой
Сообщения: 45
Зарегистрирован: 2009-02-05 12:19:38

Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение shuk007 » 2011-02-17 11:39:28

Здравствуйте!
У меня старая железка, на нем стоит FreeBSD 6.2. ( Новые версии почему-то не установились)
Теперь возникла проблема с установкой порта libxml2-2.7.8. Порты обновил и старые поставил результат NULL.
Код ошибки:

Код: Выделить всё

checking for iconv declaration...
        extern size_t iconv (iconv_t cd, const char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
Disabling ICU support
Enabled Schematron support
Enabled Schemas/Relax-NG support
./configure.lineno: 14590: Syntax error: Bad substitution
===>  Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome@FreeBSD.org, and attach (a)
"/usr/ports/textproc/libxml2/work/libxml2-2.7.8/config.log", (b) the output
of the failed make command, and (c) the gnomelogalyzer output. Also, it might
be a good idea to provide an overview of all packages installed on your system
(i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome@FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** Error code 1

Stop in /usr/ports/textproc/libxml2.
Помогите плиз
Последний раз редактировалось f_andrey 2011-02-17 14:41:47, всего редактировалось 1 раз.
Причина: Автору, выбирайте пожалуйста раздел соответствуюший тематике вашего сообщения.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение hizel » 2011-02-17 12:16:08

Код: Выделить всё

pkg_version -vI | grep need
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
shuk007
рядовой
Сообщения: 45
Зарегистрирован: 2009-02-05 12:19:38

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение shuk007 » 2011-02-17 12:18:34

Код: Выделить всё

net# pkg_version -vI | grep need
net# pkg_version -v | grep need
linux_base-fc-4_15                  <   needs updating (port has 4_16)
mysql-client-5.1.54_1               <   needs updating (port has 5.1.55)
mysql-server-5.1.54_1               <   needs updating (port has 5.1.55)

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение manefesto » 2011-02-17 12:51:09

посмотри на тут строчку которую ругается, а вообще удали папку порта и обнови порты
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1089
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение iZEN » 2011-02-17 14:05:11

Поддержка FreeBSD 6.2 современной коллекцией портов не гарантирована.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
shuk007
рядовой
Сообщения: 45
Зарегистрирован: 2009-02-05 12:19:38

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение shuk007 » 2011-02-17 14:42:45

iZEN писал(а):Поддержка FreeBSD 6.2 современной коллекцией портов не гарантирована.
да это факт, новые версии FreeBSD на моем PC не устанавливаются "почему-то", после установки ОС не загружаеться

ni4
проходил мимо

Re: Не устанавливается libxml2-2.7.8 на FreeBSD 6.2

Непрочитанное сообщение ni4 » 2012-04-24 22:03:47

Попался на такуюже проблему. Решено тут: http://forums.freebsd.org/showthread.php?t=20273
Нужно закомментировать проблемную строчку в Configure.