Ошибка обновления apache-openoffice-3.4

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Гость
проходил мимо

Ошибка обновления apache-openoffice-3.4

Непрочитанное сообщение Гость » 2013-09-01 4:00:02

При обнолении до версии apache-openoffice-3.4.1_2 выдает следующую ошибку:

Код: Выделить всё

Configure completed

Run ./bootstrap in /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main to provide build tools and get third-party packages
===>  Building for apache-openoffice-3.4.1_2
Can't locate LWP/UserAgent.pm in @INC (@INC contains: /usr/local/lib/perl5/5.14/BSDPAN /usr/local/lib/perl5/site_perl/5.14/mach /usr/local/lib/perl5/site_perl/5.14 /usr/local/lib/perl5/5.14/mach /usr/local/lib/perl5/5.14 .) at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/download_external_dependencies.pl line 64.
BEGIN failed--compilation aborted at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/download_external_dependencies.pl line 64.

dmake is located in search path

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/modules /usr/local/lib/perl5/5.14/BSDPAN /usr/local/lib/perl5/site_perl/5.14/mach /usr/local/lib/perl5/site_perl/5.14 /usr/local/lib/perl5/5.14/mach /usr/local/lib/perl5/5.14 .) at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/modules/ExtensionsLst.pm line 25.
BEGIN failed--compilation aborted at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/modules/ExtensionsLst.pm line 25.
Compilation failed in require at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/download_missing_extensions.pl line 25.
BEGIN failed--compilation aborted at /usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/solenv/bin/download_missing_extensions.pl line 25.
*** Error code 2

Stop in /usr/ports/editors/openoffice-3.
*** Error code 1

Stop in /usr/ports/editors/openoffice-3.

===>>> make failed for editors/openoffice-3
===>>> Aborting update

===>>> Killing background jobs
Terminated

===>>> You can restart from the point of failure with this command line:
       portmaster <flags> editors/openoffice-3 

===>>> Exiting

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

rayder
лейтенант
Сообщения: 661
Зарегистрирован: 2008-12-18 16:29:43
Откуда: Ukraine/Kiev
Контактная информация:

Re: Ошибка обновления apache-openoffice-3.4

Непрочитанное сообщение rayder » 2013-09-02 10:23:23

А вы в читайтесь в то что вам написало:

Код: Выделить всё

Can't locate LWP/UserAgent.pm in @INC
И посмиотрите в эту сторону:

Код: Выделить всё

#make search name=p5-LWP-UserAgent -C /usr/ports/ | grep ^Port
Человеку свойственно ошибаться, но для нечеловеческих ляпов нужен компьютер.

Аватара пользователя
vintovkin
ВДВ
Сообщения: 1286
Зарегистрирован: 2007-05-11 9:39:11
Откуда: CSKA

Re: Ошибка обновления apache-openoffice-3.4

Непрочитанное сообщение vintovkin » 2013-09-02 12:03:01

можно начать с этого:

Код: Выделить всё

pkgdb -Fu
portsnap fetch update
portupgrade -afRr openoffice*
Junos OS kernel based on FreeBSD UNIX.