ошибка обновления порта ipsec-tools

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
24rus
мл. сержант
Сообщения: 75
Зарегистрирован: 2008-09-27 16:04:59
Откуда: Красноярск
Контактная информация:

ошибка обновления порта ipsec-tools

Непрочитанное сообщение 24rus » 2014-01-23 7:33:57

Доброго времени суток!

Столкнулся с проблемой, при обновлении порта ipsec-tools.

Код: Выделить всё

portupgrade -r ipsec-tools
...
...
...
checking if --with-openssl option is specified... default
checking openssl version... too old
configure: error: OpenSSL version must be 0.9.8s or higher. Aborting.
===>  Script "configure" failed unexpectedly.
Please report the problem to vanhu@netasq.com [maintainer] and attach the
"/usr/ports/security/ipsec-tools/work/ipsec-tools-0.8.1/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/sbin/pkg_info -Ea).
*** Error code 1

Stop in /usr/ports/security/ipsec-tools.
*** Error code 1
Видно что ругается на: configure: error: OpenSSL version must be 0.9.8s or higher. Aborting.

При этом:

Код: Выделить всё

portversion -v
...
nload-0.7.4                 =  up-to-date with port
openldap-client-2.4.38      =  up-to-date with port
openssl-1.0.1_9             =  up-to-date with port
p5-Locale-gettext-1.05_3    =  up-to-date with port
pcre-8.33                   =  up-to-date with port
...
в UPDATING ничего не нашел по поводу обновления ipsec-tools.

Куда копать ?
Show must go on !

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

snorlov
подполковник
Сообщения: 3714
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: ошибка обновления порта ipsec-tools

Непрочитанное сообщение snorlov » 2014-01-23 8:10:24

Посмотреть где стоит openssl, мне кажется он идет в исходники ядра, а там именно устаревшая версия...

Аватара пользователя
skeletor
майор
Сообщения: 2486
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: ошибка обновления порта ipsec-tools

Непрочитанное сообщение skeletor » 2014-01-23 16:14:08

А что говорит

Код: Выделить всё

$openssl version
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

Аватара пользователя
24rus
мл. сержант
Сообщения: 75
Зарегистрирован: 2008-09-27 16:04:59
Откуда: Красноярск
Контактная информация:

Re: ошибка обновления порта ipsec-tools

Непрочитанное сообщение 24rus » 2014-01-24 4:33:17

to skeletor

Код: Выделить всё

=> openssl version
=> OpenSSL 0.9.8q 2 Dec 2010
Show must go on !

_skeletor
проходил мимо

Re: ошибка обновления порта ipsec-tools

Непрочитанное сообщение _skeletor » 2014-01-26 17:09:48

Вот и ответ. Переустановите заново из портов openssl и проверьте опять версию.

Аватара пользователя
24rus
мл. сержант
Сообщения: 75
Зарегистрирован: 2008-09-27 16:04:59
Откуда: Красноярск
Контактная информация:

Re: ошибка обновления порта ipsec-tools

Непрочитанное сообщение 24rus » 2014-01-27 4:43:49

to snorlov Да OpenSSl идет вместе с ядром, обновил фряху с 8,2 до 8,4, и стало OpenSSL 0.9.8y 5 Feb 2013 , и порт ipsec-tools обновился.
p.s. можно было заменить openssl из ядра, на openssl из порта, через make.conf, но решил лучше freebsd-update upgrade -r <name>
Show must go on !