проблема при запуске SAMS

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

проблема при запуске SAMS

Непрочитанное сообщение db » 2013-02-25 13:38:05

здравствуйте!
помогите пожалуйста - вот такая проблема: у меня при запуске SAMS пишет: Table 'squidctrl.log' doesn't exist'. пробовал из консоли удалять squidctrl.sams и squidctrl.log и в браузере заново запускать создение баз sql. тоже самое. и кстати в браузере не полностью открывает веб-интерфейс самса. вот такие вот картинки во вложении; в чем может быть проблема?
Вложения
sams2.JPG
sams.JPG
sams.JPG (7.8 КБ) 653 просмотра

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Charlz_Klug
рядовой
Сообщения: 49
Зарегистрирован: 2008-11-18 7:31:34

Re: проблема при запуске SAMS

Непрочитанное сообщение Charlz_Klug » 2013-02-25 16:07:41

db писал(а):вот такая проблема: у меня при запуске SAMS пишет: Table 'squidctrl.log' doesn't exist'. пробовал из консоли удалять squidctrl.sams и squidctrl.log и в браузере заново запускать создение баз sql. тоже самое.
Покажите содержимое базы данных.

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-02-27 12:16:52

а щас вообще перестала открываться база, и в браузере не загружается скрипт phpinfo();
Вложения
database.JPG

Charlz_Klug
рядовой
Сообщения: 49
Зарегистрирован: 2008-11-18 7:31:34

Re: проблема при запуске SAMS

Непрочитанное сообщение Charlz_Klug » 2013-02-28 17:42:35

db писал(а):а щас вообще перестала открываться база, и в браузере не загружается скрипт phpinfo();
Вот так

Код: Выделить всё

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| mysql              |
| performance_schema |
| squidctrl          |
| squidlog           |
| test               |
+--------------------+
6 rows in set (0.05 sec)

mysql> 

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-03-04 11:58:28

извиняюсь ошибся; база открывается, содержимое во вложении.
но в браузере не загружается скрипт phpinfo(); может проблема в php? и в браузере при открытии sams, сверху, возникают ошибки? а может проблема в том, что я по ошибке вначале установил sams, а потом mysql-server?
Вложения
sams2.JPG
databases.JPG

Аватара пользователя
vadim64
майор
Сообщения: 2098
Зарегистрирован: 2009-09-17 15:15:26
Откуда: Засратовец

Re: проблема при запуске SAMS

Непрочитанное сообщение vadim64 » 2013-03-04 15:39:16

вы бы хоть почитали эти "ошибки"
слово notice как бы намекает что это не ошибки
слова для гугла php off notice
Люди не делятся на национальности, партии, фракции и религии. Люди делятся на умных и дураков, а вот дураки делятся на национальности, партии, фракции и религии.

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-03-05 17:08:16

убрал эти намеки, спасибо за подсказку! но дальше что-то в браузере у меня не настраивается самс. или надо еще что-то сделать? или что-то не так настроено?

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-03-05 17:47:43

в sams-e не настраивается web interface settings (не отображается в правом окне sams-a); и не отображается sams administaration; кстати phpinfo тоже перестал открываться в браузере. может крякнулся php?

Аватара пользователя
vadim64
майор
Сообщения: 2098
Зарегистрирован: 2009-09-17 15:15:26
Откуда: Засратовец

Re: проблема при запуске SAMS

Непрочитанное сообщение vadim64 » 2013-03-06 8:30:46

да, смотрите логи вебсервера
Люди не делятся на национальности, партии, фракции и религии. Люди делятся на умных и дураков, а вот дураки делятся на национальности, партии, фракции и религии.

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-03-15 14:57:25

удалил php53, поставил php52; удалил mysql55; поставил mysql51; и походу переустановил sams. все заработало! спасибо за подсказки!!! видимо проблема была в php53. а может и еще в чем другом. посмотрел в гугле, там тоже у некоторых после переустановки с php53 на php52, разрешилась проблема с sams-ом. :). тему можно закрыть. еще раз спасибо за подсказки !!! :).

db
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-24 14:30:24

Re: проблема при запуске SAMS

Непрочитанное сообщение db » 2013-03-17 15:37:38

при добавлении новых пользователей в sams и далее реконфигурировании sams, в freebsd не завершается выполнение команды (в консоле) по добавлению пользователей в ncsa.sams, но пользователи добавляются. кто-нибудь сталкивался с такой проблемой? :)