Проблемы при установке Gnome на виртуальную машину

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-04 19:07:38

Приветствую всех.Помогите пожалуйста разобраться.Сколько раз пытался поставить гнома на виртуалку, столько раз заканчивалось удачей. Хочу поставить наконец-таки.
Ставлю из портов, ставилось-ставилось и заглохло:

Код: Выделить всё


[20:02] |root|   /usr/ports/x11/gnome2>  make install clean
===>  Installing for gnome2-2.32.1_4
===>   gnome2-2.32.1_4 depends on file: /usr/local/libexec/gweather-applet-2 - n                        ot found
===>    Verifying install for /usr/local/libexec/gweather-applet-2 in /usr/ports                        /x11/gnome-applets
===>   gnome-applets-2.32.1.1_4 depends on file: /usr/local/libdata/pkgconfig/sy                        stem-tools-backends-2.0.pc - found
===>   gnome-applets-2.32.1.1_4 depends on file: /usr/local/libexec/gnome-settin                        gs-daemon - not found
===>    Verifying install for /usr/local/libexec/gnome-settings-daemon in /usr/p                        orts/sysutils/gnome-settings-daemon
===>   gnome-settings-daemon-2.32.1_4 depends on executable: gmake - found
===>   gnome-settings-daemon-2.32.1_4 depends on file: /usr/local/libdata/pkgcon                        fig/xxf86misc.pc - found
===>   gnome-settings-daemon-2.32.1_4 depends on package: gstreamer-plugins-good                        >=0.10.0 - not found
===>    Verifying install for gstreamer-plugins-good>=0.10.0 in /usr/ports/multi                        media/gstreamer-plugins-good
===>   gstreamer-plugins-good-0.10.31,3 depends on package: gstreamer-plugins>=0                        .10.0 - not found
===>    Verifying install for gstreamer-plugins>=0.10.0 in /usr/ports/multimedia                        /gstreamer-plugins
===>   gstreamer-plugins-0.10.36,3 depends on package: v4l_compat>=1.0.20110720                         - found
===>   gstreamer-plugins-0.10.36,3 depends on package: gstreamer>=0.10.36 - foun                        d
===>   gstreamer-plugins-0.10.36,3 depends on package: orc>=0.4.14 - not found
===>   Found orc-0.4.11, but you need to upgrade to orc>=0.4.14.
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-plugins.
*** Error code 1

Stop in /usr/ports/multimedia/gstreamer-plugins-good.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-settings-daemon.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-settings-daemon.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
Где и чем копать?
Из пакетов тоже самое, качал качал пакеты, потом перестал с какой-то ошибкой...
Последний раз редактировалось f_andrey 2012-07-04 19:25:00, всего редактировалось 1 раз.
Причина: Автору, выбирайте пожалуйста раздел соответствуюший тематике вашего сообщения.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-04 21:24:38

Обновил orc, вроде процесс пошёл дальше, буду тут спрашивать совета с вашего позволения при возникновении вопросов и разного рода проблем.

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-05 18:11:57

Теперь вот это вылезло, подскажите как решить...

Код: Выделить всё

===>  Configuring for consolekit-0.4.3
configure: error: cannot find sources (src/ck-manager.c) in . or ..
===>  Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome@FreeBSD.org, and attach (a)
"/usr/ports/sysutils/consolekit/work/ConsoleKit-0.4.3/config.log", (b) the
output of the failed make command, and (c) the gnomelogalyzer output. Also,
it might be a good idea to provide an overview of all packages installed on
your system (i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome@FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** Error code 1

Stop in /usr/ports/sysutils/consolekit.
*** Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-settings-daemon.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-settings-daemon.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
*** Error code 1

Stop in /usr/ports/x11/gnome2.


Гость
проходил мимо

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Гость » 2012-07-05 21:55:08

Laterport писал(а):Теперь вот это вылезло, подскажите как решить...

Код: Выделить всё

===>  Configuring for consolekit-0.4.3
configure: error: cannot find sources (src/ck-manager.c) in . or ..
судя по всему сырцов хочет. у Вас они установлены ?

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-06 6:47:24

Ну если просит, значит не установлены. Как их устанавливать? Как установить конкретно что он хочет!?

Аватара пользователя
sadchok
сержант
Сообщения: 271
Зарегистрирован: 2011-10-13 10:40:54
Откуда: Алтайский край

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение sadchok » 2012-07-06 6:59:08

The brain can not be found. Runs the software emulation


Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-06 11:18:50

Обновил,

Код: Выделить всё

Updating collection src-all/cvs
Shutting down connection to server
Finished successfully
Но ошибка не ушла.

Вот что прописал в supfile

Код: Выделить всё

*default host=cvsup.fi.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_9_0_0_RELEASE
*default delete use-rel-suffix
*default compress
src-all


receptor
мл. сержант
Сообщения: 106
Зарегистрирован: 2010-05-02 12:59:03

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение receptor » 2012-07-06 21:21:55

Гость писал(а):
Laterport писал(а):Теперь вот это вылезло, подскажите как решить...

Код: Выделить всё

===>  Configuring for consolekit-0.4.3
configure: error: cannot find sources (src/ck-manager.c) in . or ..
судя по всему сырцов хочет. у Вас они установлены ?
Это сорцы устанаваливаемого пакета.


Я так думаю вы там натыкали опций при сборке с которыми не хочет собираться.
Обновите порты portsnap fetch extract
/var/db/ports удалите отсюда все папки относящиеся к сборке гнома, или даже вообще все если машина тестовая.
Пробуйте ещё.


Но не советую из портов ставить гном.
Куда проще набрать pkg_add -r gdm gnome2 а дальше уже настроить как нужно или даже пересобрать нужные пакеты из портов.

Аватара пользователя
Electronik
капитан
Сообщения: 1593
Зарегистрирован: 2008-11-15 17:32:56
Откуда: Минск
Контактная информация:

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Electronik » 2012-07-06 23:11:44

лучше сначала сделать make clean, а потом снова запустить make && make install && make clean
Предскажем будущее hw по логам и дампу, снимем сглаз и порчу с рута, поможем придумать пароль(С)
Блог

Гость
проходил мимо

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Гость » 2012-07-07 0:15:20

Electronik писал(а):запустить make && make install && make clean
можно просто

Код: Выделить всё

make install clean
;-)

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-09 14:20:27

Спасибо за ваши ответы.
Поставил всё из пакетов. Ну, теперь другое. Тестовый запуск иксов:

Код: Выделить всё

localhost# Xorg -config xorg.conf.new -retro

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:18:11 2012
(EE) Unable to locate/open config file: "xorg.conf.new"
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
Лог Xorg-а

Код: Выделить всё

Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:08:39 2012
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
Shared object "libpng.so.6" not found, required by "gnome-session"xinit: connect                                        ion to X server lost

waiting for X server to shut down failed to unset mtrr: Device not configured

localhost#  Failed to load module "vboxvideo"
localhost# xinit /usr/local/lib/X11/xinit/xinitrc -- /usr/local/bin/Xorg -retro -dpi 120


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:11:48 2012
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
/usr/local/etc/rc.d/hald start
^Cxinit: connection to X server lost

waiting for X server to shut down XIO:  fatal IO error 0 (No error: 0) on X server ":0"
      after 501 requests (501 known processed) with 0 events remaining.
xterm:  fatal IO error 35 (Resource temporarily unavailable) or KillClient on X server ":0"
xterm:  fatal IO error 35 (Resource temporarily unavailable) or KillClient on X server ":0"
xterm:  fatal IO error 35 (Resource temporarily unavailable) or KillClient on X server ":0"
failed to unset mtrr: Device not configured

xinit: unexpected signal 2
localhost# /usr/local/etc/rc.d/hald start.
/usr/local/etc/rc.d/hald: unknown directive 'start.'.
Usage: /usr/local/etc/rc.d/hald [fast|force|one](start|stop|restart|rcvar|status|poll)
localhost# /usr/local/etc/rc.d/hald start
Starting hald.
localhost# /usr/local/etc/rc.d/dbus start
dbus already running? (pid=974).
localhost# Xorg -configure

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:15:51 2012
List of video drivers:
        ati
        radeon
        intel
        mach64
        nv
        openchrome
        r128
        radeonhd
        vesa
(++) Using config file: "/root/xorg.conf.new"


Xorg detected your mouse at device /dev/sysmouse.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/xorg.conf.new

To test the server, run 'X -config /root/xorg.conf.new'

localhost# Xorg -config xorg.conf.new -retro

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:15:58 2012
(EE) Unable to locate/open config file: "xorg.conf.new"
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
^Cfailed to unset mtrr: Device not configured
localhost# Current version of pixman: 0.24.2
        to make sure that you have the latest version.
Current: Command not found.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
localhost#         (WW) warning, (EE) error, (NI) not impleme        Before reporting problems, check http://wiki.x.org
Before: Command not found.
localhost#         to make sure that you have the latest version.
to: Command not found.
localhost# Markers: (--) probed, (**) from config file, (==) default setting,
Badly placed (.
localhost#         (++) from command line, (!!) notice, (II) informational,
( ++ ) from command line, ( Markers: ( -- ) probed, ( ** ) from config file, ( == ) default setting, ) notice, ( II ) informational,
Too many )'s.
localhost#         (WW) warning, (EE) error, (NI) not impleme
localhost# rm /root/xorg.conf
localhost# find /root/ xorg.conf.new
/root/
/root/.k5login
/root/.profile
/root/.cshrc
/root/.login
/root/.mc
/root/.mc/history
/root/.mc/panels.ini
/root/.mc/ini
/root/.mc/Tree
/root/.history
/root/.xinitrc
/root/.mysql_history
/root/xorg.conf.new
/root/.Xauthority
find: xorg.conf.new: No such file or directory
localhost# Xorg -config xorg.conf.new -retro

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:18:11 2012
(EE) Unable to locate/open config file: "xorg.conf.new"
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
^Cfailed to unset mtrr: Device not configured
localhost#
localhost# clear
localhost# Xorg -config xorg.conf.new -retro

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:21:59 2012
(EE) Unable to locate/open config file: "xorg.conf.new"
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
^Cfailed to unset mtrr: Device not configured
localhost# clear
localhost# ee /var/log/Xorg.0.log
^[ (escape) menu  ^y search prompt  ^k delete line   ^p prev li   ^g prev page
^o ascii code     ^x search         ^l undelete line ^n next li   ^v next page
^u end of file    ^a begin of line  ^w delete word   ^b back 1 char
^t top of text    ^e end of line    ^r restore word  ^f forward 1 char
^c command        ^d delete char    ^j undelete char ^z next word
=====line 1 col 0 lines from top 1 ============================================

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@ob
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:21:59 2012
(EE) Unable to locate/open config file: "xorg.conf.new"
(II) Loader magic: 0x81e0080
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 InnoTek Systemberatung GmbH VirtualBox Graphics Adapter rev 0, Mem @ 0xe0000000/
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
        Section "Device"
                Identifier      "Builtin Default vboxvideo Device 0"
                Driver  "vboxvideo"
        EndSection
        Section "Screen"
                Identifier      "Builtin Default vboxvideo Screen 0"
                Device  "Builtin Default vboxvideo Device 0"
file "/var/log/Xorg.0.log", 1388 lines


Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-09 14:35:47

*в прошлом посте он не мог найти файл конфига, это я исправил.

Код: Выделить всё

Поставил всё из пакетов. Ну, теперь другое. Запуск иксов:

[code]localhost# startx
xauth:  file /root/.serverauth.1690 does not exist


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 23:33:52 2012
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
failed to set mtrr: Device not configured
Shared object "libpng.so.6" not found, required by "gnome-session"xinit: connection to X server lost

waiting for X server to shut down


[/code]

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-09 15:49:13

Последняя ругалка.

Код: Выделить всё

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 9.0-RELEASE i386
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 03 December 2011  06:59:29AM

Current version of pixman: 0.24.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 10 00:41:21 2012
(==) Using config file: "/etc/X11/xorg.conf"
(EE) LoadModule: Module fbdevhw does not have a fbdevhwModuleData data object.
(EE) Failed to load module "fbdevhw" (invalid module, 0)
(EE) No devices detected.

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-09 19:15:29

Поставил pkg_add -r virtualbox-ose-additions
подкрутил конфиг, осталось совсем немного видимо, не пойму что нужно ещё подкрутить.

Код: Выделить всё

localhost# startx 
xauth:  file /root/.serverauth.1444 does not exist 


X.Org X Server 1.7.7 
Release Date: 2010-05-04 
X Protocol Version 11, Revision 0 
Build Operating System: FreeBSD 9.0-RELEASE i386 
Current Operating System: FreeBSD localhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:15:25 UTC 2012     root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386 
Build Date: 03 December 2011  06:59:29AM 

Current version of pixman: 0.24.2 
        Before reporting problems, check http://wiki.x.org 
        to make sure that you have the latest version. 
Markers: (--) probed, (**) from config file, (==) default setting, 
        (++) from command line, (!!) notice, (II) informational, 
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown. 
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul  9 21:58:53 2012 
(==) Using config file: "/etc/X11/xorg.conf" 
Shared object "libpng.so.6" not found, required by "gnome-session"xinit: connection to X server lost 

waiting for X server to shut down . 
localhost# 

receptor
мл. сержант
Сообщения: 106
Зарегистрирован: 2010-05-02 12:59:03

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение receptor » 2012-07-09 23:12:23

Поставил pkg_add -r virtualbox-ose-additions
Там только скачивается исошник который нужно ещё монтировать, а только потом ставить.


Удалите всё к чертям и поставьте из пакетов
pkg_delete -a
pkg_add -r xorg gdm gnome2


gdm_enable="YES"

и работает.



А по той ошибке так оно само говорит чего нету

pkg_add -r png

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-10 13:17:35

Поставил всё по новой из пакетов.
После запуска /usr/local/etc/rc.d/gdm start
появляется графика, а именно окно ввода логина и пароля. Ввожу, потом несколько секунд полёт нормальный и курсор меняет значок на часики, после этого всё зависает. Какие логи показать чтобы понять почему? Xorg-a?

Laterport
ефрейтор
Сообщения: 58
Зарегистрирован: 2012-03-30 13:00:17

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Laterport » 2012-07-11 11:42:16

Вопрос снят. Всё заработало.
нужно было прописать procfs в fstab и добавить ещё одного пользователя в систему. У меня был только root. Может кому пригодится.

Аватара пользователя
Neus
капитан
Сообщения: 1780
Зарегистрирован: 2008-09-08 21:59:56

Re: Проблемы при установке Gnome на виртуальную машину

Непрочитанное сообщение Neus » 2012-07-11 15:41:33

Laterport писал(а):Вопрос снят. Всё заработало.
нужно было прописать procfs в fstab и добавить ещё одного пользователя в систему. У меня был только root. Может кому пригодится.
это в хэндбуке написано