Делаем Nat из addpac 100(попытка написать статью)

Решение проблем связванных с работой железа. Проблемы программно-аппаратной совместимости.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
kenny
мл. сержант
Сообщения: 78
Зарегистрирован: 2008-11-21 15:13:53
Откуда: Москва
Контактная информация:

Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение kenny » 2009-08-14 15:00:33

Была такая ситуация что погиб полностью сервер который проксировал :( нужно было срочно что то придумать чтобы пустить людей в нет пока пока не восстановлю сервер.
Оборудование минимум в нашел только addpac ap100. В документации нашел что оказывается он умеет натить ;-) ну и гуд пробуем :smile:
Исходные данные:
- Внешний ip-адрес AddPac 85.21.56.6 mask 255.255.255.248(ip-адрес маршрутизатора 85.21.56.1)
- Внутреняя сеть : 192.168.0.1 mask 255.255.255.0
И так телнетимся.

Код: Выделить всё

AddPac> enable
AddPac# configure terminal
AddPac(config)# ip routing
Настраиваем интерфейс который смотрит во всемирную паутину Ethernet 0 0 , в AP100 это "LAN0", в VP200, VP300, VP350 насколько помню называется "LAN"

Код: Выделить всё

AddPac(config)# interface FastEthernet 0/0
AddPac(config-if)# ip address 85.21.56.6 255.255.255.248 // присваевам ip mask интерфейсу
AddPac(config-if)# ip nat outside //включаем nat
AddPac(config-if)# speed auto //скорость устанавливаем автоматически 
AddPac(config-if)# ip route 0.0.0.0 0.0.0.0 85.21.56.1 // заварачиваем все на шлюз провайдера
Теперь настроем нашу локалку AP100- "LAN1", VP200,VP300,VP350 - "PC" на счет последних могу ошибатся

Код: Выделить всё

AddPac(config)# interface FastEthernet 0/1
AddPac(config-if)# ip address 192.168.0.1 255.255.255.0 // присваевам ip mask интерфейсу
AddPac(config-if)# ip nat inside
AddPac(config-if)# speed auto //скорость устанавливаем автоматически 
Далее разрешаем ходить все из локалки в интернет.

Код: Выделить всё

AddPac(config)# access-list 100 permit ip 192.168.0.0 .0.0.0.255
AddPac(config)# ip nat inside source list 100 inteface FastEthernet0/0 overload
Сохраняемся

Код: Выделить всё

AddPac# write
Чтобы получится информацию о конфигурации NAT набираем команду.

Код: Выделить всё

AddPac# show ip nat arp
AddPac# show ip nat statistic
AddPac# show ip nat translations
Для диагностики

Код: Выделить всё

AddPac# debug ip nat translations
AddPac# debug ip nat detail
Для отлючения отладки

Код: Выделить всё

AddPac# no debug all
В принципе все, надеюсь ничего не забыл и вам будет полезна данная информация :oops:

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Fioktist
мл. сержант
Сообщения: 84
Зарегистрирован: 2007-04-06 4:06:28
Откуда: Россия

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение Fioktist » 2009-08-17 2:45:49

веткой форума ошибся, в железо надо было разместить...
Последний раз редактировалось Fioktist 2009-08-19 22:06:39, всего редактировалось 1 раз.
Самое возмутительное в аргументах оппонента - это изобилие правды.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35332
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение Alex Keda » 2009-08-18 7:27:58

э... простите...
это вы на телефоне сделали? или на чём?
Убей их всех! Бог потом рассортирует...

kenny
мл. сержант
Сообщения: 78
Зарегистрирован: 2008-11-21 15:13:53
Откуда: Москва
Контактная информация:

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение kenny » 2009-08-18 8:33:59

Прошу прощения если не в ту ветку и сообще не нужно. Я не рекламлю, была ситуация и нужно было выкручиватся.
Делал из
Изображение
Еще раз прошу прощения если не в тему статейка :oops:

Аватара пользователя
skeletor
майор
Сообщения: 2534
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение skeletor » 2009-08-18 15:41:23

Круто!!! Не знал, что на адпаке такое можно сделать.
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение manefesto » 2009-08-19 10:05:41

хотелось бы пощупать сей девайс
я такой яростный шо аж пиздеЦ
Изображение

kenny
мл. сержант
Сообщения: 78
Зарегистрирован: 2008-11-21 15:13:53
Откуда: Москва
Контактная информация:

Re: Делаем Nat из addpac 100(попытка написать статью)

Непрочитанное сообщение kenny » 2009-08-19 10:34:54

как шлюз телефонии мегко говоря не айс, для дома подойдет в принципе но для офиса у addpac есть и намного лучше модельки :smile:
а вот как nat неделю прожил правда нагрузка не большая 60 пользователей :smile: