FreeBSD 8.1 amd64 виснет

Решение проблем связванных с работой железа. Проблемы программно-аппаратной совместимости.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-27 10:45:42

Было куплено новое железо для билинга в связи с возрастанием количество абонентов:
  • Код: Выделить всё

    Платформа ASUS 1U RS702D-E6-P 2-in-1(LGA1366,i5520,2xPCI-E,SVGA,SATARAID,8xHS SATA, 4xGbLAN, InfiniBand, 24DDR-III,770Wx2)
    Подробнее:
    2 сервера на МП Z8NH-D12, собранных в одном корпусе,чипсет Intel 5500 + 82801IJR (ICH10R)),Intel 82574L 10/100/1000 Мбит/с,камни CPU Intel Xeon E5620 BOX 2.4 ГГц/12Мб/5.86 ГТ/с LGA1366, память Kingston <KVR1066D3D4R7S/4G> DDR-III DIMM 4Gb <PC3-8500> ECC Registered with Parity CL7
Итак, заводим 1 сервер. Конфигурация-16гигов оперативки,2 камня,raid1 с помощью тамашнего рейдконтроллера.
Ставится туда: 8.1 amd64..
Имеем:

Код: Выделить всё

Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.1-RELEASE #0: Mon Jan 24 18:46:53 MSK 2011
    admin@nas1.local:/usr/src/sys/amd64/compile/NODENY amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz (2407.30-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x206c2  Family = 6  Model = 2c  Stepping = 2
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x29ee3ff<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,<b17>,DCA,SSE4.1,SSE4.2,POPCNT,AESNI>
  AMD Features=0x2c100800<SYSCALL,NX,Page1GB,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant
real memory  = 17179869184 (16384 MB)
avail memory = 16537972736 (15771 MB)
ACPI APIC Table: <111610 APIC1454>
FreeBSD/SMP: Multiprocessor System Detected: 16 CPUs
FreeBSD/SMP: 2 package(s) x 4 core(s) x 2 SMT threads
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
 cpu2 (AP): APIC ID:  2
 cpu3 (AP): APIC ID:  3
 cpu4 (AP): APIC ID: 18
 cpu5 (AP): APIC ID: 19
 cpu6 (AP): APIC ID: 20
 cpu7 (AP): APIC ID: 21
 cpu8 (AP): APIC ID: 32
 cpu9 (AP): APIC ID: 33
 cpu10 (AP): APIC ID: 34
 cpu11 (AP): APIC ID: 35
 cpu12 (AP): APIC ID: 50
 cpu13 (AP): APIC ID: 51
 cpu14 (AP): APIC ID: 52
 cpu15 (AP): APIC ID: 53
ioapic0: Changing APIC ID to 6
ioapic1: Changing APIC ID to 7
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ioapic1 <Version 2.0> irqs 24-47 on motherboard
lapic0: Forcing LINT1 to edge trigger
kbd1 at kbdmux0
acpi0: <111610 XSDT1454> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of fee00000, 1000 (3) failed
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, bff00000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
ACPI Warning: Incorrect checksum in table [OEMB] - 0x D, should be 0x A (20100331/tbutils-354)
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
cpu4: <ACPI CPU> on acpi0
cpu5: <ACPI CPU> on acpi0
cpu6: <ACPI CPU> on acpi0
cpu7: <ACPI CPU> on acpi0
cpu8: <ACPI CPU> on acpi0
cpu9: <ACPI CPU> on acpi0
cpu10: <ACPI CPU> on acpi0
cpu11: <ACPI CPU> on acpi0
cpu12: <ACPI CPU> on acpi0
cpu13: <ACPI CPU> on acpi0
cpu14: <ACPI CPU> on acpi0
cpu15: <ACPI CPU> on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci14: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci13: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci12: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci11: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci10: <ACPI PCI bus> on pcib5
pci10: <serial bus> at device 0.0 (no driver attached)
pcib6: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci9: <ACPI PCI bus> on pcib6
pcib7: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci8: <ACPI PCI bus> on pcib7
em0: <Intel(R) PRO/1000 Network Connection 7.0.5> port 0xec00-0xec1f mem 0xfbd20000-0xfbd3ffff,0xfbd80000-0xfbdfffff,0xfbd1c000-0xfbd1ffff irq 30 at device 0.0 on pci8
em0: Using MSIX interrupts with 5 vectors
em0: [ITHREAD]
em0: [ITHREAD]
em0: [ITHREAD]
em0: [ITHREAD]
em0: [ITHREAD]
em0: Ethernet address: 00:1b:21:8b:5c:f4
pcib8: <ACPI PCI-PCI bridge> at device 8.0 on pci0
pci7: <ACPI PCI bus> on pcib8
pcib9: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci6: <ACPI PCI bus> on pcib9
pcib10: <ACPI PCI-PCI bridge> at device 10.0 on pci0
pci5: <ACPI PCI bus> on pcib10
pci0: <base peripheral, interrupt controller> at device 16.0 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 16.1 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 17.0 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 17.1 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.0 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.1 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.2 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 20.3 (no driver attached)
pci0: <base peripheral> at device 22.0 (no driver attached)
pci0: <base peripheral> at device 22.1 (no driver attached)
pci0: <base peripheral> at device 22.2 (no driver attached)
pci0: <base peripheral> at device 22.3 (no driver attached)
pci0: <base peripheral> at device 22.4 (no driver attached)
pci0: <base peripheral> at device 22.5 (no driver attached)
pci0: <base peripheral> at device 22.6 (no driver attached)
pci0: <base peripheral> at device 22.7 (no driver attached)
uhci0: <Intel 82801JI (ICH10) USB controller USB-D> port 0x9400-0x941f irq 16 at device 26.0 on pci0
uhci0: [ITHREAD]
uhci0: LegSup = 0x2f00
usbus0: <Intel 82801JI (ICH10) USB controller USB-D> on uhci0
uhci1: <Intel 82801JI (ICH10) USB controller USB-E> port 0x9480-0x949f irq 21 at device 26.1 on pci0
uhci1: [ITHREAD]
uhci1: LegSup = 0x2f00
usbus1: <Intel 82801JI (ICH10) USB controller USB-E> on uhci1
ehci0: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> mem 0xfbaf8000-0xfbaf83ff irq 18 at device 26.7 on pci0
ehci0: [ITHREAD]
usbus2: EHCI version 1.0
usbus2: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> on ehci0
pcib11: <ACPI PCI-PCI bridge> irq 17 at device 28.0 on pci0
pci4: <ACPI PCI bus> on pcib11
pcib12: <ACPI PCI-PCI bridge> irq 17 at device 28.4 on pci0
pci3: <ACPI PCI bus> on pcib12
em1: <Intel(R) PRO/1000 Network Connection 7.0.5> port 0xdc00-0xdc1f mem 0xfbce0000-0xfbcfffff,0xfbcdc000-0xfbcdffff irq 16 at device 0.0 on pci3
em1: Using MSIX interrupts with 5 vectors
em1: [ITHREAD]
em1: [ITHREAD]
em1: [ITHREAD]
em1: [ITHREAD]
em1: [ITHREAD]
em1: Ethernet address: 90:e6:ba:97:59:39
pcib13: <ACPI PCI-PCI bridge> irq 16 at device 28.5 on pci0
pci2: <ACPI PCI bus> on pcib13
em2: <Intel(R) PRO/1000 Network Connection 7.0.5> port 0xcc00-0xcc1f mem 0xfbbe0000-0xfbbfffff,0xfbbdc000-0xfbbdffff irq 17 at device 0.0 on pci2
em2: Using MSIX interrupts with 5 vectors
em2: [ITHREAD]
em2: [ITHREAD]
em2: [ITHREAD]
em2: [ITHREAD]
em2: [ITHREAD]
em2: Ethernet address: 90:e6:ba:97:59:38
uhci2: <Intel 82801JI (ICH10) USB controller USB-A> port 0x9800-0x981f irq 23 at device 29.0 on pci0
uhci2: [ITHREAD]
uhci2: LegSup = 0x2f00
usbus3: <Intel 82801JI (ICH10) USB controller USB-A> on uhci2
uhci3: <Intel 82801JI (ICH10) USB controller USB-B> port 0x9880-0x989f irq 19 at device 29.1 on pci0
uhci3: [ITHREAD]
uhci3: LegSup = 0x2f00
usbus4: <Intel 82801JI (ICH10) USB controller USB-B> on uhci3
uhci4: <Intel 82801JI (ICH10) USB controller USB-C> port 0x9c00-0x9c1f irq 18 at device 29.2 on pci0
uhci4: [ITHREAD]
uhci4: LegSup = 0x2f00
usbus5: <Intel 82801JI (ICH10) USB controller USB-C> on uhci4
uhci5: <Intel 82801JI (ICH10) USB controller USB-F> port 0xa000-0xa01f irq 16 at device 29.3 on pci0
uhci5: [ITHREAD]
uhci5: LegSup = 0x2f00
usbus6: <Intel 82801JI (ICH10) USB controller USB-F> on uhci5
ehci1: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> mem 0xfbaf9000-0xfbaf93ff irq 23 at device 29.7 on pci0
ehci1: [ITHREAD]
usbus7: EHCI version 1.0
usbus7: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> on ehci1
pcib14: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci1: <ACPI PCI bus> on pcib14
vgapci0: <VGA-compatible display> port 0xb000-0xb07f mem 0xfb000000-0xfb7fffff,0xfafe0000-0xfaffffff irq 17 at device 1.0 on pci1
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH10 SATA300 controller> port 0xa080-0xa087,0xa880-0xa883,0xa800-0xa807,0xa480-0xa483,0xa400-0xa41f mem 0xfbafa000-0xfbafa7ff irq 18 at device 31.2 on pci0
atapci0: [ITHREAD]
atapci0: AHCI called from vendor specific driver
atapci0: AHCI v1.20 controller with 6 3Gbps ports, PM supported
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci0
ata5: [ITHREAD]
ata6: <ATA channel 4> on atapci0
ata6: [ITHREAD]
ata7: <ATA channel 5> on atapci0
ata7: [ITHREAD]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_button0: <Power Button> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart0: [FILTER]
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
uart1: [FILTER]
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xce000-0xcefff,0xcf000-0xcffff,0xd0000-0xd0fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: CGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3d0-0x3db iomem 0xb8000-0xbffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
ppc0: cannot reserve I/O port range
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
p4tcc2: <CPU Frequency Thermal Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
p4tcc3: <CPU Frequency Thermal Control> on cpu3
est4: <Enhanced SpeedStep Frequency Control> on cpu4
p4tcc4: <CPU Frequency Thermal Control> on cpu4
est5: <Enhanced SpeedStep Frequency Control> on cpu5
p4tcc5: <CPU Frequency Thermal Control> on cpu5
est6: <Enhanced SpeedStep Frequency Control> on cpu6
p4tcc6: <CPU Frequency Thermal Control> on cpu6
est7: <Enhanced SpeedStep Frequency Control> on cpu7
p4tcc7: <CPU Frequency Thermal Control> on cpu7
est8: <Enhanced SpeedStep Frequency Control> on cpu8
p4tcc8: <CPU Frequency Thermal Control> on cpu8
est9: <Enhanced SpeedStep Frequency Control> on cpu9
p4tcc9: <CPU Frequency Thermal Control> on cpu9
est10: <Enhanced SpeedStep Frequency Control> on cpu10
p4tcc10: <CPU Frequency Thermal Control> on cpu10
est11: <Enhanced SpeedStep Frequency Control> on cpu11
p4tcc11: <CPU Frequency Thermal Control> on cpu11
est12: <Enhanced SpeedStep Frequency Control> on cpu12
p4tcc12: <CPU Frequency Thermal Control> on cpu12
est13: <Enhanced SpeedStep Frequency Control> on cpu13
p4tcc13: <CPU Frequency Thermal Control> on cpu13
est14: <Enhanced SpeedStep Frequency Control> on cpu14
p4tcc14: <CPU Frequency Thermal Control> on cpu14
est15: <Enhanced SpeedStep Frequency Control> on cpu15
p4tcc15: <CPU Frequency Thermal Control> on cpu15
Timecounters tick every 1.000 msec
ipfw2 (+ipv6) initialized, divert enabled, nat loadable, rule-based forwarding enabled, default to deny, logging disabled
load_dn_sched dn_sched FIFO loaded
load_dn_sched dn_sched PRIO loaded
load_dn_sched dn_sched QFQ loaded
load_dn_sched dn_sched RR loaded
load_dn_sched dn_sched WF2Q+ loaded
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 480Mbps High Speed USB v2.0
usbus3: 12Mbps Full Speed USB v1.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 12Mbps Full Speed USB v1.0
usbus6: 12Mbps Full Speed USB v1.0
usbus7: 480Mbps High Speed USB v2.0
ad4: 476940MB <Seagate ST95005620AS SD23> at ata2-master UDMA100 SATA 3Gb/s
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus3
ugen4.1: <Intel> at usbus4
uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
ugen5.1: <Intel> at usbus5
uhub5: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus5
ugen6.1: <Intel> at usbus6
uhub6: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus6
ugen7.1: <Intel> at usbus7
uhub7: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus7
ad6: 476940MB <Seagate ST95005620AS SD23> at ata3-master UDMA100 SATA 3Gb/s
ar0: writing of DDF metadata is NOT supported yet
ar0: 475883MB <DDF RAID1> status: READY
ar0: disk0 READY (master) using ad4 at ata2-master
ar0: disk1 READY (mirror) using ad6 at ata3-master
lapic1: Forcing LINT1 to edge trigger
SMP: AP CPU #1 Launched!
lapic51: Forcing LINT1 to edge trigger
SMP: AP CPU #13 Launched!
lapic2: Forcing LINT1 to edge trigger
SMP: AP CPU #2 Launched!
lapic33: Forcing LINT1 to edge trigger
SMP: AP CPU #9 Launched!
lapic20: Forcing LINT1 to edge trigger
SMP: AP CPU #6 Launched!
lapic35: Forcing LINT1 to edge trigger
SMP: AP CPU #11 Launched!
lapic19: Forcing LINT1 to edge trigger
SMP: AP CPU #5 Launched!
lapic53: Forcing LINT1 to edge trigger
SMP: AP CPU #15 Launched!
lapic18: Forcing LINT1 to edge trigger
SMP: AP CPU #4 Launched!
lapic52: Forcing LINT1 to edge trigger
SMP: AP CPU #14 Launched!
lapic21: Forcing LINT1 to edge trigger
SMP: AP CPU #7 Launched!
lapic32: Forcing LINT1 to edge trigger
SMP: AP CPU #8 Launched!
lapic3: Forcing LINT1 to edge trigger
SMP: AP CPU #3 Launched!
lapic50: Forcing LINT1 to edge trigger
SMP: AP CPU #12 Launched!
lapic34: Forcing LINT1 to edge trigger
SMP: AP CPU #10 Launched!
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub3: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
uhub5: 2 ports with 2 removable, self powered
uhub6: 2 ports with 2 removable, self powered
GEOM: ad4s1: geometry does not match label (255h,63s != 16h,63s).
GEOM: ad6s1: geometry does not match label (255h,63s != 16h,63s).
Root mount waiting for: usbus7 usbus2
uhub2: 4 ports with 4 removable, self powered
Root mount waiting for: usbus7
uhub7: 8 ports with 8 removable, self powered
Root mount waiting for: usbus7
Trying to mount root from ufs:/dev/ar0s1a
ugen3.2: <vendor 0x3333> at usbus3
ukbd0: <vendor 0x3333 product 0x3333, class 0/0, rev 1.10/0.01, addr 2> on usbus3
kbd2 at ukbd0
ums0: <vendor 0x3333 product 0x3333, class 0/0, rev 1.10/0.01, addr 2> on usbus3
ums0: 5 buttons and [XYZ] coordinates ID=0
em1: link state changed to UP
Вроде как завелось, ну и ладно.. Ставится туда билинг, встает ровно,работает. Завершающий этап-направляем туда пользователей. Скажем, 250 активных,в основном безлимитчиков. Работает сутки машина, виснет. Консоль не отвечает,не пингуется ни один интерфейс. В логах последнее что вижу:

Код: Выделить всё

kernel: ng_mppc_decompress: too many (4094) packets dropped, disabling node 0xc9965980!
Дело привычное,не страшно,на прошлом железе такого много было,работать не мешало с шифрованием на mpd5. Ни корки, ни что либо в других логах нет.
Ребутаю, сервак работает несколько часов,падает. Убираю шифрование в mpd5, не помогает. Чем выше количество пользователей онлайн, там быстрее виснет машина. В пиковые моменты доходило до 10 минут работы и вис. В момент пиковой нагрузки было 95% idle, что конечно не могло не порадовать, ибо на старом железе его было 0-5%. Физически с дисками все в порядке. Есть подозрение на ar0 и есть еще бОльшие сомнения в дровах на сетевые карты.

Код: Выделить всё

em0@pci0:8:0:0: class=0x020000 card=0xa01f8086 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Intel 82574L Gigabit Ethernet Controller (82574L)'
    class      = network
    subclass   = ethernet
em1@pci0:3:0:0: class=0x020000 card=0x83691043 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Intel 82574L Gigabit Ethernet Controller (82574L)'
    class      = network
    subclass   = ethernet
em2@pci0:2:0:0: class=0x020000 card=0x83691043 chip=0x10d38086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Intel 82574L Gigabit Ethernet Controller (82574L)'
    class      = network
    subclass   = ethernet
Первая попытка пересадить пользователей на новое железо не увенчался успехом, срочно пришлось откатиться на старое,чтобы не потерять клиентов. В итоге имеем новое железо, работающее в холостую up 13:34 без ошибок. Почитал,что люди пишут. Меняют дрова на от яндекса, чтобы распределить нагрузку и поиграть с очередью. Но схожей ситуации с моей с интелевыми дровами я не увидел. Кто сталкивался с похожим?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-27 10:49:10

diskinfo -tv /dev/ar0

Код: Выделить всё

/dev/ar0
        512             # sectorsize
        498999492608    # mediasize in bytes (465G)
        974608384       # mediasize in sectors
        0               # stripesize
        0               # stripeoffset
        60666           # Cylinders according to firmware.
        255             # Heads according to firmware.
        63              # Sectors according to firmware.
                        # Disk ident.

Seek times:
        Full stroke:      250 iter in   2.057594 sec =    8.230 msec
        Half stroke:      250 iter in   2.609851 sec =   10.439 msec
        Quarter stroke:   500 iter in   1.822101 sec =    3.644 msec
        Short forward:    400 iter in   1.448515 sec =    3.621 msec
        Short backward:   400 iter in   2.830190 sec =    7.075 msec
        Seq outer:       2048 iter in   0.305859 sec =    0.149 msec
        Seq inner:       2048 iter in   0.299332 sec =    0.146 msec
Transfer rates:
        outside:       102400 kbytes in   1.045036 sec =    97987 kbytes/sec
        middle:        102400 kbytes in   1.306997 sec =    78348 kbytes/sec
        inside:        102400 kbytes in   1.974649 sec =    51857 kbytes/sec



Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-27 11:58:27

попробуй убрать HT
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-27 12:55:04

HT это что?

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-27 13:30:28

hyper threading
или ты хочешь сказать что у тебя реально 16 ядер ?
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-27 13:42:42

каждый камень 4 ядра 8 потоков. Попробую

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35332
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение Alex Keda » 2011-01-27 19:07:18

asus серверов не производит
когад вы уже все это поймёте...
Убей их всех! Бог потом рассортирует...

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-28 7:45:28

отчего же _http://www.apitcomp.ru/shop/server_asus_rs700d_e6_ps8_381282/
я например под десктопы очень люблю материнки асус
даже директору на AMD Phenom x6 + mb asus собрал
Но это десктопы.
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35332
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение Alex Keda » 2011-01-28 9:02:54

Alex Keda писал(а):asus серверов не производит
когад вы уже все это поймёте...
Убей их всех! Бог потом рассортирует...

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-28 9:16:02

asus производит сервера. Прямыми поставками в Россию не занимается. Продают в России дистрибьюторы.
_http://ru.asus.com/ProductGroup3.aspx?PG_ID=xrOlpXWE87x7bSBN
_http://ru.asus.com/websites/global/aboutasus/certificate/ISO14001.pdf
8 800 100-2787 Асус Россия

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35332
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение Alex Keda » 2011-01-28 9:36:53

Alex Keda писал(а):
Alex Keda писал(а):asus серверов не производит
когад вы уже все это поймёте...
Убей их всех! Бог потом рассортирует...

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-28 9:54:01

ну алексей как бы намекает что асус не вписывается в нишу серверов
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-28 10:03:21

отключение HT и дрова от яндекса не помогли

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-28 10:14:31

в России тоже не выпускает автомобили. Но от этого полстраны не перестают на них ездить. Давайте будем называть вещи своими именами, есть железо,сделал асус, статус-сервер. Есть проблема, надо решить, поэтому пишу в размышлениях

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-28 11:53:12

обновляйся до 8.1-pX и используй GENERIC ядро, тогда будем делать выводы
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-28 14:34:58

круг сузился до mpd-5.5. Последние разы зависал именно он, не убивался, пинги шли. Система продолжала работать

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-28 15:13:23

кури нетграф
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-28 16:51:02

пересобираем ядро без инфраструктуры для кэширования потоков FLOWTABLE. И полетели

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35332
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение Alex Keda » 2011-01-28 18:12:05

Alex Keda писал(а):
Alex Keda писал(а):
Alex Keda писал(а):asus серверов не производит
когад вы уже все это поймёте...
Убей их всех! Бог потом рассортирует...

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-31 14:24:15

Проблема имеет продолжение. Сутки с лишим аптайм, fatal trap 12- отвалился один из дисков говнорейда, вывесив сервак в мертвое состояние.
В биосе рейда разрушение массива, отсутствует один диск на канале. Назревает логичный вопрос-так всегда бывает с говнорейдами,когда они разваливаются и вешают железо?
IMAG1.GIF

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-31 14:27:11

собери gmirror и не парься
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-31 14:29:35

это-то понятно. Вопрос, что это было, контроллер или диск

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-01-31 14:30:37

контроллер.
диск бы выпал из массива и всё, а тут ar0 вылетел
я такой яростный шо аж пиздеЦ
Изображение

mymymy
сержант
Сообщения: 224
Зарегистрирован: 2008-05-16 21:23:38
Откуда: Москва

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение mymymy » 2011-01-31 14:36:46

ну тут отвалился один канал просто. Рейд работает после перезагрузки на одном винте. Странная реакция фряхи на этот. Я бы тоже сказал - однозначно контроллер. Причем есть подозрение что он и убил один диск. Думаю в течение суток еще раз свалится. Да и с предыдущими зависаниями,чует моя- та же самая проблема,просто на консоль не успевало ничего свалится и статус биос-рейда был онлайн

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: FreeBSD 8.1 amd64 виснет

Непрочитанное сообщение manefesto » 2011-02-01 12:30:12

Alex Keda писал(а):
Alex Keda писал(а):
Alex Keda писал(а):
Alex Keda писал(а):asus серверов не производит
когад вы уже все это поймёте...
я такой яростный шо аж пиздеЦ
Изображение