Анонс сети в двух датацентрах

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Гость
проходил мимо

Анонс сети в двух датацентрах

Непрочитанное сообщение Гость » 2014-02-07 15:37:27

Здравствуйте,
Прошу помочь в решении такой задачи, необходимо проанонсировать одну подсеть одновременно в двух датацентрах, как я понимаю в этом случае используется IBGP

Сейчас в каждом датацентре анансируется своя подсеть из AS11111, необходимо проанонсировать в первом датацентре подсеть из второго.
DC1: 20.0.0.1 - gw вышестоящего провайдера (AS44444), 20.0.0.2/eth0 внешний ip, 100.0.1.0/23 анонсируется (AS11111):

Код: Выделить всё

!
router bgp 11111
 bgp router-id 20.0.0.2
 bgp log-neighbor-changes
 network 100.0.1.0/23
 neighbor 20.0.0.1 remote-as 44444
 neighbor 20.0.0.1 description ISP-1
 neighbor 20.0.0.1 next-hop-self
 neighbor 20.0.0.1 soft-reconfiguration inbound
 neighbor 20.0.0.1  route-map ISP-1-IN in
 neighbor 20.0.0.1 route-map ISP-1-OUT out
!
ip route 10.0.0.0/8 Null0 254
ip route 172.16.0.0/12 Null0 254
ip route 192.168.0.0/16 Null0 254
ip route 100.0.1.0/23 Null0 254
!
ip prefix-list default description default route
ip prefix-list default seq 10 permit 0.0.0.0/0
ip prefix-list bogusnets description bogus networks
ip prefix-list bogusnets seq 15 permit 127.0.0.0/8 le 32
ip prefix-list bogusnets seq 20 permit 10.0.0.0/8 le 32
ip prefix-list bogusnets seq 25 permit 172.16.0.0/12 le 32
ip prefix-list bogusnets seq 30 permit 192.168.0.0/16 le 32
ip prefix-list bogusnets seq 35 permit 169.254.0.0/16 le 32
ip prefix-list bogusnets seq 40 permit 224.0.0.0/4 le 32
ip prefix-list bogusnets seq 45 permit 240.0.0.0/4 le 32
ip prefix-list our-block-up seq 10 permit 100.0.1.0/23
!
ip as-path access-list 1 permit _6451[2-9]_
ip as-path access-list 1 permit _645[2-9][0-9]_
ip as-path access-list 1 permit _64[6-9][0-9][0-9]_
ip as-path access-list 1 permit _65[0-9][0-9][0-9]_
!
route-map ISP-1-OUT permit 100
 match ip address prefix-list our-block-up
 set metric 10
!
route-map ISP-1-OUT deny 200
!
route-map ISP-1-IN deny 100
 match as-path 1
!
route-map ISP-1-IN deny 110
 match ip address prefix-list bogusnets
!
route-map ISP-1-IN deny 120
 match ip address prefix-list our-block-up
!
route-map ISP-1-IN permit 200
!
ip forwarding
ipv6 forwarding
!
line vty
 exec-timeout 0 0
!
end
DC2: 30.0.0.1 - gw вышестоящего провайдера (AS55555), 30.0.0.2/eth0 внешний ip, 100.0.3.0/23 анонсируется (AS11111):

Код: Выделить всё

!
log syslog
log facility local7
!
debug ospf6 lsa unknown
!
interface eth0
 ipv6 nd suppress-ra
 link-detect
!
interface eth1
 ipv6 nd suppress-ra
 link-detect
!
interface lo
!
router bgp 11111
 bgp router-id 100.0.3.1
 bgp network import-check
 network 100.0.3.0/23
 neighbor 30.0.0.1 remote-as 55555
 neighbor 30.0.0.1 update-source eth0
 neighbor 30.0.0.1 route-map eBGP-IMPORT in
!
ip route 0.0.0.0/0 30.0.0.1
!
ip prefix-list RFC1918PREFIXES seq 10 permit 10.0.0.0/8 le 32
ip prefix-list RFC1918PREFIXES seq 20 permit 172.16.0.0/12 le 32
ip prefix-list RFC1918PREFIXES seq 30 permit 192.168.0.0/16 le 32
!
route-map eBGP-IMPORT deny 10
 match ip address prefix-list RFC1918PREFIXES
!
route-map eBGP-IMPORT permit 20
!
ip forwarding
ipv6 forwarding
!
line vty
!
end

Добавляем в DC1:
network 100.0.3.0/23
neighbor 30.0.0.2 remote-as 11111
ip prefix-list our-block-up seq 20 permit 100.0.3.0/23

В DC2:
neighbor 20.0.0.2 remote-as 11111

И весь траффик сразу уходит в DC1

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: Анонс сети в двух датацентрах

Непрочитанное сообщение lap » 2014-02-07 19:00:15

Исходящий или какой? вы от обоих пиров что получаете?
Не сломалось - не чини.