FreeBSD 8.1+WIiFi+WPA невыдача IP

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
overl0rd
проходил мимо
Сообщения: 3
Зарегистрирован: 2010-01-23 10:14:21
Контактная информация:

FreeBSD 8.1+WIiFi+WPA невыдача IP

Непрочитанное сообщение overl0rd » 2011-02-13 17:22:02

Доброго времени суток.

Сабжевая проблема, есть ось

Код: Выделить всё

# uname -a
FreeBSD deffkopta 8.1-RELEASE FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:55:53 UTC 2010     root@almeida.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386
Есть настроеный rc.conf:

Код: Выделить всё

wlans_ath0="wlan0"
ifconfig_wlan0="DHCP WPA"
Есть wpa_suppliciant.conf вида:

Код: Выделить всё

network={
        ssid="bazuha"
        #psk="securenetw0rkkey"
        psk=a7f470aeb6248d73e6fdfe710bb13518ef7a053a83535b3af37de35de9e80e6a
}
При старте система выдает:

Код: Выделить всё

ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
Starting Network: wlan0.
Ifconfig выдает:

Код: Выделить всё

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 20:cf:30:2d:13:d9
        media: Ethernet autoselect (none)
        status: no carrier
ath0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 74:f0:6d:8f:a4:af
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
        inet6 ::1 prefixlen 128 
        inet 127.0.0.1 netmask 0xff000000 
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 74:f0:6d:8f:a4:af
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        ssid "" channel 11 (2462 MHz 11g)
        regdomain 33411 country RU indoor ecm authmode OPEN privacy OFF
        txpower 20 bmiss 7 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
        roam:rssi 7 roam:rate 5 protmode CTS wme burst bintval 0
После ввода команды

Код: Выделить всё

wpa_supplicant -i wlan0 -c /etc/wpa_suppliciant.conf -D bsd
Вывод ifconfig выглядит так:

Код: Выделить всё

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 20:cf:30:2d:13:d9
        media: Ethernet autoselect (none)
        status: no carrier
ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 74:f0:6d:8f:a4:af
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
        status: associated
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
        inet6 ::1 prefixlen 128 
        inet 127.0.0.1 netmask 0xff000000 
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 74:f0:6d:8f:a4:af
        inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
        media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11g
        status: associated
        ssid bazuha channel 11 (2462 MHz 11g) bssid f0:7d:68:42:8c:de
        regdomain 33411 country RU indoor ecm authmode WPA2/802.11i
        privacy ON deftxkey UNDEF AES-CCM 2:128-bit txpower 20 bmiss 7
        scanvalid 450 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi 7
        roam:rate 5 protmode CTS wme burst roaming MANUAL
То есть к сети он подключается но адрес так и не получает.
На стороне роутера переиодически появляются сообщения о выдаче IP на мак принадлежащий wlan0.
Роутер D-Link DIR-300nru, если это вдруг важно.

Как все-таки заставить ноут получать IP, да еще автоматически, чтоб не вводить лишний раз ничего?

Гугление мое результата не дало, увы и ах и пепел на мою плешь :)

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

snorlov
подполковник
Сообщения: 3881
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 8.1+WIiFi+WPA невыдача IP

Непрочитанное сообщение snorlov » 2011-02-13 18:19:58

overl0rd писал(а): При старте система выдает:

Код: Выделить всё

ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
Starting Network: wlan0.
Может начать надо с того, что демон не может автоматом подцепить /etc/wpa_supplicant.conf..., права на него какие вы дали


overl0rd
проходил мимо
Сообщения: 3
Зарегистрирован: 2010-01-23 10:14:21
Контактная информация:

Re: FreeBSD 8.1+WIiFi+WPA невыдача IP

Непрочитанное сообщение overl0rd » 2011-02-13 18:52:32

snorlov писал(а):
overl0rd писал(а): При старте система выдает:

Код: Выделить всё

ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
ifconfig: create: bad value
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
/etc/rc.d/wpa_supplicant: WARNING: /etc/wpa_supplicant.conf is not readable.
/etc/rc.d/wpa_supplicant: WARNING: failed precmd routine for wpa_supplicant
Starting Network: wlan0.
Может начать надо с того, что демон не может автоматом подцепить /etc/wpa_supplicant.conf..., права на него какие вы дали
Права дефолтные 644.
olo писал(а): /etc/wpa_supplicant.conf is not readable.
/etc/wpa_suppliciant.conf
Маленькая опечатка :) Спсасибо, этот момент я поправил.
Теперь интерфейс поднимается автоматически. Но так и не получает адреса.

snorlov
подполковник
Сообщения: 3881
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 8.1+WIiFi+WPA невыдача IP

Непрочитанное сообщение snorlov » 2011-02-14 10:09:31

Внимательнее посмотрите wpa_supplicant.conf, установите там опции логирования, может что нибудь и вытащите, управлять supplicant'ом можно через wpa_cli...

overl0rd
проходил мимо
Сообщения: 3
Зарегистрирован: 2010-01-23 10:14:21
Контактная информация:

Re: FreeBSD 8.1+WIiFi+WPA невыдача IP

Непрочитанное сообщение overl0rd » 2012-04-04 12:35:45

Немного гробокопства :)

Как выяснилось, драйвер на вайфайные карты с этим ядром был попросту бажный. Баг как я помню в 8.2 версии тоже не был исправлен, но в 9.0 уже все работает нормально :)

Чисто случайно, год спустя вспомнил про этот топик :)