OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
vinyl777
проходил мимо
Сообщения: 2
Зарегистрирован: 2020-05-07 20:46:28

OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Непрочитанное сообщение vinyl777 » 2020-05-07 20:54:26

Здравствуйте.

Прошу помощи в настройке одной небольшой фичи. Есть роутер D-Link DIR-320 B1 на прошивке OpenWrt 19.07.2. Интернет приходит с другого Wi-fi роутера. Проблема в том, что когда отключается раздающая интернет Wi-fi сеть, следом за ней пропадает и сеть, поднятая на OpenWrt, а мне нужно, чтобы эта сеть работала даже без интернета (просто как локалка).

Написал на linux.org.ru, но там за два дня один просмотр и тишина. Может, здесь есть спецы по OpenWRT)

Спасибо!

/etc/conig/network на всякий случай:

Код: Выделить всё

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdee:200a:97f0::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.0.1'
	option ifname 'eth0 eth0.1'
	option gateway '192.168.0.1'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd6:bf:7f:69:30:ca'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd6:bf:7f:69:30:cb'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config interface 'wwan'
	option proto 'dhcp'

config interface 'yotaToAir'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'
	option force_link '1'

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35253
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Непрочитанное сообщение Alex Keda » 2020-05-21 12:46:49

поясните - что значит
vinyl777 писал(а):
2020-05-07 20:54:26
следом за ней пропадает и сеть, поднятая на OpenWrt
там какая-то отдельная сеть? пропадает что именно - даже устройства не пингуются, воткнутые в порты LAN между собой?
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35253
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Непрочитанное сообщение Alex Keda » 2020-05-21 12:47:56

vinyl777 писал(а):
2020-05-07 20:54:26
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '10.0.0.1'
option ifname 'eth0 eth0.1'
option gateway '192.168.0.1'
а чё шллюз не в сети?
Убей их всех! Бог потом рассортирует...

vinyl777
проходил мимо
Сообщения: 2
Зарегистрирован: 2020-05-07 20:46:28

OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Непрочитанное сообщение vinyl777 » 2020-05-21 13:02:46

Alex Keda писал(а):
2020-05-21 12:46:49
там какая-то отдельная сеть
Wi-fi сеть. Сори,что не указал. Примерная схема работы.

Alex Keda писал(а):
2020-05-21 12:47:56
а чё шллюз не в сети?
Мне нужно, чтобы он был не в той же сети. Но интернет работает, подозреваю, потому что стоит relayd.

Мне здесь подсказали одно решение, но всё никак до него не доберусь.

Спасибо!

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35253
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

OpenWrt, локальная сеть без интернета (в т.ч. Wi-fi)

Непрочитанное сообщение Alex Keda » 2020-05-21 13:13:02

ну согласен, да, интерфейс кладётся
Убей их всех! Бог потом рассортирует...