OSPF или BGP и два канала

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 8:26:17

Надыбал в инете что можно спокойно и просто для резервирования и балансировки исрользовать протоколы динамической маршрутизации OSPF или BGP. Знаю что на FreeBSD нада будет ставить пакет zebra настроить ospf, зону и т.д.... Вопрос такой, что требуется от провайдера сделать чтоб это всё зароботало?????

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/


_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 9:42:26

abanamat писал(а):договор.
а кроме договора??? какие настройки OSPF они должны внести???

Аватара пользователя
abanamat
сержант
Сообщения: 255
Зарегистрирован: 2007-03-15 11:24:26
Откуда: Питер
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение abanamat » 2007-07-20 11:21:55

так об этом с админом провайдера лучше поговорить

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 12:51:25

Пакет ставить надо не zebra, а quagga так как зебра - это заглохший проект, всякие вкусняшки и обновления есть только для квагги, хотя разработчик тот же самый Kunihiro Ishiguro. Плюс в quagga есть штатный watcher который поднимает демонов когда они начинают тупить.

В случае с ospf - можно провайдера не трогать, только я плохо представляю себе реализацию этого хозяйства на одном роутере.

Для BGP - нужен номер AS получить на блок IP адресов, естественно потребуется реальные, а не приватные.
настройка BGP, правда под лялих
http://www.netup.ru/BGP_Cisco_Gentoo_Linux_Quagga.php

лично я протокол BGP не окучивал, по ospf могу подсказать, или статью написать в свободное время, благо отпуск на две недели.
не спеши, а то успеешь.

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: OSPF или BGP и два канала

Непрочитанное сообщение hizel » 2007-07-20 13:13:54

чтобы таких вопросов не возникало советую скачать\купить и курнуть книжку
Принципы маршрутизации в Internet (2-е издание) Хелеби, Мак-Ферсон
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 13:16:29

или взять два корыта и поэкспериментировать, предварительно раскурив rfc :)
не спеши, а то успеешь.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35056
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение Alex Keda » 2007-07-20 13:17:24

rfc тяжело раскуриваются...
залежались :)
Убей их всех! Бог потом рассортирует...

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 13:25:22

npu3pak писал(а):Пакет ставить надо не zebra, а quagga так как зебра - это заглохший проект, всякие вкусняшки и обновления есть только для квагги, хотя разработчик тот же самый Kunihiro Ishiguro. Плюс в quagga есть штатный watcher который поднимает демонов когда они начинают тупить.

В случае с ospf - можно провайдера не трогать, только я плохо представляю себе реализацию этого хозяйства на одном роутере.

Для BGP - нужен номер AS получить на блок IP адресов, естественно потребуется реальные, а не приватные.
настройка BGP, правда под лялих
http://www.netup.ru/BGP_Cisco_Gentoo_Linux_Quagga.php

лично я протокол BGP не окучивал, по ospf могу подсказать, или статью написать в свободное время, благо отпуск на две недели.
значит если я понял правильно нужно 2 роутера, с поднятым OSPF???
например если у меня есть один:
LAN: 192.168.1.1 INET: 83.xx.xx.xx
и ещё один:
LAN: 192.168.1.2 INET:84.xx.xx.xx
то можно как та через DR и BDR настроить автоматическое переключение каналов или балансировку, если у юзеров стоит по дефолту 192.168.1.1???

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 13:47:05

кхм...

у меня когда то было так -
два роутера смотрящие каждый на своего прова, один роутер под клиентов. На всех трёх была поднята квагга. На тех что смотрели на провайдера был прописан default route на прова, на клиентском defaultroute="NO". Все они находились в одной служебной сетке 10.0.0.0/29, тоесть что-то типа такого

head1
lan 10.0.0.1/29
inet 83.0.0.0
defaultrouter=''83.0.0.*'

head2
lan 10.0.0.2/29
inet 84.0.0.0
defaultrouter="84.0.0.*"

foot
lan1 10.0.0.3/29
lan2 192.168.0.0/16

это я про ospf, т.к. BGP на практике не применял
не спеши, а то успеешь.

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 13:50:50

npu3pak писал(а):кхм...

у меня когда то было так -
два роутера смотрящие каждый на своего прова, один роутер под клиентов. На всех трёх была поднята квагга. На тех что смотрели на провайдера был прописан default route на прова, на клиентском defaultroute="NO". Все они находились в одной служебной сетке 10.0.0.0/29, тоесть что-то типа такого

head1
lan 10.0.0.1/29
inet 83.0.0.0
defaultrouter=''83.0.0.*'

head2
lan 10.0.0.2/29
inet 84.0.0.0
defaultrouter="84.0.0.*"

foot
lan1 10.0.0.3/29
lan2 192.168.0.0/16

это я про ospf, т.к. BGP на практике не применял
отлично, пойду клянчить железо у шефа :)

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 13:53:17

кстати только что настроил балансировку каналов на 2-х СПД, средствами OSPF, классна работает :). Если кто хочет могу выложить конфиги :)

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35056
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение Alex Keda » 2007-07-20 14:04:09

естессно. выкладывай.
Убей их всех! Бог потом рассортирует...

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 14:14:32

моя сетка имеет вот такоу вид:

Код: Выделить всё

router1:
lan: 192.168.1.1
spd1, inet: 83.xx.xx.xx, VPN 192.168.1.1 > 192.168.0.1
spd2:10.xx.xx.xx, VPN:192.168.10.1 > 192.168.10.2

Код: Выделить всё

router2:
lan: 192.168.0.1
spd1, inet: 194.xx.xx.xx, VPN 192.168.0.1 > 192.168.1.1
spd2:10.xx.xx.xx, VPN 192.168.10.2 > 192.168.10.1

Код: Выделить всё

router1 zebra.conf:
!
! Zebra configuration saved from vty
!   2007/07/20 14:37:21
!
hostname router1
password pass
enable password pass
log stdout
log syslog
!
interface gif0
!
interface gif1
!
interface gif2
!
interface lo0
!
interface re0
!
interface rl0
!
interface rl1
!
interface rl2
!
interface tun0
!
ip route 0.0.0.0/0 83.xx.xx.254
!
ip forwarding
!
line vty

Код: Выделить всё

router1 ospfd.conf:
!
! Zebra configuration saved from vty
!   2007/07/20 14:21:43
!
hostname ospfrouter
password pass
enable password pass
!
!
!
interface gif0
!
interface gif1
!
!
interface gif2
!
interface lo0
!
interface plip0
!
interface rl1
!
interface rl2
!
router ospf
 network 192.168.0.0/24 area 0.0.0.0
 network 192.168.1.0/24 area 0.0.0.0
 network 192.168.10.0/24 area 1
 neighbor 192.168.0.1
 neighbor 192.168.10.2
!
line vty
!

Код: Выделить всё

router2 zebra.conf:

! Zebra configuration saved from vty
!   2007/03/31 11:11:48
!
hostname router2
password pass
enable password pass
log stdout
log syslog
!
interface gif0
!
interface gif1
!
interface ipln0
!
interface lo0
!
interface plip0
!
interface ppp0
!
interface rl0
!
interface rl1
!
interface rl2
!
ip route 0.0.0.0/0 194.xx.xx.254
ip route 10.xx.xx.0/24 10.xx.xx.1
!
ip forwarding
!
line vty
log file /var/log/zebra/zebra.log
!

Код: Выделить всё



router2 ospfd.conf:
!
! Zebra configuration saved from vty
!   2007/07/20 14:21:43
!
hostname router2
password pass
enable password pass
!
!
!
interface gif0
!
interface gif1
!
interface ipln0
!
interface lo0
!
interface plip0
!
interface rl0
!
interface rl1
!
interface rl2
!
router ospf
 network 192.168.0.0/24 area 0.0.0.0
 network 192.168.1.0/24 area 0.0.0.0
 network 192.168.10.0/24 area 1
 neighbor 192.168.1.1
 neighbor 192.168.10.1
!
line vty
!
Последний раз редактировалось _kirill_ 2007-07-20 14:24:12, всего редактировалось 1 раз.

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 14:23:30

а что так жестко соседей ospf указал? они вроде автоматом подсасываются через OSPF-HELLO
или это изза vpn?

еще
redistribute connected
redistribute static

помоему это лучше чем руками указывать маршруты к сетям :)
Последний раз редактировалось npu3pak 2007-07-20 14:28:13, всего редактировалось 1 раз.
не спеши, а то успеешь.

_kirill_
ст. сержант
Сообщения: 311
Зарегистрирован: 2007-05-11 9:41:21
Откуда: Tashkent
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение _kirill_ » 2007-07-20 14:25:33

npu3pak писал(а):а что так жестко соседей ospf указал? они вроде автоматом подсасываются через OSPF-HELLO
ага, на всякий случай :). ты думаешь лучше убрать???

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35056
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: OSPF или BGP и два канала

Непрочитанное сообщение Alex Keda » 2007-07-20 14:26:07

юзайте кнопочку code :)
я не могу все посты за всех править :)
Убей их всех! Бог потом рассортирует...

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 14:35:51

ага, на всякий случай :). ты думаешь лучше убрать???
оставь, пока работает :) помню были какие-то грабли с работой ospf через vpn-туннели, надо смотреть документацию, сейчас уже не вспомню, настраивал давно.

кстати можно указать руками стоимость маршрута через интерфейс

Код: Выделить всё

!
interface rl0
ip ospf cost N
!
interface rl1
ip ospf cost 2N
!
если до хоста есть два альтернативных маршрута то 2N траффика пойдет через rl0, а N траффика через rl1
сам оспф на автомате рассчитывает стоимость через пропускную способность интерфейса.

Пишу по памяти, так что могу приврать :)
не спеши, а то успеешь.

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-07-20 14:37:54

кстати оспф использует алгоритм Дикстры для вычисления маршрута - будет интересно погугли эту тему, там траффиком можно вертеть как душе угодно
не спеши, а то успеешь.

100kg
ст. сержант
Сообщения: 393
Зарегистрирован: 2006-05-18 14:01:32

Re: OSPF или BGP и два канала

Непрочитанное сообщение 100kg » 2007-09-04 0:03:46

белман-калаба, форд-фулкерсон, эх любил я теорию графом, понимаешь что весь инет на матрицах сидит! но тут не до алгоритмов, нужно грамотно понять зачем это все, куча протоколов для маршрутизации RIP BGP OSPF EGP! :twisted: сложно! вот смотрю микротик хорошо распространен для этих дел!

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-09-04 1:39:07

эх любил я теорию графом, понимаешь что весь инет на матрицах сидит! но тут не до алгоритмов, нужно грамотно понять зачем это все,
динамическое обновление таблиц маршрутизации, балансировка нагрузки на каналы, поиск оптимального пути следования пакета.

ИМХО:
RIP - забыть как страшный сон :) (Rest In Peace, Nya =)))))
OSPF - для локальных провайдеров самое оно.
BGP {eBGP;iBGP} - если планируется пускать свозь себя чужой трафик.

Немного лирики - помню то-ли накосячили с конфигом, толи где-то свич подгаживал - трассы на Fpingere ходили красивыми петлями и зигзагами. Эхъ, уже ностальгия, непорядок.
не спеши, а то успеешь.

100kg
ст. сержант
Сообщения: 393
Зарегистрирован: 2006-05-18 14:01:32

Re: OSPF или BGP и два канала

Непрочитанное сообщение 100kg » 2007-09-04 2:12:06

RIP- rest in peace hhahahahaha

Andy
ст. лейтенант
Сообщения: 1117
Зарегистрирован: 2007-03-04 7:48:58
Откуда: Mytischi

Re: OSPF или BGP и два канала

Непрочитанное сообщение Andy » 2007-09-04 10:30:52

100kg писал(а):вот смотрю микротик хорошо распространен для этих дел!
Какая версия Mikrotik'а? ;)
Jul 16 19:37:15 freebsd sshd[4152]: Invalid user idiot from 210.75.200.104

npu3pak
мл. сержант
Сообщения: 121
Зарегистрирован: 2007-07-08 2:49:39

Re: OSPF или BGP и два канала

Непрочитанное сообщение npu3pak » 2007-09-04 14:07:46

что то мне этот MicroTikOS напоминает поделку Stonesoft Stonegate - ядро линюкса, фаер ipchains плюс виндовая администрялка к ней = коммерческий продукт с мегалицензиями. Не понравился он мне - консолька привычнее :roll:
не спеши, а то успеешь.

Andy
ст. лейтенант
Сообщения: 1117
Зарегистрирован: 2007-03-04 7:48:58
Откуда: Mytischi

Re: OSPF или BGP и два канала

Непрочитанное сообщение Andy » 2007-09-04 14:38:45

npu3pak писал(а):что то мне этот MicroTikOS напоминает поделку Stonesoft Stonegate - ядро линюкса, фаер ipchains плюс виндовая администрялка к ней = коммерческий продукт с мегалицензиями. Не понравился он мне - консолька привычнее :roll:
Там и консолька есть. Что за привычка, хаить не попробовав?
Jul 16 19:37:15 freebsd sshd[4152]: Invalid user idiot from 210.75.200.104