падает bgp сессия при отключении pppoe

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-13 22:41:55

Каким оразом можно отучить bgpd из quagga реагировать на удаление pppoe интефейсов

Код: Выделить всё

2008/06/13 19:08:53 ZEBRA: if_ioctl(SIOCGIFFLAGS) failed: Device not configured
2008/06/13 19:08:53 ZEBRA: Can't lookup mtu by ioctl(SIOCGIFMTU)
как следствеи падение bgp сесии

для ospf

Код: Выделить всё

passive-interface ng0
типа помогает

касетельно bgp пока ничего похожего не нашол
на стороне сервера у pppoe серый ip у клиета реальный

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-14 17:34:51

а нефиг bgp тулить на тунели
кто вам вообще еще AS дал
при таком канале

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:16:43

wan статический + bgp quagga
lan планирутеся pppoe

при таком раскладе, падает bgp wan при авто удалении ng интерфейса, в этом и проблема

paradox так что не суетись )) все намально ;-)

пока тест все на 1 металоломе,
планирую вынести все что касается глобального рутинга на другой желез но сейчас так и проблема такая, и адекватного решения пока нет .....

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-14 23:20:53

хм
каким это образом падает quagga если она про тот интефейс ничего незнает?? про ng0
ммм

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:23:40

я ей говорил что есть у меня ng0 но она при его удалении всеравно падает, может статически создать N ng интерфейсов и сказать ей что они есть у меня

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:26:47

на создание нового ng quagga не реагирует никак, но на удаление начинает материться, и падает bgp сесия

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-14 23:30:03

а зачем ей говорить что у вас динамический интерфейс?

можно на конфиг глянуть?

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:37:56

еще раз обяьясняю топологию,

wan - статический реальный ip
lan - реальные ip (рутинг по bgp)+ планируется pppoe

Код: Выделить всё

cat /usr/local/etc/quagga/zebra.conf
! -*- zebra -*-
interface lo0
! description test of desc.
!
interface bge0
interface em0
interface em1
interface ng0
interface ng1
! multicast
!
!
! Static default route sample.
!

ip route 0.0.0.0/0 111.111.11.111
ip route 22.22.22.0/22 0.0.0.0
!
!
log file /var/log/zebra.log
!log syslog

Код: Выделить всё

cat /usr/local/etc/quagga/bgpd.conf
!
!
router bgp 12345
network 22.22.22.0/22
neighbor 111.111.11.111 remote-as 22234
neighbor 111.111.11.111 next-hop-self
neighbor 111.111.11.111 soft-reconfiguration inbound
!passive-interface ng0
!
line vty
!

это что что сейчас работает

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:39:55

я ей как только не пытался обьяснить что ng интерфейсы дело не твое не трогай их ... ничего не вышло

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-14 23:41:35

просить что бы айпи выдавали статический
и вместо интерфейса указать айпиадресс
попробуй
непомню zabra/quagga умеет или нет

если нет
на днях загляну в соурсы как можно обойти

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-14 23:47:27

при добавлении ng девайса она походу начинает что то сним мутить, но при удалении незнает как себя всести ...
как по моему в эту сторону нужно смотреть, но я не настолько спец в С ((((

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-14 23:55:37

!passive-interface ng0
заменить на
!passive-interface 1.1.1.1

так катит?


или у вас еще и айпишник pppoe будет динамически давать?)))

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:00:58

у меня нет дтнамических ip
только mpd5 создает динамически интрфейсы при подключении

pppoe дает статичный ip из радиуса
на passive-interface в bgpd.conf зебра категорически матеится в любой вариации

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:04:44

либо надо на loopback как то закручивать
либо передописывать зебру или куагу
что бы можно было вставлять вместо имени интерфейса его айпишник

потому как ситуация когда исчезает интерфейс на который опираемся третей ногой - не есть нормальная ситуация)
в этом виноват админ с его топологией

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:14:30

не админ виноват )) что предлагаеш из дома cisco приташить и поставить для bgp )))

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:17:27

если автономка реальная и ее видно в нета
то за глюки с bgp вас запинают
(блин забыл как умное слово называеться) =)))

для реальных автономок токо циска
потому как ни зебра ни куаага
не держит (уже блин непомню) какойто обьем (какогто уровня)

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:20:17

я то поставлю отдельный металомом под рутитнг, из того что есть в наличии если ничего не решиться ....
история вроди бы и банальная, но странно что ни укого на эту тему до меня небыло воросов, я не нарыл ничего похожего разве что для ospf но для bgp тоже не работает

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:22:23

на тему запинают так и есть, но и за циску тоже прибьют сначала потом не купят )))

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:25:45

у вас реальная автономка?
скоко сеть? /22 если да то даже и незадумывайся КИСКА ОДНОЗНАЧНО

иначе пинальти запинают
а потом могут и сеть отобрать))))

токо если меньше /22 и то с напрягом можешь ставить quagga
зебру не советую)

с интерфейсом немного непонял

можно топологию что бы понять почем pppoe итд

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:36:31

всё реальное
стоит quagga сейчас
рельно рутятся 2 сети /24 ip

на тему топологии

wan - статичекский реальный ip
lan - реальные ip из моей AS

сейчас на лан средствами простого рутинга дается нет
возникла идея не просто рутить а давать ip через pppoe

всё на 1 сервере IBM

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:39:49

эт типа клинетам раздавать по pppoe реальные айпи
а квага что бы это рулила

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:40:49

так и получается

только ничего не получается :ROFL:

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:48:27

думать мне щас влом
но чего то там в понимании реализации у вас не так

вы ж клиентам по одному айпи раздаете
а не по несколько сетей

at
мл. сержант
Сообщения: 74
Зарегистрирован: 2008-06-13 0:35:22

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение at » 2008-06-15 0:50:33

по 1 Ip и в чем проблема, связи не вижу

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: падает bgp сессия при отключении pppoe

Непрочитанное сообщение paradox » 2008-06-15 0:57:27

думать щас влом :-D
я вот в другой ветке шокирован тем что циска оказываеться
вместо сеанса ppp ipcp
запускает DHCP :shock: и раздает таким макаром айпи
[цензура][цензура]