quagga удлинение маршрута

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 8:33:58

имеется freebsd 9.0-RELEASE quagga-0.99.21 пытаюсь сделать удлинение маршрута на AS34034 этот провайдер является резервным но у него маршрут в bgp короче и весь входящий трафик идет через него

Код: Выделить всё

Building configuration...

Current configuration:
!
hostname Router
log file /usr/local/etc/quagga/zebra.log
hostname bgpd
log stdout
!
debug bgp events
debug bgp keepalives
debug bgp updates
!
password zebra
enable password zebra
password poass
!
interface lo0
!
interface msk0
 ipv6 nd suppress-ra
!
interface pflog0
 ipv6 nd suppress-ra
!
interface pfsync0
 ipv6 nd suppress-ra
!
interface rl0
 ipv6 nd suppress-ra
!
interface usbus0
 ipv6 nd suppress-ra
!
interface usbus1
 ipv6 nd suppress-ra
!
interface usbus2
 ipv6 nd suppress-ra
!
interface usbus3
 ipv6 nd suppress-ra
!
interface usbus4
 ipv6 nd suppress-ra
!
interface usbus5
 ipv6 nd suppress-ra
!
interface usbus6
 ipv6 nd suppress-ra
!
interface usbus7
 ipv6 nd suppress-ra
!
interface vr0
 ipv6 nd suppress-ra
!
router bgp 2222
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 bgp deterministic-med
 network 1.1.1.1/24
 neighbor 3.3.3.3 remote-as 34034
 neighbor 3.3.3.3 description Arctel Network
 neighbor 3.3.3.3 weight 1000
 neighbor 3.3.3.3 soft-reconfiguration inbound
 neighbor 3.3.3.3 route-map map-AS34034-in in
 neighbor 3.3.3.3 route-map map-AS34034-out out
 neighbor 2.2.2.2 remote-as 42754
 neighbor 2.2.2.2 description AROMA-LESK-NET
 neighbor 2.2.2.2 weight 2000
 neighbor 2.2.2.2 soft-reconfiguration inbound
 neighbor 2.2.2.2 route-map map-AS42754-in in
 neighbor 2.2.2.2 route-map map-AS42754-out out
!
ip route 0.0.0.0/0 2.2.2.2 25
ip route 0.0.0.0/0 3.3.3.3 35
ip route 91.216.48.0/24 Null0 254
!
ip prefix-list LIST-NAME seq 5 permit 1.1.1.1/24
ip prefix-list bogons seq 20 permit 127.0.0.0/8 le 32
ip prefix-list bogons seq 25 permit 192.0.2.0/24 le 32
ip prefix-list bogons seq 30 permit 10.0.0.0/8 le 32
ip prefix-list bogons seq 35 permit 172.16.0.0/12 le 32
ip prefix-list bogons seq 40 permit 192.168.0.0/16 le 32
ip prefix-list bogons seq 45 permit 169.254.0.0/16 le 32
ip prefix-list bogons seq 50 permit 192.42.172.0/24 le 32
ip prefix-list bogons seq 55 permit 198.18.0.0/15 le 32
ip prefix-list bogons seq 60 permit 192.88.99.0/24 le 32
ip prefix-list bogons seq 65 permit 224.0.0.0/4 le 32
ip prefix-list bogons seq 70 permit 240.0.0.0/4 le 32
ip prefix-list map-AS34034-in seq 75 deny 0.0.0.0/0
ip prefix-list map-AS34034-in seq 80 permit any
ip prefix-list map-AS42754-in seq 85 deny 0.0.0.0/0
ip prefix-list map-AS42754-in seq 90 permit any
ip prefix-list map-AS42754-in seq 95 permit 0.0.0.0/0 le 19
!
ip as-path access-list 1 permit _6451[2-9]_
ip as-path access-list 1 permit _645[2-9][0-9]_
!
route-map map-AS42754-in deny 100
 description -- filter private ASs
 match as-path 1
!
route-map map-AS42754-in deny 110
 description -- -- filter bogons
 match ip address prefix-list bogons
!
route-map map-AS42754-in permit 200
 description -- permit any else, set default loc-pref, set community
 match ip address prefix-list map-AS42754-in
 set local-preference 300
!
route-map map-AS34034-out permit 100
 description -- permit our prefixes
 match ip address prefix-list LIST-NAME
 set as-path prepend 2222 2222 2222
!
route-map map-AS42754-out permit 100
 description -- permit our prefixes
 match ip address prefix-list LIST-NAME
!
route-map map-AS34034-in deny 100
 description -- filter private ASs
 match as-path 1
!
route-map map-AS34034-in deny 110
 description -- -- filter bogons
 match ip address prefix-list bogons
!
route-map map-AS34034-in permit 200
 description -- permit any else, set default loc-pref, set community
 match ip address prefix-list map-AS42754-in
 set local-preference 200
!
ip forwarding
!
line vty
!
end
show ip bgp

Код: Выделить всё

  Network          Next Hop            Metric LocPrf Weight Path
*  1.0.0.0/24        3.3.3.3                 200   1000 34034 15169 i
*>                       2.2.2.2                 300   2000 42754 15169 i
*  1.0.4.0/22        3.3.3.3                 200   1000 34034 3327 6939 7545 7545 7545 7545 7545 56203 i
*>                      2.2.2.2                 300   2000 42754 8595 8732 6939 7545 7545 7545 7545 7545 56203 i
*  1.0.16.0/23      3.3.3.3                 200   1000 34034 3327 9002 2519 i
*>                       2.2.2.2                 300   2000 42754 28968 1299 2914 2519 i
*  1.0.18.0/23      3.3.3.3                 200   1000 34034 3327 9002 2519 i
*>                       2.2.2.2               300   2000 42754 28968 1299 2914 2519 i 

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
skeletor
майор
Сообщения: 2471
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение skeletor » 2013-01-17 13:59:13

Вроде бы всё правильно выглядит. А не забыли сделать

Код: Выделить всё

clear ip bgp ...
?
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 14:21:43

побывал делать clear ip bgp
побывал перестартовать quagga
со ровно маршрут не удлиняется

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-17 15:03:01

препенды надо смотреть на внешних lg (traceroute.net.ru ) и на свой префикс (свои анонсы).
Не сломалось - не чини.

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 15:17:56

по подробней можно

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-17 15:39:38

тот аспаф который ты видишь по sh ip bgp влияет на твой исходящий трафик (это если всякие локапрефы и прочую ботву откинуть).

то что у тебя навешивается командой set as-path prepend ххх в роутмапе - оно у тебя как минимум висит на оут. тоесть через оператора 42754 ваша сеть будет видна с более длинным аспасом и также при прочих равных он будет более плохим.

как-то так.
Не сломалось - не чини.

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 15:55:37

lap писал(а):тот аспаф который ты видишь по sh ip bgp влияет на твой исходящий трафик (это если всякие локапрефы и прочую ботву откинуть).

то что у тебя навешивается командой set as-path prepend ххх в роутмапе - оно у тебя как минимум висит на оут. тоесть через оператора 42754 ваша сеть будет видна с более длинным аспасом и также при прочих равных он будет более плохим.

как-то так.
я же делал удлинение маршрута на AS34034 по чему тогда удлиняется маршрут на as42754

Код: Выделить всё

route-map map-AS34034-out permit 100
 description -- permit our prefixes
 match ip address prefix-list LIST-NAME
 set as-path prepend 2222 2222 2222

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-17 15:59:57

это я не туда посмотрел =)
и если я правильно понял кто вы есть - то я вижу вас у себя через 34034 с 4мя вашими АСками в пути.
Не сломалось - не чини.

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 16:03:38

lap писал(а):это я не туда посмотрел =)
и если я правильно понял кто вы есть - то я вижу вас у себя через 34034 с 4мя вашими АСками в пути.
вот именно а должны меня видеть по as42754 а as34034 должна быть как резервный канал

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-17 16:12:52

Опятьже - если мои догадки верны - то в объектах от 42754 нет про вас ничего. Из-за этого есть большой шанс отгрести геморрой с распространением анонсов наружу (ибо нормальные люди фильтры строят по данным во всяких radb и райпах).

Код: Выделить всё

% Information related to 'AS42754'

aut-num:        AS42754
as-name:        AROMA-LESK-AS
descr:          Iskratelecom CJSC
descr:          Seven-Sky (TM)
org:            ORG-JI4-RIPE
import:         from AS8631 action pref=100; accept ANY
export:         to AS8631 announce AS-7SKY
import:         from AS28968 action pref=100; accept ANY
export:         to AS28968 announce AS-7SKY
import:         from AS49320 action pref=100; accept AS49320
export:         to AS49320 announce ANY
import:         from AS8595  action pref=100; accept  ANY
export:         to AS8595  announce AS-7SKY
import:         from AS57782  action pref=100; accept  AS57782
export:         to AS57782 announce ANY
import:         from AS30784 action pref=300; accept AS30784
export:         to AS30784  announce AS-7SKY
admin-c:        MKSH1-RIPE
admin-c:        PRPG-RIPE
tech-c:         MKSH1-RIPE
tech-c:         PRPG-RIPE
mnt-by:         RIPE-NCC-END-MNT
mnt-by:         ISKRATELECOM-MNT
mnt-by:         MNT-AROMA-LESK
mnt-routes:     MNT-AROMA-LESK
source:         RIPE # Filtered


% Information related to 'AS-7SKY'

as-set:         AS-7SKY
descr:          Aroma Lesk Ltd.
descr:          Seven-Sky (TM)
members:        AS42754
members:        AS49320
members:        AS57782
members:        AS59663
members:        AS30784
tech-c:         MKSH1-RIPE
tech-c:         PRPG-RIPE
admin-c:        MKSH1-RIPE
admin-c:        PRPG-RIPE
mnt-by:         MNT-AROMA-LESK
source:         RIPE # Filtered
Не сломалось - не чини.

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-17 16:15:27

действительно нас нету буду звонить провайдерам по результатам отпишусь

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-21 8:21:35

провайдеры прописали роут
только со ровно анонсы идут через AS34034

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-21 12:15:53

а через этот севенскай вообще что-нибудь прилетает? я напрмер вижу у них в аплинках есть евразийа-телеком, весткал и мск-их, но ни в анонсах евразии мне, ни на lg msk-ix-а вашей сети через них нэвидать =/
Не сломалось - не чини.

svetogor82
рядовой
Сообщения: 41
Зарегистрирован: 2009-11-16 20:33:38

Re: quagga удлинение маршрута

Непрочитанное сообщение svetogor82 » 2013-01-21 12:38:06

через их сейчас настроен исходящий трафик и по статистики он идет
show ip bgp summary

Код: Выделить всё

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3          4 34034   82378     274        0    0    0 04:30:08   442822
2.2.2.2          4 42754  119873     274        0    0    0 04:30:06   455163

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: quagga удлинение маршрута

Непрочитанное сообщение lap » 2013-01-21 12:45:46

ну то что трафик у вас ушел в одну дырку, не факт что он через нее-же и вернется =) если остальной интернет вас не будет видеть через 42754, то и пакетики обратно к вам через них не вернутся (они в их сторону просто не полетят).
Не сломалось - не чини.