wlan не запускается при старте системы

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Jeque
рядовой
Сообщения: 45
Зарегистрирован: 2009-01-23 12:28:33

wlan не запускается при старте системы

Непрочитанное сообщение Jeque » 2012-03-10 19:15:13

Обновил систему с 7.3 до 9.0 и теперь имею следующую проблему.
wlan перестал подниматься при старте системы. При этом, если после загрузки сделать всё в ручную, то точка доступа поднимается и работает.
В rc.conf что только уже не писал, в том числе в точности, как в handbook:

Код: Выделить всё

wlans_ath0="wlan0"
create_args_wlan0="wlanmode hostap"
ifconfig_wlan0="inet 192.168.3.1 netmask 255.255.255.0 ssid freebsdap mode 11g channel 1"
При загрузке, интерфейс wlan0 не образуется и, соответсвенно, hostapd не стартует и пишет
bsd_init: interface wlan0 does not exist

если сразу после этого дать следующие команды:

Код: Выделить всё

ifconfig wlan0 create wlandev ath0 wlanmode hostap
ifconfig wlan0 inet 192.168.3.1/24 ssid freebsdap mode 11g channel 1
/etc/rc.d/hostapd start
то всё прекрасно работает.

Подскажите, что я делаю не так. Уже второй день бьюсь над проблемой.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Jeque
рядовой
Сообщения: 45
Зарегистрирован: 2009-01-23 12:28:33

Re: wlan не запускается при старте системы

Непрочитанное сообщение Jeque » 2012-03-11 21:58:22

Проблема решилась переустановкой системы. Видимо, обновление прошло как-то некорректно. Грешу на то, что не очень внимательно работал с mergemaster.

Кстати, а mergemaster вообще используется во время работы freebsd-update upgrade? Такое ощущение, что нет. По крайней мере конфигурационный файл mergemaster.rc оно проигнорировало и замотало меня вопросами про файлы, которые отличаются только заголовками и никогда вручную не правятся. И таких файлов сотни. Как тут не ошибиться?