Eclipse+diablo-jdk=трабл?

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Larin
лейтенант
Сообщения: 975
Зарегистрирован: 2008-01-29 20:08:41
Откуда: РБ, Минск

Eclipse+diablo-jdk=трабл?

Непрочитанное сообщение Larin » 2008-08-27 11:43:24

поставил эклипс. diablo jdk и jre

Код: Выделить всё

%pkg_info | grep diablo
diablo-jdk-1.6.0.07.02 Java Development Kit 1.6.0_07.02
diablo-jre-1.6.0.07.02 Java Runtime Environment 1.6.0_07.02
%pkg_info | grep eclipse
eclipse-3.2.2_2     An open extensible IDE for anything and nothing in particul
%uname -a
FreeBSD  7.0-STABLE FreeBSD 7.0-STABLE #1: Thu Aug 14 14:47:43 EEST 2008     larin@:/usr/src/sys/i386/compile/NEW  i386
%
но эклипс при запуске падает с ошибкой

Код: Выделить всё

JVM terminated. Exit code=1
/usr/local/bin/java
-Xms40m
-Xmx256m
-jar /usr/local/eclipse/startup.jar
-os freebsd
-ws gtk
-arch x86
-launcher /usr/local/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 30003
-vm /usr/local/bin/java
-vmargs
-Xms40m
-Xmx256m
-jar /usr/local/eclipse/startup.jar 
З.Ы. гуглил. проблема у многих встречается, но решения не нашел. может быть товарисч IZEN поможет?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1089
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Eclipse+diablo-jdk=трабл?

Непрочитанное сообщение iZEN » 2008-08-27 19:47:38

У меня:
> uname -rsm
FreeBSD 7.0-STABLE amd64
> pkg_info | grep jdk
jdk-1.6.0.3p4_3 Java Development Kit 1.6.0
> pkg_info | grep eclipse
eclipse-3.2.2_2 An open extensible IDE for anything and nothing in particul

Без проблем всё работает.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Larin
лейтенант
Сообщения: 975
Зарегистрирован: 2008-01-29 20:08:41
Откуда: РБ, Минск

Re: Eclipse+diablo-jdk=трабл?

Непрочитанное сообщение Larin » 2008-08-28 8:54:57

iZEN писал(а):У меня:
> uname -rsm
FreeBSD 7.0-STABLE amd64
> pkg_info | grep jdk
jdk-1.6.0.3p4_3 Java Development Kit 1.6.0
> pkg_info | grep eclipse
eclipse-3.2.2_2 An open extensible IDE for anything and nothing in particul

Без проблем всё работает.
ок. попробую поставить обычный jdk

Larin
лейтенант
Сообщения: 975
Зарегистрирован: 2008-01-29 20:08:41
Откуда: РБ, Минск

Re: Eclipse+diablo-jdk=трабл?

Непрочитанное сообщение Larin » 2008-08-28 17:16:42

угу. с обычным заработало нормально.
хм...странный этот diablo-jdk