FreeBSD 9.2 не обновляется софт.

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-14 19:47:36

Вечер добрый.
FreeBSD 9.2 не обновляется софт.
Обновил порты.
Смотрю.

Код: Выделить всё

# pkg_version -v | grep need
cmake-2.8.12.1_4                    <   needs updating (port has 3.0.1_1)
cmake-modules-2.8.12.1_1            <   needs updating (port has 3.0.1_1)
exim-4.83_2                         <   needs updating (port has 4.84_1)
glib-2.36.3_3                       <   needs updating (port has 2.36.3_4)
lftp-4.5.3_1                        <   needs updating (port has 4.5.4)
libffi-3.0.13_1                     <   needs updating (port has 3.0.13_2)
libiconv-1.14_3                     <   needs updating (port has 1.14_4)
libssh2-1.4.3_2,2                   <   needs updating (port has 1.4.3_4,2)
libyaml-0.1.6                       <   needs updating (port has 0.1.6_1)
mysql55-client-5.5.38               <   needs updating (port has 5.5.39)
mysql55-server-5.5.38               <   needs updating (port has 5.5.39)
nginx-1.6.0_3,2                     <   needs updating (port has 1.6.1_1,2)
oniguruma4-4.7.1                    <   needs updating (port has 4.7.1_1)
pcre-8.34_1                         <   needs updating (port has 8.35)
php5-5.4.30                         <   needs updating (port has 5.4.32)
php5-ctype-5.4.30                   <   needs updating (port has 5.4.32)
php5-dom-5.4.30                     <   needs updating (port has 5.4.32)
php5-filter-5.4.30                  <   needs updating (port has 5.4.32)
php5-hash-5.4.30                    <   needs updating (port has 5.4.32)
php5-iconv-5.4.30                   <   needs updating (port has 5.4.32)
php5-json-5.4.30                    <   needs updating (port has 5.4.32)
php5-mbstring-5.4.30                <   needs updating (port has 5.4.32)
php5-mcrypt-5.4.30                  <   needs updating (port has 5.4.32)
php5-mysql-5.4.30                   <   needs updating (port has 5.4.32)
php5-mysqli-5.4.30                  <   needs updating (port has 5.4.32)
php5-openssl-5.4.30                 <   needs updating (port has 5.4.32)
php5-pdo-5.4.30                     <   needs updating (port has 5.4.32)
php5-pdo_sqlite-5.4.30_1            <   needs updating (port has 5.4.32_1)
php5-phar-5.4.30                    <   needs updating (port has 5.4.32)
php5-posix-5.4.30                   <   needs updating (port has 5.4.32)
php5-session-5.4.30                 <   needs updating (port has 5.4.32)
php5-simplexml-5.4.30               <   needs updating (port has 5.4.32)
php5-sqlite3-5.4.30_1               <   needs updating (port has 5.4.32_1)
php5-tokenizer-5.4.30               <   needs updating (port has 5.4.32)
php5-xml-5.4.30                     <   needs updating (port has 5.4.32)
php5-xmlreader-5.4.30               <   needs updating (port has 5.4.32)
php5-xmlwriter-5.4.30               <   needs updating (port has 5.4.32)
php5-zip-5.4.30                     <   needs updating (port has 5.4.32)
php5-zlib-5.4.30                    <   needs updating (port has 5.4.32)
phpMyAdmin-4.2.6                    <   needs updating (port has 4.2.8.1)
pkgconf-0.9.6                       <   needs updating (port has 0.9.6_1)
portupgrade-2.4.12_1,2              <   needs updating (port has 2.4.12_2,2)
python27-2.7.8                      <   needs updating (port has 2.7.8_5)
ruby-1.9.3.484_2,1                  <   needs updating (port has 1.9.3.547_2,1)
ruby19-bdb-0.6.6_3                  <   needs updating (port has 0.6.6_4)
sqlite3-3.8.5_1                     <   needs updating (port has 3.8.6)
запускаю.

Код: Выделить всё

# portupgrade -arR
[Reading data from pkg(8) ... - 16 packages found - done]
Как быть?

Код: Выделить всё

# uname -rm
9.2-RELEASE-p10 amd64

Код: Выделить всё

# cat /etc/make.conf 
#WRKDIRPREFIX=		/var/ports
#DISTDIR=		/var/ports/distfiles
#PACKAGES=		/var/ports/packages
#INDEXDIR=		/var/ports
NO_WARNING_PKG_INSTALL_EOL=yes
WITHOUT_IPV6=yes
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 8:08:25

У вас судя по всему стоит мешанина из софта, поставленного старым способом без pkg и с новым pkg...

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-15 8:16:57

snorlov писал(а):У вас судя по всему стоит мешанина из софта, поставленного старым способом без pkg и с новым pkg...
Не понял.
Что за мешанина7
С тавил все из сорцов, make install clean.
Обновлял все порты через portupgrade -arR
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 8:30:41

Перейдите полностью на использование pkg (/usr/ports/ports-mgmt/pkg) и проблемы ваши исчезнут...

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-15 9:06:29

snorlov писал(а):Перейдите полностью на использование pkg (/usr/ports/ports-mgmt/pkg) и проблемы ваши исчезнут...
Решил так сделать. в make.conf указал WITH_PKGNG=yes
И пересобрал /usr/ports/ports-mgmt/pkg
после обвновляю порты. Посмотрим чем закончится.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 9:41:24

После установки pkg базу пакаджей сконвертировали?

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-15 11:03:33

snorlov писал(а):После установки pkg базу пакаджей сконвертировали?
После

Код: Выделить всё

pkgdb -fu
--->  Updating the pkgdb
[Reading data from pkg(8) ... - 89 packages found - done
После пересобрал все порты.
Смотрю.

Код: Выделить всё

# pkg_version -v | grep need
apache22-2.2.27_6                   <   needs updating (port has 2.2.29)
apr-1.5.1.1.5.3_3                   <   needs updating (port has 1.5.1.1.5.3_4)
cmake-2.8.12.1_4                    <   needs updating (port has 3.0.1_1)
cmake-modules-2.8.12.1_1            <   needs updating (port has 3.0.1_1)
exim-4.83_2                         <   needs updating (port has 4.84_1)
lftp-4.5.3_1                        <   needs updating (port has 4.5.4)
libffi-3.0.13_1                     <   needs updating (port has 3.0.13_2)
libiconv-1.14_3                     <   needs updating (port has 1.14_4)
libsigsegv-2.10                     <   needs updating (port has 2.10_1)
libyaml-0.1.6                       <   needs updating (port has 0.1.6_1)
mod_php5-5.4.30,1                   <   needs updating (port has 5.4.32,1)
mysql55-client-5.5.38               <   needs updating (port has 5.5.39)
mysql55-server-5.5.38               <   needs updating (port has 5.5.39)
nginx-1.6.0_3,2                     <   needs updating (port has 1.6.1_1,2)
oniguruma4-4.7.1                    <   needs updating (port has 4.7.1_1)
pcre-8.34_1                         <   needs updating (port has 8.35)
php5-5.4.30                         <   needs updating (port has 5.4.32)
php5-ctype-5.4.30                   <   needs updating (port has 5.4.32)
php5-dom-5.4.30                     <   needs updating (port has 5.4.32)
php5-filter-5.4.30                  <   needs updating (port has 5.4.32)
php5-gd-5.4.30                      <   needs updating (port has 5.4.32)
php5-hash-5.4.30                    <   needs updating (port has 5.4.32)
php5-iconv-5.4.30                   <   needs updating (port has 5.4.32)
php5-json-5.4.30                    <   needs updating (port has 5.4.32)
php5-mbstring-5.4.30                <   needs updating (port has 5.4.32)
php5-mcrypt-5.4.30                  <   needs updating (port has 5.4.32)
php5-mysql-5.4.30                   <   needs updating (port has 5.4.32)
php5-mysqli-5.4.30                  <   needs updating (port has 5.4.32)
php5-openssl-5.4.30                 <   needs updating (port has 5.4.32)
php5-pdo-5.4.30                     <   needs updating (port has 5.4.32)
php5-pdo_sqlite-5.4.30_1            <   needs updating (port has 5.4.32_1)
php5-phar-5.4.30                    <   needs updating (port has 5.4.32)
php5-posix-5.4.30                   <   needs updating (port has 5.4.32)
php5-session-5.4.30                 <   needs updating (port has 5.4.32)
php5-simplexml-5.4.30               <   needs updating (port has 5.4.32)
php5-sqlite3-5.4.30_1               <   needs updating (port has 5.4.32_1)
php5-tokenizer-5.4.30               <   needs updating (port has 5.4.32)
php5-xml-5.4.30                     <   needs updating (port has 5.4.32)
php5-xmlreader-5.4.30               <   needs updating (port has 5.4.32)
php5-xmlwriter-5.4.30               <   needs updating (port has 5.4.32)
php5-zlib-5.4.30                    <   needs updating (port has 5.4.32)
phpMyAdmin-4.2.6                    <   needs updating (port has 4.2.8.1)
pkgconf-0.9.6                       <   needs updating (port has 0.9.6_1)
portupgrade-2.4.12_1,2              <   needs updating (port has 2.4.12_2,2)
ruby-1.9.3.484_2,1                  <   needs updating (port has 1.9.3.547_3,1)
ruby19-bdb-0.6.6_3                  <   needs updating (port has 0.6.6_4)
sqlite3-3.8.5_1                     <   needs updating (port has 3.8.6)
t1lib-5.1.2_2,1                     <   needs updating (port has 5.1.2_4,1)

Код: Выделить всё

# php -v
PHP 5.4.32 (cli) (built: Sep 15 2014 09:53:48)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
Не понятно, почему пакеты показываются что типа не обновились, а в это ге обновились?
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 11:56:14

А вы забудьте теперь о pkg_****, наберите man pkg и пользуйтесь... в этом конкретном случае

Код: Выделить всё

pkg version 
, в каталоге /var/db/pkg можно оставить только базу, которую юзает pkg, это 2-а файла *.sqlite и 1 *.xml...

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-15 13:09:30

Хмм, а как же мне теперь отслеживать какие порты нужно обновлять.?
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 13:46:35

bagas писал(а):Хмм, а как же мне теперь отслеживать какие порты нужно обновлять.?
Практически так же, только инструмент несколько другой. С другой стороны, какая вам разница, как хранится база об установленном софте в виде текстовых файлов или базы sqlite, если вы используете утилиты, а не ручками просматриваете каталог .../pkg

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-15 14:23:22

bagas писал(а):Хмм, а как же мне теперь отслеживать какие порты нужно обновлять.?
Практически так же, только инструмент несколько другой. С другой стороны, какая вам разница, как хранится база об установленном софте в виде текстовых файлов или базы sqlite, если вы используете утилиты, а не ручками просматриваете каталог ...

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-16 20:46:55

так всетаки, как теперь отслеживать обновления софта?
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

snorlov
подполковник
Сообщения: 3810
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение snorlov » 2014-09-17 9:16:19

bagas писал(а):так всетаки, как теперь отслеживать обновления софта?

Код: Выделить всё

man pkg
pkg version  | grep "<"

Аватара пользователя
bagas
лейтенант
Сообщения: 922
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

Re: FreeBSD 9.2 не обновляется софт.

Непрочитанное сообщение bagas » 2014-09-17 9:57:31

snorlov писал(а):
bagas писал(а):так всетаки, как теперь отслеживать обновления софта?

Код: Выделить всё

man pkg
pkg version  | grep "<"
Ага спасибо.
Я так на 10-ке пользуюсь.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.