Ошибка при установке mencoder

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
cubespace
мл. сержант
Сообщения: 114
Зарегистрирован: 2010-02-25 0:23:15

Ошибка при установке mencoder

Непрочитанное сообщение cubespace » 2011-01-21 15:21:35

Здравствуйте !
При установке выдает такую ошибку :

Код: Выделить всё

glxext.c: At top level:
glxext.c:116: error: expected ')' before numeric constant
glxext.c:134: error: expected ')' before '&' token
glxext.c: In function '__glXFreeDisplayPrivate':
glxext.c:187: warning: implicit declaration of function 'FreeScreenConfigs'
glxext.c: In function '__glXInitialize':
glxext.c:653: error: 'XExtDisplayInfo' undeclared (first use in this function)
glxext.c:653: error: 'info' undeclared (first use in this function)
glxext.c:653: warning: implicit declaration of function '__glXFindDisplay'
glxext.c:677: warning: implicit declaration of function 'XextHasExtension'
glxext.c:680: warning: implicit declaration of function 'XMissingExtension'
gmake[2]: *** [glxext.o] Ошибка 1
gmake[2]: *** Ожидание завершения заданий...
gmake[2]: Leaving directory `/usr/ports/graphics/libGLU/work/Mesa-7.4.4/src/glx/x11'
gmake[1]: *** [subdirs] Ошибка 1
gmake[1]: Leaving directory `/usr/ports/graphics/libGLU/work/Mesa-7.4.4/src'
gmake: *** [default] Ошибка 1
*** Error code 1

Stop in /usr/ports/graphics/libGLU.
*** Error code 1

Stop in /usr/ports/multimedia/gpac-libgpac.
*** Error code 1

Stop in /usr/ports/multimedia/gpac-libgpac.
*** Error code 1

Stop in /usr/ports/multimedia/x264.
*** Error code 1

Stop in /usr/ports/multimedia/x264.
*** Error code 1

Stop in /usr/ports/multimedia/mencoder.
*** Error code 1

Stop in /usr/ports/multimedia/mencoder.

Пытался отдельно установить libGLU
Но тоже самое!

Код: Выделить всё

===>  Building for libGL-7.4.4
gmake[1]: Entering directory `/usr/ports/graphics/libGL/work/Mesa-7.4.4/src'
Making sources for autoconf
gmake[2]: Entering directory `/usr/ports/graphics/libGL/work/Mesa-7.4.4/src/glx/x11'
cc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa -I../../../src/mesa/glapi -I/usr/local/include -I/usr/local/include/drm   -I/usr/local/include   -D_THREAD_SAFE -I/usr/local/include   -I/usr/local/include -O2 -pipe -fno-strict-aliasing -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing  -fPIC  -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -DHAVE_POSIX_MEMALIGN -DUSE_XCB -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DHAVE_ALIAS -DGLX_INDIRECT_RENDERING -DGLX_DIRECT_RENDERING -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/local/lib/dri\" glxext.c -o glxext.o
cc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa -I../../../src/mesa/glapi -I/usr/local/include -I/usr/local/include/drm   -I/usr/local/include   -D_THREAD_SAFE -I/usr/local/include   -I/usr/local/include -O2 -pipe -fno-strict-aliasing -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing  -fPIC  -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -DHAVE_POSIX_MEMALIGN -DUSE_XCB -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DHAVE_ALIAS -DGLX_INDIRECT_RENDERING -DGLX_DIRECT_RENDERING -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/local/lib/dri\" glxextensions.c -o glxextensions.o
glxext.c:42:33: error: X11/extensions/Xext.h: No such file or directory
glxext.c:43:36: error: X11/extensions/extutil.h: No such file or directory
glxextensions.c:32:36: error: X11/extensions/extutil.h: No such file or directory
glxextensions.c:33:33: error: X11/extensions/Xext.h: No such file or directory
gmake[2]: *** [glxextensions.o] Ошибка 1
gmake[2]: *** Ожидание завершения заданий...
glxext.c:81: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
glxext.c: In function '__glXCloseDisplay':
glxext.c:110: warning: implicit declaration of function 'XextRemoveDisplay'
glxext.c:110: error: '__glXExtensionInfo' undeclared (first use in this function)
glxext.c:110: error: (Each undeclared identifier is reported only once
glxext.c:110: error: for each function it appears in.)
glxext.c: At top level:
glxext.c:116: error: expected ')' before numeric constant
glxext.c:134: error: expected ')' before '&' token
glxext.c: In function '__glXFreeDisplayPrivate':
glxext.c:187: warning: implicit declaration of function 'FreeScreenConfigs'
glxext.c: In function '__glXInitialize':
glxext.c:653: error: 'XExtDisplayInfo' undeclared (first use in this function)
glxext.c:653: error: 'info' undeclared (first use in this function)
glxext.c:653: warning: implicit declaration of function '__glXFindDisplay'
glxext.c:677: warning: implicit declaration of function 'XextHasExtension'
glxext.c:680: warning: implicit declaration of function 'XMissingExtension'
gmake[2]: *** [glxext.o] Ошибка 1
gmake[2]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-7.4.4/src/glx/x11'
gmake[1]: *** [subdirs] Ошибка 1
gmake[1]: Leaving directory `/usr/ports/graphics/libGL/work/Mesa-7.4.4/src'
gmake: *** [default] Ошибка 1
*** Error code 1

Stop in /usr/ports/graphics/libGL.

Порты обновлены!
Подскажите как решить проблемку ?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Ошибка при установке mencoder

Непрочитанное сообщение hizel » 2011-01-21 15:51:19

Код: Выделить всё

pkg_version -vI | grep need
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
cubespace
мл. сержант
Сообщения: 114
Зарегистрирован: 2010-02-25 0:23:15

Re: Ошибка при установке mencoder

Непрочитанное сообщение cubespace » 2011-01-21 16:28:35

Код: Выделить всё

# pkg_version -vI | grep need
gio-fam-backend-2.20.5              <   needs updating (index has 2.22.4)
glib-2.20.5                         <   needs updating (index has 2.22.4)
help2man-1.36.4_3                   <   needs updating (index has 1.37.1)
libiconv-1.13.1                     <   needs updating (index has 1.13.1_1)
libslang2-2.1.4_1                   <   needs updating (index has 2.2.2)
libtool-2.2.6a                      <   needs updating (index has 2.2.6b)
mc-4.6.2                            <   needs updating (index has 4.7.0.2_1)
pcre-7.9                            <   needs updating (index has 8.00)
python26-2.6.2_3                    <   needs updating (index has 2.6.4)
ru-freebsd-doc-20090913             <   needs updating (index has 20100213)