portupgrade

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 15:25:14

Обновлял порты ....
pkg_version -v | grep "need"
список что нужно обновить ...
portupgrade sendmail
обновился ошибок не выдал .... НО после того как я запускаю снова pkg_version -v | grep "need" на месте в списке где был sendmail, пишет
pkg_version: Failed to get PKGNAME from /usr/potrs/sysutils//Makefile!


Что такое ??? в чем проблема ???

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35282
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: portupgrade

Непрочитанное сообщение Alex Keda » 2010-05-04 15:25:48

вы покажите чегоонтам вам показывает
а не своими словами
Убей их всех! Бог потом рассортирует...

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 15:29:20

Код: Выделить всё

freetype2-2.3.5                     <   needs updating (port has 2.3.11)
gd-2.0.35,1                         <   needs updating (port has 2.0.35_7,1)
gettext-0.16.1_3                    <   needs updating (port has 0.17_1)
glib-2.14.6                         <   needs updating (port has 2.22.4)
gmake-3.81_2                        <   needs updating (port has 3.81_3)
gnutls-2.2.2                        <   needs updating (port has 2.8.3)
help2man-1.36.4_1                   <   needs updating (port has 1.37.1_2)
isc-dhcp3-server-3.0.5_2            <   needs updating (port has 3.0.7_5)
javavmwrapper-2.3.2                 <   needs updating (port has 2.3.4)
jpeg-6b_4                           <   needs updating (port has 8_1)
libX11-1.2,1                        <   needs updating (port has 1.2.1_1,1)
libcheck-0.9.6                      <   needs updating (port has 0.9.8)
libgcrypt-1.4.4                     <   needs updating (port has 1.4.5)
libgmp-4.2.2                        <   needs updating (port has 4.3.2)
libgpg-error-1.6                    <   needs updating (port has 1.7)
libiconv-1.11_1                     <   needs updating (port has 1.13.1_1)
libpthread-stubs-0.1                <   needs updating (port has 0.3_3)
libslang-1.4.9                      <   needs updating (port has 2.2.2_1)
libspf2-1.2.5_3                     <   needs updating (port has 1.2.9_1)
libtool-1.5.24                      <   needs updating (port has 2.2.6b)
libxcb-1.2                          <   needs updating (port has 1.5)
libxml2-2.6.31                      <   needs updating (port has 2.7.6_2)
libxslt-1.1.24_2                    <   needs updating (port has 1.1.26)
lightsquid-1.7.1_1                  <   needs updating (port has 1.8_2)
linuxthreads-2.2.3_23               <   needs updating (port has 2.2.3_24)
m4-1.4.9,1                          <   needs updating (port has 1.4.14,1)
mc-4.6.1_6                          <   needs updating (port has 4.7.0.2_2)
mpd-5.1_1                           <   needs updating (port has 5.5)
mysql-client-5.0.51a                <   needs updating (port has 5.0.90)
mysql-server-5.0.51a                <   needs updating (port has 5.0.90)
p5-Compress-Raw-Zlib-2.021          <   needs updating (port has 2.024)
p5-GD-2.35_1                        <   needs updating (port has 2.44_2)
p5-URI-1.40                         <   needs updating (port has 1.54)
p5-gettext-1.05_1                   <   needs updating (port has 1.05_2)
p5-libwww-5.833                     <   needs updating (port has 5.834)
pcre-7.6                            <   needs updating (port has 8.02)
perl-5.8.8_1                        <   needs updating (port has 5.8.9_3)
php5-5.2.5_1                        <   needs updating (port has 5.3.2)
php5-mysql-5.2.5_1                  <   needs updating (port has 5.3.2)
php5-pcre-5.2.5_1                   <   needs updating (port has 5.3.2)
php5-session-5.2.5_1                <   needs updating (port has 5.3.2)
pkg-config-0.22_1                   <   needs updating (port has 0.23_1)
png-1.2.25                          <   needs updating (port has 1.4.1_1)
popt-1.7_4                          <   needs updating (port has 1.14)
portupgrade-2.4.3_2,2               <   needs updating (port has 2.4.6_4,2)
postfixadmin-2.1.0_7                <   needs updating (port has 2.3_1)
python25-2.5.4_1                    <   needs updating (port has 2.5.5)
rbldnsd-0.996b                      <   needs updating (port has 0.996b_1)
rsync-3.0.6                         <   needs updating (port has 3.0.7)
ruby-1.8.6.111_1,1                  <   needs updating (port has 1.8.7.248,1)
ruby18-bdb-0.6.2                    <   needs updating (port has 0.6.5_1)
pkg_version: Failed to get PKGNAME from /usr/ports/sysutils//Makefile!
squid-2.6.18                        <   needs updating (port has 2.7.8)
sudo-1.6.9.14                       <   needs updating (port has 1.7.2.6)
tiff-3.8.2_1                        <   needs updating (port has 3.9.2_1)
wget-1.11                           <   needs updating (port has 1.12)
xcb-proto-1.4                       <   needs updating (port has 1.6)
xproto-7.0.14                       <   needs updating (port has 7.0.15)
Последний раз редактировалось Alex Keda 2010-05-04 15:31:25, всего редактировалось 1 раз.
Причина: Товарищщи, цените чужое время, юзайте кнопочку [code]...

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 15:31:00

Надобыло ИСЧО сделать:

Код: Выделить всё

pkgdb -F
И не когда не прирывать в момент portupgrade!
Если прирывать то осторожная на нужных этапах...
Попробуйте сделать:

Код: Выделить всё

pkgdb -F
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 15:34:35

После запуска вот такая вот ИГра :)))

Код: Выделить всё

proxy# pkgdb -F
--->  Checking the package registry database
Stale origin: 'sysutils/': perhaps moved or obsoleted.
Skip this for now? [yes] yes
To skip it without asking in future, please list it in HOLD_PKGS.
Stale origin: 'mail/oborona@yandex-team.ru': perhaps moved or obsoleted.
Skip this for now? [yes] yes
To skip it without asking in future, please list it in HOLD_PKGS.
Stale origin: 'mail/spamooborona-data': perhaps moved or obsoleted.
Skip this for now? [yes] no
Browse CVSweb for the port's history? [no] no
Guessing... no idea.
Not in due form <category/portname>:
Fixed. (-> mail/spamooborona-data)
Stale origin: 'mail/spamooborona_daemon': perhaps moved or obsoleted.
Skip this for now? [yes] yes
To skip it without asking in future, please list it in HOLD_PKGS.
Stale origin: 'sysutils/spamooborona_perllib': perhaps moved or obsoleted.
Skip this for now? [yes] no
Browse CVSweb for the port's history? [no] no
Guessing... no idea.
Not in due form <category/portname>:
Fixed. (-> sysutils/spamooborona_perllib)
Stale origin: 'sysutils/spamooborona_wmi': perhaps moved or obsoleted.
Skip this for now? [yes] no
Browse CVSweb for the port's history? [no] ^Z
Suspended

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 15:41:52

Вы-ж sendmail обновляли?
Проверти в пакетах он есть?

Код: Выделить всё

pkg_info | grep sendmail
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 15:43:27

Да все есть !!!!!

Код: Выделить всё

proxy# pkg_info | grep sendmail
sendmail-8.14.4_2   Reliable, highly configurable mail transfer agent with util

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 15:53:25

Замечательно...
Ну а что показывает:

Код: Выделить всё

pkg_version -v | grep "need"
Нормально? Или косяк остался?
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 15:57:43

нет косяк остался .......

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 16:00:44

vaskocuturilo писал(а):нет косяк остался .......
а как он говорит?
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 16:01:25

Да все так же и говорит !!!

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 16:10:45

vaskocuturilo писал(а):Да все так же и говорит !!!
Ну попробуйте, повтороно csup или cvsup обновить порты, затем посмотрите нужно ли апгрейдеть?
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-04 16:23:28

НЕ ВОПРОС !!!! ОПРОБУЮ ОТПИШУЬС СПАСИБО

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-04 16:30:31

vaskocuturilo писал(а):НЕ ВОПРОС !!!! ОПРОБУЮ ОТПИШУЬС СПАСИБО
Всегда пожалуйста!
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-05 11:55:55

Обновил порты .... И все равно, ошибка лезет обновит cvsup он без проблем обновился и не ругается а вот sendmail ругается

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-05 17:31:02

vaskocuturilo писал(а):Обновил порты .... И все равно, ошибка лезет обновит cvsup он без проблем обновился и не ругается а вот sendmail ругается
Как именно ругается?
Только при провреки версии?
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
vaskocuturilo
мл. сержант
Сообщения: 147
Зарегистрирован: 2009-09-21 9:06:43
Откуда: Архангельск
Контактная информация:

Re: portupgrade

Непрочитанное сообщение vaskocuturilo » 2010-05-05 18:52:18

Ругается так же ...
Да только при проверке

Аватара пользователя
fox
ст. лейтенант
Сообщения: 1154
Зарегистрирован: 2008-07-24 0:25:31
Откуда: Ukraine, Donetsk

Re: portupgrade

Непрочитанное сообщение fox » 2010-05-05 19:00:26

vaskocuturilo писал(а):Ругается так же ...
Да только при проверке
Так-же, как-же...
Ребят, Вы пишите пост, люди вам пытаются помочь, пожалусто делайте пост понятным, с сабжем, логами...
Я как то раз сам писал пост, и красиво оформил его, а когда перечитывал то заметил где сам набочил!
Убедительно прошу делайте понятными посты, а то по прибегают некоторые и начнут писать Go google.com...
Пожалусто, делайте наглядным пост!

А теперь по делу, покажите мне:

Код: Выделить всё

pkg_version -v | grep sendmail
Да пребудет с нами сила!!!
Всех убью, один останусь!

Аватара пользователя
MASiK
лейтенант
Сообщения: 625
Зарегистрирован: 2008-09-19 20:09:41
Откуда: Оттуда
Контактная информация:

Re: portupgrade

Непрочитанное сообщение MASiK » 2010-05-26 13:44:08

Была такая штука, дело в том что он не может найти переменную Я сделал иначе:
добавил в /etc/make.conf

Код: Выделить всё

PKGNAME=&PORTNAME-&PORTVERSION
Но вот тока не уверен я в правильности этого Хитрого хода, так как не все же пакеты он так помечает, и где он вообще берёт эту переменную Остаётся загадкой...
Самурай