Вопросы по TouchPad'у

FreeBSD и прочие в роли десктопа.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-09 14:18:51

Здравствуйте.
Подскажите пожалуйста как увеличить скорость перемещения курсора TouchPad'а
и активизировать "джойстик" TouchPad'а
в Консоли и в Иксах.
OS FreeBSD 7.0, arch=amd64

"джойстик" TouchPad'а - одна кнопка с четырьмя направляющими( вверх, вниз, вправо,влево ).
Активизировать "джойстик" TouchPad'а, например для вертикальной и горизонтальной прокрутки.

Курсор у меня движется очень медленно - по 1/4 экрана, то есть необходимо 4 раза шеркнуть
пальцем по TouchPad'у чтобы переместить курсор с одного конца экрана на другой.
Немного утомляет.

Какие меры предпринимались:
  • в файле /etc/rc.conf
    moused_type="glidepoint"
    moused_flags="-r high -z 4 5 6 7 -w 6"

    а также

    в файле /etc/X11/xorg.conf
    Section "InputDevice"
    ...
    Option "Buttons" "6"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection
Я не совсем понимаю откуда берётся "4 5 6 7" ?
Как узнать какие у меня должны быть ?
xev говорит, что влево и вправо - кнопка номер 2,
а вверх и вниз - типа это вообще не кнопки, в смысле информации о них не выводит.

Option "Buttons" "6", а также
moused_flags="-w 6"
Это количество кнопок - по моим соображениям их 6( левая, правая и 4 на джойстике ).
Может ошибаюсь, может ещё что-то за кнопки считается, ведь почему-то "4 5 6 7" ?

Заранее большое спасибо.
_____________________________
С наилучшими пожеланиями,
Monarh

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Вопросы по TouchPad'у

Непрочитанное сообщение paradox » 2009-04-09 14:36:38

а что а бук и какой тачпад?
и откуда ты взял это
moused_type="glidepoint"

у меня к примеру джойстик во все направления двигаеться
а у тебя токо 4 степени свободы
маловато

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-09 15:22:30

Ноутбук Acer Aspire 7520,
TouchPad, я даже не знаю как объяснить, если имеется в виду его вид :smile:
то сверху сенсорное поле( или как там его назвать ),
под этим "полем" по середине джойстик, по бокам от джойстика левая и правая кнопки, слева и справа соответственно.
paradox писал(а): и откуда ты взял это
Monarh писал(а):moused_type="glidepoint"
На ноуте предустановленная виста
В диспечере оборудования определилось как
"Мыши и иные указывающие устройства" - "Alps Pointing-device"

man moused говорит:
Есть тип протокола ALPS GlidePoint protocol
в параметрах обозначать как glidepoint.
Консоль замечательно работает с этим параметром, а вот Иксы нет.
Когда в Иксах начинаешь дёргать мышку за хвостик, то она забивается в левый верхний угол и дрожжит :smile:
Это при
  • Option "Protocol" "glidepoint"
может параметры надо подкорректировать, а
при
  • Option "Protocol" "auto"
нормально работает.
И кстати как задать в xorg.conf параметр resolution ?
Где можно найти файл всех возможных параметров для xorg.conf ?
В /etc/defaults он отсутствует.
paradox писал(а): у меня к примеру джойстик во все направления двигаеться
а у тебя токо 4 степени свободы
Возможно можно ещё и в углы понажимать.
Как задействовать весь потенциал джойстика ?
_____________________________
С наилучшими пожеланиями,
Monarh

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Вопросы по TouchPad'у

Непрочитанное сообщение paradox » 2009-04-09 15:45:59

ну у нас наверное разное понимания джойстика )))
у меня он используеться как раз для управления мыши
у него полная свобода

а у тебя он какойто странный

резолюшин помоему в man moused были
хотя если ты говоришьв консоли нормально все со скоростью
то тогда в xorg.conf нужно менять

кстати покажи всю секцию по мише в xorg.conf
что там за девайс? /dev/ ?? sysmouse я надеюсь

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-09 16:40:03

paradox писал(а):ну у нас наверное разное понимания джойстика )))
у меня он используеться как раз для управления мыши
у него полная свобода
А у меня для управления мышью панелька сенсорная есть :smile:
а "джойстик" как замена двум колёсикам используется,
тобишь для скроллинга по вертикали и по горизонтали.
Можно сказать кнопка с четырьмя направляющими.
Вот такой видок
TouchPad.jpg
paradox писал(а):резолюшин помоему в man moused были
да там говорится так
  • -r resolution
    где resolution = low, medium-low, medium-high или high.
Но непонятно как его в xorg.conf отобразить.
Так что-ли:
  • Option "Resolution" "high"
paradox писал(а):хотя если ты говоришь в консоли нормально все со скоростью
Я так не говорил.
Я сказал, что с параметром "glidepoint" в консоли нормально работает.
У меня и в консоли точно также курсор медленно ползает.
paradox писал(а):покажи всю секцию по мише в xorg.conf

Код: Выделить всё

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
#       Option          "Protocol"      "glidepoint"
        Option          "Protocol"      "auto"
        Option          "Device"        "/dev/sysmouse"
        Option          "Resolution"    "high"
        Option          "Buttons"       "6"
        Option          "ZAxisMapping"  "4 5 6 7"
EndSection
И ему по-моему вообще без разницы "Resolution" "high" или "Resolution" "low".
Или я не правильно параметр указал "Resolution", может как-то по-другому или
как написано в man moused, что не все девайсы могут поддерживать эту опцию.
Последний раз редактировалось Monarh 2009-05-11 17:28:52, всего редактировалось 2 раза.
_____________________________
С наилучшими пожеланиями,
Monarh

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Вопросы по TouchPad'у

Непрочитанное сообщение paradox » 2009-04-09 17:02:12

А у меня для управления мышью панелька сенсорная есть
а "джойстик" как замена двум колёсикам используется,
тобишь для скроллинга по вертикали и по горизонтали.
Можно сказать кнопка с четырьмя направляющими
ааа
тю
а я думал у тебя джойстик как у меня - полноценный мишь

что то беглый гугул дал результат что у многих с мышиным протоколом ALPS - проблемы
и вроде даже у линухоидов...
надо дальше гуглить искать

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Alex Keda » 2009-04-09 23:13:37

Код: Выделить всё

hw.psm.synaptics_support=1
в бут.лоадер.конф
для начала.
у меня работало, но ноутбук тот кончился, и уже не скажу.
можо ппопроовать поискать мои конфиги иксов по форуму - там всё есть.
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-25 14:33:41

Конфиги иксов искал по форуму - не нашёл !!!
Поискал по инету, много чего почитал, много чего перепробовал ничего не помогает, всё время одно и то же:
  • Не может открыть устройство /dev/psm0. Устройство занято.
Даже при отключенном мышином демоне( moused ).

Содержимое xorg.conf

Код: Выделить всё

Section "ServerLayout"
        ...
        InputDevice     "TouchPad"
        ...
EndSection
...
Section "InputDevice"
        Identifier      "TouchPad"
        Driver          "synaptics"
        Option          "CorePointer"
        Option          "Device"                "/dev/psm0"
        Option          "Protocol"              "alps"
        Option          "LeftEdge"              "130"
        Option          "RightEdge"             "840"
        Option          "TopEdge"               "130"
        Option          "BottomEdge"            "640"
        Option          "FingerLow"             "7"
        Option          "FingerHigh"            "8"
        Option          "MaxTapTime"            "180"
        Option          "MaxTapMove"            "110"
        Option          "EmulateMidButtonTime"  "75"
        Option          "VertScrollDelta"       "20"
        Option          "HorizScrollDelta"      "20"
        Option          "MinSpeed"              "0.25"
        Option          "MaxSpeed"              "0.50"
        Option          "AccelFactor"           "0.010"
        Option          "EdgeMotionMinSpeed"    "200"
        Option          "EdgeMotionMaxSpeed"    "200"
        Option          "UpDownScrolling"       "1"
        Option          "CircularScrolling"     "1"
        Option          "CircScrollDelta"       "0.1"
        Option          "CircScrollTrigger"     "2"
        Option          "SHMConfig"             "on"
        Option          "Emulate3Buttons"       "on"
EndSection
...
Может кто чего подскажет ?
Заранее большое спасибо.
Последний раз редактировалось Monarh 2009-04-26 8:41:58, всего редактировалось 1 раз.
_____________________________
С наилучшими пожеланиями,
Monarh

Аватара пользователя
Hazzard
сержант
Сообщения: 265
Зарегистрирован: 2009-02-01 21:22:36
Откуда: Москва
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Hazzard » 2009-04-25 17:55:29

lissyara писал(а):

Код: Выделить всё

hw.psm.synaptics_support=1
в бут.лоадер.конф
для начала.
у меня работало, но ноутбук тот кончился, и уже не скажу.
можо ппопроовать поискать мои конфиги иксов по форуму - там всё есть.
на toshiba l300-129 это помогло на полную включить тачпад (собственнно тачпад и 2 кнопки, всё работает на ура)
Debian, php/mysql и другой бред...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Alex Keda » 2009-04-25 21:03:47

тогда ковыряйте драйвер - все опции что использовал я выковырнул оттуда.
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-26 8:41:05

Hazzard писал(а):
lissyara писал(а):

Код: Выделить всё

hw.psm.synaptics_support=1
в бут.лоадер.конф
...
на toshiba l300-129 это помогло на полную включить тачпад (собственнно тачпад и 2 кнопки, всё работает на ура)
в boot/loader.conf у меня эта строчка прописана !!!
Курсорчик-то у меня тоже ползает, правда еле-еле, что очень напрягает( ширину экрана за 4 возюкания пальцем по тачпаду ), а также левая и правая кнопки работают.
У меня проблема со скоростью движения курсора и прокрутки не работают( средняя кнопка, между левой и правой, на тачпаде, которая имеет четыре направляющие( влево, вправо, вверх и вниз ) и отвечает за прокрутки ) !!!
lissyara писал(а):тогда ковыряйте драйвер - все опции что использовал я выковырнул оттуда.
При загрузке Иксов он пишет Устройство /dev/psm0 занято.
И как я понимаю он ТачПад'овскую секцию в xorg.conf игнорирует поскольку не смог использовать устройство !!?
Поскольку какие опции не выставляй, по-моему, ничего не меняется !!?

Хотя вот что странно курсорчик-то двигается !!!

И ещё, synclient говорит, что мой тачпад - подключаемое устройство (guest device)
и его параметры - x, y, z, f, w, l,r,u,d,m,multi и gm всё время по нулям,
меняются лишь координаты пальца на тачпаде - gdx и gdy, а также gl и gr при нажатии левой и правой кнопок соответственно.
При нажатии на любую из направляющих средней кнопки - реакции никакой.

Может кто подскажет почему мой тачпад определяется как подключаемое устройство, а не как родное и как это исправить,
возможно всё дело в этом ?
_____________________________
С наилучшими пожеланиями,
Monarh

Аватара пользователя
Hazzard
сержант
Сообщения: 265
Зарегистрирован: 2009-02-01 21:22:36
Откуда: Москва
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Hazzard » 2009-04-26 18:17:22

Monarh писал(а): Может кто подскажет почему мой тачпад определяется как подключаемое устройство, а не как родное и как это исправить,
возможно всё дело в этом ?
просто может тачпад в юсб втыкается на мамке?
Debian, php/mysql и другой бред...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Alex Keda » 2009-04-26 18:40:18

изврат какой-то =)
Убей их всех! Бог потом рассортирует...

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Вопросы по TouchPad'у

Непрочитанное сообщение paradox » 2009-04-26 18:49:57

все крутите вертите
ты определись скоко у тебя физических устройств??
одно или много
dmesg -a
usbdevs -v
если уже moused юзает psm0 то он предоставляет для достпа sysmouse
который в иксах и нужно юзать
в исках тютинг тот что ты делаешь если делаеться через sysmouse то должен быть доступен через moused

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-04-27 6:04:37

Hazzard писал(а):
Monarh писал(а): Может кто подскажет почему мой тачпад определяется как подключаемое устройство, а не как родное и как это исправить,
возможно всё дело в этом ?
просто может тачпад в юсб втыкается на мамке?
Теоретически должно быть PS/2, а практически - кто бы знал :smile:
lissyara писал(а):изврат какой-то =)
Согласен, но разобраться с ним - это уже дело принципа :smile:
paradox писал(а):если уже moused юзает psm0 то он предоставляет для достпа sysmouse
который в иксах и нужно юзать
в исках тютинг тот что ты делаешь если делаеться через sysmouse то должен быть доступен через moused
Можно ли использовать moused и тачпад одновременно ?
Я так понимаю, что для тачпада специально написан "драйвер" - synaptics
и с помощью него и нужно прикручивать тачпад,
но, как я понимаю, при использовании synaptics надо отрубать moused ?
Правильно ли я понимаю ?
Если можно с помощью moused прикрутить тачпад, то как ? ТачПад у меня - ALPS Glidepoint.
Если только с помощью synaptics, то как можно сделать, чтобы и в консоли грызуна использовать можно было
и в иксах все настройки можно было нормально сделать, то есть скорость поползновений грызуна увеличить и прокрутки нормально реализовать ?
paradox писал(а):все крутите вертите
ты определись скоко у тебя физических устройств??
одно или много
Смотря какие устройства имеются в виду, если имеются в виду грызуны, то я использую только тачпад,
других грызунов нету - ни usb ни каких либо других.

dmesg -a

Код: Выделить всё

Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-RELEASE #3: Tue Apr 28 12:39:18 NOVST 2009
    root@Roman.cn.ru:/usr/obj/usr/src/sys/KERNEL_TURION_64_X2
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Turion(tm) 64 X2 Mobile Technology TL-66 (2300.32-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x60f81  Stepping = 1
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x11f<LAHF,CMP,SVM,ExtAPIC,CR8,Prefetch>
  Cores per package: 2
usable memory = 2133127168 (2034 MB)
avail memory  = 2058395648 (1963 MB)
ACPI APIC Table: <PTLTD          APIC  >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0 <Version 1.1> irqs 0-23 on motherboard
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Apr 28 2009 12:39:09)
acpi0: <ACRSYS ACRPRDCT> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x10> port 0x62,0x66 on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 25000000 Hz quality 900
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
powernow0: <PowerNow! K8> on cpu0
cpu1: <ACPI CPU> on acpi0
powernow1: <PowerNow! K8> on cpu1
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory, RAM> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> port 0x1d00-0x1dff at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
pci0: <memory, RAM> at device 1.2 (no driver attached)
pci0: <processor> at device 1.3 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xf0686000-0xf0686fff irq 21 at device 2.0 on pci0
ohci0: [GIANT-LOCKED]
ohci0: [ITHREAD]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: <nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 5 ports with 5 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xf0689000-0xf06890ff irq 22 at device 2.1 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb1: EHCI version 1.0
usb1: companion controller, 12 ports each: usb0
usb1: <EHCI (generic) USB 2.0 controller> on ehci0
usb1: USB revision 2.0
uhub1: <nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb1
uhub1: 5 ports with 5 removable, self powered
ugen0: <SuYin Acer CrystalEye webcam, class 239/2, rev 2.00/1.00, addr 2> on uhub1
ohci1: <OHCI (generic) USB controller> mem 0xf0687000-0xf0687fff irq 23 at device 4.0 on pci0
ohci1: [GIANT-LOCKED]
ohci1: [ITHREAD]
usb2: OHCI version 1.0, legacy support
usb2: <OHCI (generic) USB controller> on ohci1
usb2: USB revision 1.0
uhub2: <nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 5 ports with 5 removable, self powered
ehci1: <EHCI (generic) USB 2.0 controller> mem 0xf0689400-0xf06894ff irq 20 at device 4.1 on pci0
ehci1: [GIANT-LOCKED]
ehci1: [ITHREAD]
usb3: EHCI version 1.0
usb3: companion controller, 12 ports each: usb2
usb3: <EHCI (generic) USB 2.0 controller> on ehci1
usb3: USB revision 2.0
uhub3: <nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb3
uhub3: 5 ports with 5 removable, self powered
atapci0: <nVidia nForce MCP67 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x30c0-0x30cf at device 6.0 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
pcm0: <NVidia MCP67 High Definition Audio Controller> mem 0xf0680000-0xf0683fff irq 21 at device 7.0 on pci0
pcm0: [ITHREAD]
pcib1: <ACPI PCI-PCI bridge> at device 8.0 on pci0
pci_link0: BIOS IRQ 10 for 1.4.INTA is invalid
pci1: <ACPI PCI bus> on pcib1
fwohci0: <1394 Open Host Controller Interface> mem 0xf0300000-0xf03007ff irq 11 at device 4.0 on pci1
fwohci0: [FILTER]
fwohci0: OHCI version 1.0 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:02:3f:79:c5:00:22:8b
fwohci0: Phy 1394a available S400, 1 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
pci1: <base peripheral> at device 4.1 (no driver attached)
pci1: <base peripheral> at device 4.2 (no driver attached)
pci1: <base peripheral> at device 4.3 (no driver attached)
pci1: <base peripheral> at device 4.4 (no driver attached)
atapci1: <nVidia ATA controller> port 0x30f0-0x30f7,0x30e4-0x30e7,0x30e8-0x30ef,0x30e0-0x30e3,0x30d0-0x30df mem 0xf0684000-0xf0685fff irq 22 at device 9.0 on pci0
atapci1: [ITHREAD]
ata2: <ATA channel 0> on atapci1
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci1
ata3: [ITHREAD]
nfe0: <NVIDIA nForce MCP67 Networking Adapter> port 0x30f8-0x30ff mem 0xf0688000-0xf0688fff,0xf0689c00-0xf0689cff,0xf0689800-0xf068980f irq 23 at device 10.0 on pci0
miibus0: <MII bus> on nfe0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
nfe0: Ethernet address: 00:1b:38:53:ae:df
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
nfe0: [FILTER]
pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci2: <ACPI PCI bus> on pcib2
vgapci0: <VGA-compatible display> port 0x4000-0x407f mem 0xce000000-0xceffffff,0xd0000000-0xdfffffff,0xcc000000-0xcdffffff irq 17 at device 0.0 on pci2
pcib3: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci3: <ACPI PCI bus> on pcib3
atapci2: <JMicron AHCI controller> port 0x50f8-0x50ff,0x50dc-0x50df,0x50f0-0x50f7,0x50d8-0x50db,0x50e0-0x50ef mem 0xf0000000-0xf0001fff at device 0.0 on pci3
atapci2: [ITHREAD]
atapci2: AHCI Version 01.00 controller with 1 ports detected
ata4: <ATA channel 0> on atapci2
ata4: [ITHREAD]
pcib4: <ACPI PCI-PCI bridge> at device 13.0 on pci0
pci5: <ACPI PCI bus> on pcib4
ath0: <Atheros 5424/2424> mem 0xf0200000-0xf020ffff irq 19 at device 0.0 on pci5
ath0: [ITHREAD]
ath0: unable to attach hardware; HAL status 13
device_attach: ath0 attach returned 6
acpi_button1: <Power Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_ec0: EcRead: failed waiting to get data
ACPI Exception (evregion-0529): AE_NO_HARDWARE_RESPONSE, Returned by Handler for [EmbeddedControl] [20070320]
ACPI Error (psparse-0626): Method parse/execution failed [\\_SB_.PCI0.LPC0.ECOK] (Node 0xffffff00011bea60), AE_NO_HARDWARE_RESPONSE
ACPI Error (psparse-0626): Method parse/execution failed [\\_TZ_.THRM._CRT] (Node 0xffffff00011c7c00), AE_NO_HARDWARE_RESPONSE
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model GlidePoint, device ID 0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio0: [FILTER]
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
module_register_init: MOD_LOAD (fire_saver, 0xffffffff80c95000, 0) error 19
ipfw2 (+ipv6) initialized, divert enabled, rule-based forwarding enabled, default to accept, logging limited to 100 packets/entry by default
hptrr: no controller detected.
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
acd0: DVDR <Optiarc DVD RW AD-7560A/DX06> at ata0-master UDMA33
ad4: 152627MB <WDC WD1600BEVS-22RST0 04.01G04> at ata2-master UDMA33
ad5: 152627MB <WDC WD1600BEVS-22RST0 04.01G04> at ata2-slave UDMA33
ad8: 715404MB <WDC WD7500AACS-65D6B0 01.01A01> at ata4-master SATA150
pcm0: <HDA Codec: Realtek ALC268>
pcm0: <HDA Driver Revision: 20071129_0050>
SMP: AP CPU #1 Launched!
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 
GEOM_LABEL: Label for provider acd0 is iso9660/NEW.
GEOM_LABEL: Label for provider ad4s1 is ntfs/PQSERVICE.
GEOM_LABEL: Label for provider ad4s2 is ntfs/ACER.
GEOM_LABEL: Label for provider ad4s3 is ntfs/PROGRAM.
GEOM_LABEL: Label for provider ad8s1 is ntfs/ROMAN.
Trying to mount root from ufs:/dev/ad5s1a
Loading configuration files.
kernel dumps on /dev/ad5s1b
Entropy harvesting:
 interrupts
 ethernet
 point_to_point
 kickstart
.
swapon: adding /dev/ad5s1b as swap device
Starting file system checks:
/dev/ad5s1a: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s1a: clean, 341945 free (1081 frags, 42608 blocks, 0.2% fragmentation)
/dev/ad5s3d: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s3d: clean, 2539659 free (99 frags, 317445 blocks, 0.0% fragmentation)
/dev/ad5s4d: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s4d: clean, 3141554 free (53458 frags, 386012 blocks, 1.1% fragmentation)
/dev/ad5s4f: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s4f: clean, 5077077 free (21 frags, 634632 blocks, 0.0% fragmentation)
/dev/ad5s4g: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s4g: clean, 51927367 free (383 frags, 6490873 blocks, 0.0% fragmentation)
/dev/ad5s4e: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s4e: clean, 4196313 free (8545 frags, 523471 blocks, 0.2% fragmentation)
/dev/ad5s2d: FILE SYSTEM CLEAN; SKIPPING CHECKS
/dev/ad5s2d: clean, 2447070 free (926 frags, 305768 blocks, 0.0% fragmentation)
Setting hostuuid: 66303861-3536-6335-6635-001b3853aedf.
Setting hostid: 0xe7fa4f87.
Mounting local file systems:
.
Setting hostname: Roman.cn.ru.
net.inet.ip.fw.verbose_limit: 
100
 -> 
10

hw.syscons.bell: 
1
 -> 
0

kern.ipc.shmmax: 
33554432
 -> 
67108864

kern.ipc.shmall: 
8192
 -> 
32768

nfe0: no link ...
.
 got link
DHCPREQUEST on nfe0 to 255.255.255.255 port 67

DHCPACK from 192.168.1.1

bound to 192.168.1.100 -- renewal in 3600 seconds.

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 ::1 prefixlen 128 
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
        inet 127.0.0.1 netmask 0xff000000 
nfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 00:1b:38:53:ae:df
        inet6 fe80::21b:38ff:fe53:aedf%nfe0 prefixlen 64 scopeid 0x1 
        inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
Additional routing options:
.
add net ::ffff:0.0.0.0: gateway ::1
add net ::0.0.0.0: gateway ::1
net.inet6.ip6.forwarding: 
0
 -> 
0

net.inet6.ip6.accept_rtadv: 
0
 -> 
1

add net fe80::: gateway ::1
add net ff02::: gateway ::1
IPv4 mapped IPv6 address support=NO
Starting devd.
hw.acpi.cpu.cx_lowest: 
C1
 -> 
C1

Additional IP options:
.
Mounting NFS file systems:
.
ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib /usr/local/lib/compat/pkg /usr/local/lib/compat/pkg /usr/local/lib/kde3 /usr/local/lib/nss /usr/local/lib/qt4
32-bit compatibility ldconfig path: /usr/lib32
Clearing /tmp (X related).
Creating and/or trimming log files:
.
Starting syslogd.
Checking for core dump on /dev/ad5s1b...
savecore: no dumps found
Initial amd64 initialization:
.
Additional ABI support:
.
Starting default moused:
moused: 
mouse type mismatch (ps/2 != glidepoint), ps/2 is assumed

.
Starting local daemons:
.
Updating motd
.
Mounting late file systems:
.
Configuring syscons:
 keymap
 scrnmap
 font8x16
 blanktime
 allscreens
.
Starting cron.
Local package initialization:
.
mixer: 
unknown recording device: mic

Starting background file system checks in 60 seconds.

Tue Apr 28 12:54:13 NOVST 2009
Apr 28 13:02:06 Roman login: ROOT LOGIN (root) ON ttyv1
usbdevs -v

Код: Выделить всё

Controller /dev/usb0:
addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), nVidia(0x0000), rev 1.00
 port 1 powered
 port 2 powered
 port 3 powered
 port 4 powered
 port 5 powered
Controller /dev/usb1:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), nVidia(0x0000), rev 1.00
 port 1 powered
 port 2 powered
 port 3 addr 2: high speed, power 500 mA, config 1, Acer CrystalEye webcam(0xa101), SuYin(0x064e), rev 1.00
 port 4 powered
 port 5 powered
Controller /dev/usb2:
addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), nVidia(0x0000), rev 1.00
 port 1 powered
 port 2 powered
 port 3 powered
 port 4 powered
 port 5 powered
Controller /dev/usb3:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), nVidia(0x0000), rev 1.00
 port 1 powered
 port 2 powered
 port 3 powered
 port 4 powered
 port 5 powered
Заранее всем большое спасибо.
_____________________________
С наилучшими пожеланиями,
Monarh

Аватара пользователя
Monarh
ефрейтор
Сообщения: 66
Зарегистрирован: 2009-04-03 10:48:20

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Monarh » 2009-05-11 17:32:42

Скорость движения курсора подкорректировал при помощи хинтов для psm0:

Добавил в /boot/device.hints

Код: Выделить всё

hint.psm.0.flags="0x14"
В результате и в консоли и в Иксах курсорчик быстрее начал бегать весь ЭКРАН за ОДНО возюкание :smile:
Может кто подскажет всё-таки как реализовать прокрутку на тачпаде.
И как вообще разобраться с клавишей с четырьмя направляющими,
отвечающими, как раз, за прокрутки по вертикали и горизонтали,
если xev говорит, что влево и вправо - одна клавиша под номером 2,
а на вверх и вниз - вообще НОЛЬ эмоций, как-будто я пальцем по столу тыкаю, а не по кнопкам на тачпаде :smile:

Заранее всем большое спасибо.
_____________________________
С наилучшими пожеланиями,
Monarh

Аватара пользователя
cool-bmb
мл. сержант
Сообщения: 76
Зарегистрирован: 2009-05-15 17:40:53
Откуда: Дербент
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение cool-bmb » 2009-09-19 18:50:33

вот как у меня

Код: Выделить всё

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "Buttons" "6"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Код: Выделить всё

moused_port="/dev/psm0"
moused_type="auto"
moused_enable="YES"
ну и про то что выше говорил лис hw.psm.synaptics_support=1
и все :smile:
Последний раз редактировалось paradox 2009-09-19 19:00:07, всего редактировалось 1 раз.
Причина: и ты хочешь сказать что ты исправился? как не использовал теги так и не используешь
Даги вот она сила

Василий
проходил мимо

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Василий » 2011-01-12 13:14:42

Здравствуйте! У меня вопрос по touch pad'у

В общем, проблема в том, что при нажатии и удержании любой кнопки клавиатуры курсор больше не двигается. Чтобы он ожил, нужно обязательно отпустить кнопку.
В безопасном режиме такой проблемы нету. До этого стояла виста, на ней такой проблемы не было, а щас поставил 7.
Что можете посоветовать?

Аватара пользователя
Gamerman
капитан
Сообщения: 1723
Зарегистрирован: 2009-05-17 21:01:23
Откуда: Украина, Ужгород - Днепр
Контактная информация:

Re: Вопросы по TouchPad'у

Непрочитанное сообщение Gamerman » 2011-01-12 13:18:57

7-ка уже стала Unix? :shock:
Глюк глюком вышибают!