X: (EE) RADEON(0): No valid MMIO address

FreeBSD и прочие в роли десктопа.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
maxd
проходил мимо
Сообщения: 9
Зарегистрирован: 2009-07-02 14:16:01
Откуда: Великий Новгород
Контактная информация:

X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение maxd » 2009-08-02 13:14:35

Несколько месяцев назад поставил на ноут (hp nx9420) freebsd 7.0. Поставил X и kde3 из пакетов. Версию иксов не помню, но все встало четко. Сейчас решил все снести и поставить заново иксы и 4-е кеды. Систему не обновлял. Делаем:

Код: Выделить всё

pkg_delete -a
set PACKAGESITE=ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7-stable/All/
pkg_add -r xorg
rehash
X -configure
X -config /root/xorg.conf.new
Не заводится. Получаем эррор. Лог:

Код: Выделить всё

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/snk.workgroup:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 7.2-PRERELEASE i386 
Current Operating System: FreeBSD snk.workgroup 7.0-RELEASE FreeBSD 7.0-RELEASE #7: Thu May  7 00:01:59 MSD 2009     root@snk.workgroup:/usr/obj/usr/src/sys/hp i386
Build Date: 20 July 2009  04:57:05PM
 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug  1 20:48:36 2009
(++) Using config file: "/root/xorg.conf.new"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
	/usr/local/lib/X11/fonts/misc/,
	/usr/local/lib/X11/fonts/TTF/,
	/usr/local/lib/X11/fonts/OTF,
	/usr/local/lib/X11/fonts/Type1/,
	/usr/local/lib/X11/fonts/100dpi/,
	/usr/local/lib/X11/fonts/75dpi/,
	/usr/local/lib/X11/fonts/misc/,
	/usr/local/lib/X11/fonts/TTF/,
	/usr/local/lib/X11/fonts/OTF,
	/usr/local/lib/X11/fonts/Type1/,
	/usr/local/lib/X11/fonts/100dpi/,
	/usr/local/lib/X11/fonts/75dpi/,
	built-ins
(**) ModulePath set to "/usr/local/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x7a0
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 5.0
	X.Org XInput driver : 4.0
	X.Org Server Extension : 2.0
(II) Loader running on freebsd
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0@1:0:0) ATI Technologies Inc M56P [Radeon Mobility X1600] rev 0, BIOS @ 0x????????/65536
(II) System resource ranges:
	[0] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[1] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[2] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[3] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[4] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "dbe"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "dri"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(==) AIGLX disabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/local/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "radeon"
(II) Loading /usr/local/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
	compiled for 1.6.1, module version = 6.12.2
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 5.0
(II) RADEON: Driver for ATI Radeon chipsets:
# ---------------------- тут вырезал для уменьшения объема
	ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,
# ---------------------- тут вырезал для уменьшения объема
(II) Primary Device is: PCI 01@00:00:0
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[1] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[2] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[3] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[4] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) resource ranges after probing:
	[0] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[1] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[2] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[3] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B]
	[4] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B]
	[5] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B]
	[6] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[7] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[8] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
	[9] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) RADEON(0): TOTO SAYS 0000000000000000
(EE) RADEON(0): No valid MMIO address
(II) UnloadModule: "radeon"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
 
Конфиг:

Код: Выделить всё

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/local/lib/xorg/modules"
	FontPath     "/usr/local/lib/X11/fonts/misc/"
	FontPath     "/usr/local/lib/X11/fonts/TTF/"
	FontPath     "/usr/local/lib/X11/fonts/OTF"
	FontPath     "/usr/local/lib/X11/fonts/Type1/"
	FontPath     "/usr/local/lib/X11/fonts/100dpi/"
	FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "dri2"
	Load  "extmod"
	Load  "glx"
	Load  "record"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/sysmouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "Dac8Bit"            	# [<bool>]
        #Option     "BusType"            	# [<str>]
        #Option     "CPPIOMode"          	# [<bool>]
        #Option     "CPusecTimeout"      	# <i>
        #Option     "AGPMode"            	# <i>
        #Option     "AGPFastWrite"       	# [<bool>]
        #Option     "AGPSize"            	# <i>
        #Option     "GARTSize"           	# <i>
        #Option     "RingSize"           	# <i>
        #Option     "BufferSize"         	# <i>
        #Option     "EnableDepthMoves"   	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "NoBackBuffer"       	# [<bool>]
        #Option     "DMAForXv"           	# [<bool>]
        #Option     "FBTexPercent"       	# <i>
        #Option     "DepthBits"          	# <i>
        #Option     "PCIAPERSize"        	# <i>
        #Option     "AccelDFS"           	# [<bool>]
        #Option     "IgnoreEDID"         	# [<bool>]
        #Option     "DisplayPriority"    	# [<str>]
        #Option     "PanelSize"          	# [<str>]
        #Option     "ForceMinDotClock"   	# <freq>
        #Option     "ColorTiling"        	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "RageTheatreCrystal" 	# <i>
        #Option     "RageTheatreTunerPort" 	# <i>
        #Option     "RageTheatreCompositePort" 	# <i>
        #Option     "RageTheatreSVideoPort" 	# <i>
        #Option     "TunerType"          	# <i>
        #Option     "RageTheatreMicrocPath" 	# <str>
        #Option     "RageTheatreMicrocType" 	# <str>
        #Option     "ScalerWidth"        	# <i>
        #Option     "RenderAccel"        	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "DynamicClocks"      	# [<bool>]
        #Option     "VGAAccess"          	# [<bool>]
        #Option     "ReverseDDC"         	# [<bool>]
        #Option     "LVDSProbePLL"       	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI"                	# [<bool>]
        #Option     "ConnectorTable"     	# <str>
        #Option     "DefaultConnectorTable" 	# [<bool>]
        #Option     "DefaultTMDSPLL"     	# [<bool>]
        #Option     "TVDACLoadDetect"    	# [<bool>]
        #Option     "ForceTVOut"         	# [<bool>]
        #Option     "TVStandard"         	# <str>
        #Option     "IgnoreLidStatus"    	# [<bool>]
        #Option     "DefaultTVDACAdj"    	# [<bool>]
        #Option     "Int10"              	# [<bool>]
        #Option     "EXAVSync"           	# [<bool>]
        #Option     "ATOMTVOut"          	# [<bool>]
        #Option     "R4xxATOM"           	# [<bool>]
	Identifier  "Card0"
	Driver      "radeon"
	VendorName  "ATI Technologies Inc"
	BoardName   "M56P [Radeon Mobility X1600]"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Как полечить?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение paradox » 2009-08-02 14:05:36

наскоко я помню драйвера радеона постоянно обновляют
так что обновляйте версию исков
хотя я на вашем месте обновился сразу бы до bsd 8
там по ATI много изменений в ядре было насчет drm

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Alex Keda » 2009-08-02 19:03:06

без конфига заводиться?
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Neus
капитан
Сообщения: 1982
Зарегистрирован: 2008-09-08 21:59:56

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Neus » 2009-08-03 9:48:11

2 maxd
поставь в конфиге:

Код: Выделить всё

Driver "radeonhd"
и попробуй с ним

maxd
проходил мимо
Сообщения: 9
Зарегистрирован: 2009-07-02 14:16:01
Откуда: Великий Новгород
Контактная информация:

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение maxd » 2010-04-08 20:40:51

Уф, я тут потерялся ненадолго :roll:
Обновился до 8.0, иксы тоже обновил, теперь стартуют, но глючат. Запускаю кеды - курсор есть, но фон черный Заголовки окон есть, но содержимого нет. При перетаскивании окна остается шлейф этого окна (мозаика или артефакты, как это назвать). В Гноме тоже самое. Еще при тесте иксов меня смутило, что нет этой самой белой решетки, ну подумал фича, версия-то новая, может убрали. В гугле советовали опцию NoAccel On - с ней все прорисовывается нормально, но жутко тормозит.
С radeonhd вообще мрак... не работает в общем.
Рядом поставил пингвина openSUSE - там кеды, гномы пашут исправно.
Как бы фряху-то до ума довести все-таки?

Гость
проходил мимо

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Гость » 2010-04-08 20:59:23

приходите еще через год :-D когда пофиксят

Charlz_Klug_
проходил мимо

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Charlz_Klug_ » 2010-04-09 9:37:47

Эх, всем хороша Фряха, но только не в качестве десктопа.

Аватара пользователя
ed_butcher
мл. сержант
Сообщения: 70
Зарегистрирован: 2009-04-17 16:00:53
Откуда: Харьков-Киев

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение ed_butcher » 2010-04-09 9:49:47

Нормальный десктоп :smile: просто много нюансов нужно учитывать при поднятии, такие как соотв-е железо, прямые руки и необходимый уровень знаний!

Charlz_Klug_
проходил мимо

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Charlz_Klug_ » 2010-04-09 11:05:16

Интересно, а когда Фряха будет поддерживать винмодемы дайлапные из коробки?))) Софт должен поддерживать железо, а не железо поддерживать софт. © Каганов Л.

Аватара пользователя
hizel
дядя поня
Сообщения: 9032
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение hizel » 2010-04-09 11:15:25

драйвера должен писать производитель или давать спеки, компромэ?
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Гость
проходил мимо

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение Гость » 2010-04-09 11:19:03

фряха никому ничего не должна
есть производители железа, пусть они и поддерживают

представте ситуацию
вы стоите на рынке и продаете восковые свечи
я у вас покупаю
а потом прихожу и делаю претензию с криком, почему при подключении електричества ваши свечи не горят!
а вы делая круглые выпученые глаза :crazy: отвечаете
что мол свечи вообще не ваши!

мимо проходил
проходил мимо

Re: X: (EE) RADEON(0): No valid MMIO address

Непрочитанное сообщение мимо проходил » 2010-04-09 14:24:46

maxd писал(а):Уф, я тут потерялся ненадолго :roll:
Обновился до 8.0, иксы тоже обновил, теперь стартуют, но глючат. Запускаю кеды - курсор есть, но фон черный Заголовки окон есть, но содержимого нет. При перетаскивании окна остается шлейф этого окна (мозаика или артефакты, как это назвать). В Гноме тоже самое. Еще при тесте иксов меня смутило, что нет этой самой белой решетки, ну подумал фича, версия-то новая, может убрали. В гугле советовали опцию NoAccel On - с ней все прорисовывается нормально, но жутко тормозит.
С radeonhd вообще мрак... не работает в общем.
Рядом поставил пингвина openSUSE - там кеды, гномы пашут исправно.
Как бы фряху-то до ума довести все-таки?
Знакомая штука, если ставить 7.2 RELEASE c DVD, эта видюха будет работать на ура и не дай бог портапгрейд делать.
в 8.0 не смог завести, поменял на GF6600 вот тут телодвижения -> http://www.bsdportal.ru/viewtopic.php?t=21442
Или работать с VESA.